Community
cancel
Showing results for 
Search instead for 
Did you mean: 
MCadl
Beginner
1,783 Views

What is going on with the Dual Band Wireless AC-7260 adapter?

I recently bought a new laptop with this adapter. After a week of sometimes intermittent/sometimes constant connection issues, I took the laptop back and exchanged it for an identical one. By the way, the laptop is an HP Envy X360. The second laptop is doing the same thing. When it drops its connection, it will not reconnect until I've rebooted my router (Netgear WNR2000v3). All other devices in my home are still connected and working find through the router.. just not the laptop.

I've made changes to my router in an attempt to fix. I've downloaded the latest driver directly from Intel (17.0.5.8). Nothing has helped. I went back to Best Buy today and found a laptop from another brand. Upon doing a little research (Google) I found that most of the comments were "Great laptop. Terrible internet connection." I looked up the adapter in the device manager of the display. Sure enough, it was this same adapter.

The internet is full of people with complaints who have a laptop with this adapter.

What is going on here? Is Intel going to act on this and provide updated, working drivers? I've never had this much trouble trying to purchase a laptop... ever.

Anyone, please advise. Thank you.

0 Kudos
13 Replies
RA6
New Contributor I
151 Views

The AC-7260 works best if you have a AC Router. Also sadly to say your Netgear WNR2000v3 is not at dual band router. If you are going to use the 802.11N standard it is best to have a dual band router and connect on the 5Ghz band. Also please make sure your firmware of our router is up to date. sometime that can fix some issues.

MCadl
Beginner
151 Views

Thanks for your reply, but I can't believe that the thousands of people who buy a laptop with the AC-7260 in it should also be required to buy a new dual band AC router. Worse than that, even if that were true, wouldn't you think that the computer manufacturers and Intel would make sure that consumers know that the AC-7260 is -incompatible- with non-dual band or non-AC routers? Not only that, but think of all of the places one could take their laptop that would still be using non-dual band, non-AC routers. It would render the laptop useless in most places.

I can't believe that. I believe that it is meant to work (even if not as good) with non-dual band and non-AC routers, and no one is doing anything to fix the problem.

Btw.. my router does have the latest firmware.

RA6
New Contributor I
151 Views

The AC-7260 is but at the same time is not compatible with 802.11N networks. The 802.11AC Standard mainly uses the 5Ghz range. So the AC-7260 will work with 802.11N routers that have the dual band so you can connect to the 5Ghz band. It will work in the 2.4Ghz band but this card is having a lot off issues with slowness in that range. So for best performance it is best to connect on the 5Ghz band. And if you have not figured out how Technology works they always push you to buy the newest thing. Just like Microsoft coming out with Windows 8 when Windows 7 is fine and making almost all new computes with Windows 8 making you have to use it. The AC standard makes Wireless a lot faster So to get best performance out of the card it is best to match Standards.

Jose_H_Intel1
Employee
151 Views

Please try the following steps:

 

MCadl
Beginner
151 Views

Joe, the wireless security I'm using is WPA2-PSK (AES). Not an issue. I already use inSSIDer, and am using the best channel, although it does vary from time to time.

Joe, I don't understand why you asked me to disable uAPSD in my adapter properties. My confusion stems from two reasons: 1. My problem isn't with reduced data throughput, which, as stated in the article you referenced, is the only symptom of uAPSD being enabled. 2. I don't have either one of the routers listed in the article, which are--

TP-Link* TL-WA801N.

NetGear* 3700.

The article goes on to state the following: "Intel and their customers have tested numerous access points, and only the two identified APs exhibit the behavior, but there might be others."

Why did you offer this as a solution? I clearly stated in my original post that I have a Netgear WNR2000v3. I also clearly stated that the problem I (and hundreds of others) am having with your adapter is that it loses connection altogether with the router, while other devices remain fully connected.

Please come back with some real insight, and maybe a solution--although I am not sure the solution is possible without an acknowledgement from Intel that there is a problem with their adapter.

BB4
New Contributor II
151 Views

There are so many concurrent threads about the AC adapter going on that it simply may be the case that responses to stated issues might get confused because the threads are all starting to run together.

Maybe there should be a couple of stickied threads at the top, one for Win 7 and one for Win 8, with a list or discussion of best practices for each--configurations and settings that seem to work best. Which driver version, ProSet installed or no, AC or no AC router, adapter settings, router settings, etc.

When I come back to this forum each day, I'm finding it a bit of a challenge to remember whether I've read a particular thread. They're bunching up at the top like aircraft waiting to land at O'Hare. Then someone will find one that dropped off the first page and reply to it, and, of a sudden, there's yet another one. Ai yai yai.

MCadl
Beginner
151 Views

What would be even better is Intel addressing this as an inherent problem with this card and publishing a fix... or, if needed, sending out a recall.

BB4
New Contributor II
151 Views

I've replied to several stating the steps that I've taken to get mine working pretty well. I'd be happy to contribute to a sticky thread, as I proposed.

But at some point, I and the others who've found success are going to grow weary of writing the same thing over and over. The occasional suggestions from the Intel contributors aren't harmonious and it doesn't appear that there is a consistent method or approach amongst them. --Intel peeps, that's not intended as a gratuitous criticism. It's just that you're attempting to put out small fires in individual replies to individual posters, while it's become pretty clear that a series of steps have to occur in sync with each other to get this card working well, or even working at all. Steps involving those settings I suggested two posts north of this one.

I'd be the first to admit that it may not be the case that one size fits all. There are a myriad of configurations to have to consider. But there are underlying core settings that I bet are worthy of considering globally.

MCadl
Beginner
151 Views

GattoNero,

I've spent the last 15 minutes searching for posts from you on other threads, but can't seem to find the solutions you've suggested. Could you post a link to a thread or post where you outline your fixes?

 

Thanks.

 

BB4
New Contributor II
151 Views

You got it. See gawdawful long new post in this forum Read at your own risk.

MCadl
Beginner
151 Views

I don't see a thread started by gawdawful. Can you post a link to it?

BB4
New Contributor II
151 Views

Jose_H_Intel1
Employee
151 Views

It is advised to disable channel bonding for 2.4 GHz because of the amount of channels and the possible interference present in this band.

http://www.intel.com/support/wireless/sb/CS-025343.htm Wireless Networking — How to configure 802.11n channel bonding on Intel Wireless adapters

Reply