Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
7589 Discussions

Why does DSA Install option fail for Dual Band Wireless driver update


This post is directed to any Intel people who can do something about the issue, or, tell me what I am doing wrong.


My machine is 7i7bnh.

Update available seen 12/4/2019 in the DSA was

Intel® Wireless Technology-Based Driver for Intel® NUC

Latest version:

Installed Version:


When I click "Install Now" (after downloading a driver update) I expect it to "install".

Instead, I have to choose between Modify and Remove.  Of course I want to "Modify" the driver ... to the newest version; why would I want to just Remove the driver?

Why doesn't the system simply install the newest version for me (and remove the old driver in the background)?

The install fails.


Next, I try Remove, then I re-run and look for "Modify" but it is not there. It seems to proceed to installation.

But ... Failed


Re-run "Install" ... the Install Now option does nothing.


Please fix this craziness in processes for drivers that have the Modify and Remove options; make all driver installs consistent and transparent to user


Thanks for your attention.


Stephen Mehl


0 Kudos
1 Reply

@smehl​  This is Monique, the IDSA project manager with Intel Corporation. We had posted the latest wireless driver version to Download Center during the time you tried scanning, so there may have been some latency in the caching refresh time causing the version detection discrepancy. Please try running the IDSA scan again and see if the driver version is showing now. It it continues to prompt you to install the wireless update, go through that process and see if it's successful this time. If you see an "install failed" message flash on the IDSA scan page, rescan IDSA and it should report back correctly that the driver is updated. Our team tried replicating this issue today and it seems to be working correctly now.


Monique with Intel

0 Kudos