Community
cancel
Showing results for 
Search instead for 
Did you mean: 
MTres
Beginner
3,119 Views

WiFi Link 1000 BGN won't connect

My sister owns an HP Pavilion DV6 VX070AV laptop with a WiFi Link 1000 BGN/Centrino Wireless-N 1000 card for WiFi. Unfortunately, ever since I attempted to update the driver for her, the computer will not connect to WiFi.

The computer also has a Realtek card for Ethernet, which works perfectly, and the computer also works fine with a Netgear WNA1100 USB network adapter. Interestingly, while using the driver from HP names the card "WiFi Link 1000 BGN", Intel's driver names it as "Centrino Wireless-N 1000."

Here is what I have tried:

- I have tried installing both version 16.7.0 and 16.11.0 of the driver from Intel.

- I have tried updating the driver through HP Support Assistant.

- I have tried deleting the driver completely (including driver files) and allowing Windows to reinstall the driver.

- I have tried deleting the driver completely and installing the drivers with Intel's installer.

- I have tried using a Linux liveDVD. I have tried both Linux Mint 17.1 and KDE Neon 5 (Currently Ubuntu 15.10 beta with latest KDE). Neither of these are able to connect, although KDE Neon displayed the network as WPA, while I know that the network is WPA2.

The router is a Motorola Netopia from around 2008 with WPA2 and 802.11g WiFi.

Does the WiFi Link 1000 BGN have firmware flashed to it that is updated with driver updates? Is this somehow a problem?

I do not think it is a problem with the router, as we have had no issues with other devices connecting.

Any help is much appreciated.

-Matthew

Tags (1)
0 Kudos
20 Replies
ASouz7
Honored Contributor II
808 Views

Hello MTres19,

We would be more than glad to assist you but any assistance to LINUX* OS we recommend that you access the Linux* Forum: https://downloadcenter.intel.com/download/17045/Intel-Drivers-for-Linux- Intel® Drivers for Linux*

MTres
Beginner
808 Views

Perhaps I wasn't quite clear. The laptop runs Windows 7 Home Premium 64-bit. Running Linux was only a test to know whether the problem persisted under a different OS. Right now, help on Windows is more urgent than Linux.

-Matthew

ASouz7
Honored Contributor II
808 Views

MTres19,

Is this wireless adapter the original one that came installed by factory?

MTres
Beginner
808 Views

Yes, this is the adapter that was installed by the factory. I am aware that sometimes hardware is changed by the manufacturer. However, even the driver installed by HP Support Assistant failed to cause the adapter to work properly. The adapter is able to properly list nearby networks, but cannot connect.

HGome1
Novice
808 Views

Aleki_Intel: Here's another good example of the same issue happening on a factory adapter, though a different card, theres not doubts about Intel drivers mess up somewhere.

ASouz7
Honored Contributor II
808 Views

hggomes,

All Intel(R) Drivers found in our https://downloadcenter.intel.com/ Download Center are generic and may not be compatible to the customizations done by the computer manufacturer. That is the reason we recommend to contact them first and see what drivers they have. Our drivers may be newer that those found in the OEM support page but that does not mean they are the right ones for the adapter.

ASouz7
Honored Contributor II
808 Views

MTres19,

When you uninstall the drivers, did you do it to the point that Windows no longer recognizes the adapter and sees it as unknown device?

Once you have done that, you could try the latest drivers provided by HP. Did you do a clean install of the OS before this issue occurs?

When you did the procedures informed by you above, did you do the following:

1 - Updated the BIOS.

2 - Checked if antivirus and/or firewall security configurations are impacting the connection.

3 - Allow computer to turn off this device to save power

4 - On the adapter properties, check if the value of Power transmit is set to 5. highest

5 - Have you checked the router configuration?

6 - Check this link for further troubleshooting steps: http://www.intel.com/p/en_US/support/highlights/wireless/1000 Support for the Intel® WiFi Link 1000

MTres
Beginner
808 Views

Yes, I am aware of this, however, HP support assistant's drivers also did not work. I would assume that these drivers are provided by HP.

HGome1
Novice
808 Views

No, the base driver originally is from Intel, then HP/other manufacturers do some small changes on them, based on regulatory region, txpower allowed, etc.They also put the WNIC on BIOS white list so users cant use other cards beside the ones listed, but the drivers are always from Intel, if theres a problem with the Intel driver you will see the same problem happening on the manufaturer driver, manufaturers dont make drivers to Intel hardware, Intel simply provide them.

HGome1
Novice
808 Views

hggomes,

All Intel(R) Drivers found in our https://downloadcenter.intel.com/ Download Center are generic and may not be compatible to the customizations done by the computer manufacturer. That is the reason we recommend to contact them first and see what drivers they have. Our drivers may be newer that those found in the OEM support page but that does not mean they are the right ones for the adapter.

I know that, but i/other users still don't have a solution on this, either with manufacturer or Intel driver.

Tks for your reply.

MTres
Beginner
808 Views

Sorry for my late reply. No, I have not updated the BIOS or changed any router settings. Since the Netgear WNA1100 works, I don't think that it is a firewall setting. I am not sure about Windows turning off the device to save power, but if this were the problem, it doesn't seem that this would occur under Linux. I agree with hggomes, too. Since HP's drivers don't work either, isn't it likely that there is a bug in the Windows and Linux driver? As stated in my original post, I have tried both of the two most recent versions of the driver from Intel, but neither work.

I will look through the troubleshooting section of the support pages, but I think that most likely this is a driver issue. Is this issue being evaluated?

MTres
Beginner
808 Views

An update on the support pages: I filtered the troubleshooting pages to "Known issues," and there were no results. Thanks for the recommendation, though.

ASouz7
Honored Contributor II
808 Views

MTres19,

So far, the information we have on the Intel® Centrino® Wireless-N 1000 is that it is not supported on Windows*10.

Unfortunately we have no information if this will change in the future.

KTee
New Contributor III
808 Views

I know that there is no information stating that this driver supports your adapter, but I had a gander through the inf, and the Centrino Wireless-N 1000 and it's associated device ID's are still listed within it: https://downloadcenter.intel.com/downloads/eula/25275/Intel-PROSet-Wireless-Software-and-Drivers-for... Intel® PROSet/Wireless Software and Drivers for IT Admins (Update the driver in Device Manager, point it to Netwsw00.inf)

Driver versions of the Centrino Wireless-N 1000 for the different Intel WLAN packages:

(Netwsw00)

16.7.0: 15.9.2.1

16.11.0: 15.11.0.7

18.20.0: 15.11.0.9

It's worth a shot, but I'm not sure if it will fix your issue.

MTres
Beginner
808 Views

As stated before, this is not Windows 10. The computer runs Windows 7 Home Premium 64-bit.

MTres
Beginner
808 Views

I'll look into trying that, thanks. Still, the fact that the problem also occurs under Linux concerns me.

MTres
Beginner
808 Views

Thanks for your help, but on the Intel Download Center, I tried searching for both "WiFi Link 1000" and "Centrino Wireless-N 1000" and though there were executable installers, I did not find a .zip file for the drivers that would contain Netwsw00.inf. Since this problem also occurs on Linux live DVDs, I don't think it's a problem only with the driver installation state.

KTee
New Contributor III
808 Views

Zip file links for the various releases: http://www.intel.com/support/wireless/wtech/proset-ws/sb/CS-034038.htm http://www.intel.com/support/wireless/wtech/proset-ws/sb/CS-034038.htm

I agree though, if Linux distros are also showing an issue, the problem may not lie with the driver.

rshai2
Novice
808 Views

Can you please help me out to have software of intel proset for wired connection version 8.2.1.0 for windows 2000 OS

MTres
Beginner
123 Views

My family recently got a new modem/router with 802.11n, and the network adapter still doesn't work. Any recommendations from anyone?

Reply