Community
cancel
Showing results for 
Search instead for 
Did you mean: 
RShan15
Beginner
457 Views

Wifi Adapter Dual Band 7625 gets frequently disconnected- Need a fix.

Wifi Adapter Dual Band 7625 gets frequently disconnected all of a sudden from last week (I think after an update- at the same time water spilled on my laptop as well) - after both instances happening at the same time this is happening. I did the below.

 

  1. Re-install OS and still happening.
  2. Battery saver is turned off

 

Now it is connected to wifi, while working it gets disconnected and connects again.

 

Is it a SW issue or HW issue? Note- In Inter website, it shows there is an update for Wifi driver, but I'm hesitant to install that as the last time I installed it and then the issue got worse.

 

Mine is a 64 Bit, Dell Inspiron 7573- Bough in USA but using now in India

0 Kudos
6 Replies
David_V_Intel
Employee
97 Views

Hello RShan15,

 

Thank you for posting on the Intel communities. 

 

Taking into consideration the fact that you have already re-installed the operating system and water was spilled on the system, this would point at a hardware issue, which, I would recommend reporting directly to the system manufacturer.

 

They may be able to provide you with more options to troubleshoot the defective adapter which appears to have been damaged according to the information you have provided.

 

 

David V

 

Intel Customer Support Technician

A Contingent Worker at Intel

RShan15
Beginner
97 Views

Hi David, how sure could it be a hardware issue ? What I'm not convinced is that it happens intermittently. Is that a sign of GW issue ? I thought if HW is at fault you won't even recognize the adapter in the PC. But it actually happened after the update as well ​?

David_V_Intel
Employee
97 Views

Hello RShan15,

 

Thank you for your response.

 

Analyzing the information you have provided so far, you tried re-installing the Operating System but even this still does not solve the problem. Unless the build of Windows* you are installing is the same as when the update was done, this points at a hardware issue, specially taking into consideration the water spilled. 

 

Now, of course we can check other possibilities, please provide me with an System Support Utility report, please download the tool in the link below: 

 

https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows-

 

NOTE: Make sure to attach this to the thread directly as a .txt file. 

 

 

David V

 

Intel Customer Support Technician

A Contingent Worker at Intel

RShan15
Beginner
97 Views

David,

Here you go.

David_V_Intel
Employee
97 Views

Hello RShan15,

 

Thank you for your response.

 

I was reviewing the report you attached and I can see that you have an older build of Windows installed right now which is the 1803, please attempt to update Windows to the latest version available which should be 1903 and check to see if the issue yet persists.

 

Normally, the O.S update should be done via Windows Update; however, if you are unable to do so, please refer to the link below: 

 

https://www.microsoft.com/en-us/software-download/windows10

 

If after updating the O.S, the issue is still present, please try updating the network driver to the latest one provided by your system manufacturer. Please refer to the link below: 

 

https://www.dell.com/support/home/us/en/19/product-support/product/inspiron-15-7573-2-in-1-laptop/dr...

 

NOTE: It should be the one labeled " Intel 3160/7260/3165/7265/8260/8265 Bluetooth Driver". 

 

It is recommended to try a clean installation of the drivers, you can find the instructions on how to do so in the following link:

 

https://www.intel.com/content/www/us/en/support/articles/000022173/network-and-i-o/wireless-networki...

 

I hope this helps, please let me know the outcome.

 

 

David V

 

Intel Customer Support Technician

A Contingent Worker at Intel

RShan15
Beginner
97 Views

Hi,

 

Still same problem.

Reply