Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
1,507 Views

Wifi stop working. Win10 shows only one network and it doesn't connect to WiFi

Product Name: Hp Omen 15

Operating System: Microsoft Windows 10 (64-bit) and Elementary OS Freya

Wifi Adapter: Intel Wireless-n 7260

 

Hi guys,

 

since some days my wifi has stopped working.

 

If I click on Wifi icon it shows only ONE (max two) NETWORK, but not mine!

And I live in a building with 20+ networks, as you can see from WiFi Analyzer (I'm the red one on the right)

 

 

My Wifi is on the top. If it's saved, Windows connects to it and then it drops the connection; if it's not saved and I try to connect, it says "You're not able to connect to this network".

 

The fun fact is that after some seconds every network disappear and only one is showed (probably the neighbour one..I dunno).

I've already tried to HARD-RESET the notebook keeping the power button for 10/15sec with the laptop turned off.

 

I've already tried to follow these instructions from HP support (http://support.hp.com/us-en/document/c04649175) http://support.hp.com/us-en/document/c04649175) updating drivers (Intel 18.12.0.3, 18.12.1.2, 18.30.0.9 [Windows 10 default], 18.32.0 [Lastest drivers]) with no success. Everytime I install a new drivers, I uninstalled the previous one + Wireless software + reboot.

I tried to uncheked "Allow this computer to turn off this device to save power" on my Wifi hardware settings without success.

The HP Network support says I didn't choose a Wifi (Really? The problem is I don't see my Wifi on the list!).

This is not related to a new Windows 10 upgrade since I've installed it months ago and It's the first time I've this problem :/ It always worked

I tried different settings too:

 

I changed channel, I set 802.11g on my router, APSD off on the router.

 

I set "Magic packet off, ad hoc QoS off, U-APSD off, fat channel off,incremental throughput off, HT mode off" on the card setting without success. Nothing chaned.

The Hardware test doesn't detect any failure.

Note carefully: If I go close to the router, it shows my network with full power connection and it connects to it. Then I go back to my bedroom (probably 3/4 meters far), it KEEPS the connection for 30/40min and It drops the connection and I can't reconnect to it anymore. It always worked perfectly in my room in these months (I bought it in March 2015), so the distance is not a problem, I'm 6/7m far from the router.

 

In this case It shows my Network (Connected) and the neighbour network...and the other 20+ networks???

The only way I have is USB tethering with my Nexus 5.

Linux: I tried the Wifi connection on Elementary Freya (Ubuntu linux based OS) and it shows 20+ networks available on the list. It has not connection problem with my Wifi, but sometimes it stops working, the webpages stop loading and I must reboot Wifi to reconnect to it (usually after 30/40min using it).

-------------------------------------------------------------------------------------

What's the problem? Is my Network-board broken? Any suggestion?

Tags (1)
0 Kudos
5 Replies
ASouz7
Honored Contributor II
91 Views

Gorghino,

Have you tried to remove all internet profiles and let the wireless adapter search for them again? If this wilress adapter is the one installed by factory, we recommend to contact the OEM, in this case, HP* as you have mentioned in order to obtain support from them first.

What wireless adapter do you have in order to see how we can provide you assistance.

Can you confirm this wireless adapter is the one installed by factory?

idata
Community Manager
91 Views

Hi Aleki, sorry I forgot to mention it.

 

The wireless adapter is the one installed by factory and It's Intel Wireless-n 7260. I'm trying all the ways, contacting HP and Intel too in order to fix this problem.

Thanks

ASouz7
Honored Contributor II
91 Views

Gorghino,

In this particular case, it is recommend to contact HP* and check if the antennas are connected properly. We also recommend that you check the following:

1. Check Disabled the Power Saving Functions

2. Go to control Panel >> Hardware and Sound >> Power Option >> Set the High Performance and apply to default settings.

3. Check Change Plan settings >> Change Advanced Power Settings >> Wireless Adapter settings >> Power savings Mode and make sure both on battery and plugged in are set to Maximum Performance.

4. Check and if necessary change the value of Transmit Power and make sure it is set to 5. Highest.

5. On a single-band wireless adapter, it is preferable that you set the 802.11n Channel Widith to limited 20MHz.

6. Set the value of Roaming Aggressiveness to Lowest

7. Set the value of Ad Hoc QoS Mode to WMM to Disabled.

idata
Community Manager
91 Views

Hi Aleki,

I took a risk.

 

I did a restore factory with HP recovery (I've a dedicated drive for it) and....it worked!

 

I had to upgrade Win8.1 to 10, but the Wifi problem is solved!

I'm still guessing which was the problem...

Now I'm running Intel drivers ver. 18.30.0.9 and all the networks are working.

In the next days I'm trying to check the linux problem (the factory reset deleted Elementary partition).

ASouz7
Honored Contributor II
91 Views

Gorghino,

We are glad to know all is fine now. Thanks for sharing it.

Reply