Wireless
Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
7587 Discussions

Wireless 7265d repeatedly disconnects, then becomes unavailable until reboot in debian 11.7

Umbra
Beginner
797 Views

My wifi connection is normally stable, but then, without warning, will start stuttering. The card will show itself as restarting, which is confirmed via dmesg, but it never becomes stable again. Instead, after a highly variable amount of time, it will simply become unresponsive. It doesn't show itself as rebooting. dmesg stops showing any messages from iwlwifi, it just goes silent. Modprobe indicates that it's in use when trying to remove it, however no firmware shows up for the network card under lshw

I tried to use this post (https://community.intel.com/t5/Wireless/Wireless-7265-constantly-disconnecting-in-Ubuntu-20-04/m-p/1260967) to help debug, but it ended up not being a similar issue.

 

System information:

  • Network Controller: Intel Corperation Wireless 7265 (rev 59) (shows up in lspci)
  • kernel version 5.10.0-23-amd64, which should support this card
  • iwlwifi and iwlmvm are both installed and loaded, and iwlwifi has definitely been initialized
  • lshw doesn't indicate any firmware is in use

 

The kernel log will sometimes say that there's a

  1. microcode software issue
    1. restarting 0x20000000
    2. status 0x00000050 (sometimes 0x00000040)
  2. a firmware error
  3. hardware error
    1. status 0x00000040

 

Several lines appear in the kernel log repeatedly, including:

  • Cannot send HCMD of  Phy DB cfg section
  • HW problem - can not stop rx aggregation...
  • failed to remove key ... from hardware (-5)
  • iwl_trans_wait_tx_queues_empty bad state = 0
  • selected rate control algorithm 'iwl-mvm-rs'
  • failed to read out thermal zone (-61)
  • HCMD_ACTIVE already clear for command TIME_EVENT_CMD
    • same as above but for commands
    • LQ_CMD
    • MAC_CONTEXT_CMD
    • STATISTICS_CMD
    • SHARED_MEM_CFG_CMD
    • BT_COEX_UPDATE_REDUCED_TXP
    • BT_CONFIG
    • ECHO_CMD
  • HCMD skipped: index (3) 35 2
    • numbers vary
  • Hardware error detected. Restarting.
  • Collecting data: trigger 2 fired.
    • Collecting data: trigger 15 fired.
    • Collecting data: trigger 16 fired.
  • Hardware restart was requested
  • FW already configured (0) - re-configuring
  • Applying debug destination EXTERNAL_DRAM
  • Failing on timeout while stopping DMA channel 8 [0xa5a5a5a2]
    • sometimes has other hexvals
    • [0x077d0001]
    • [0x077f0001]
    • [0x07fd0001]
  • Firmware error during reconfiguration - reprobe!
  • Failed to start INIT ucode: -110
  • Failed to run INIT ucode: -110
    • (or -5 sometimes)
  • Failed to start RT ucode: -110
  • mac start retry 0
  • direct-loading firmware iwlwifi-7265D-29.ucode
  • Found debug destination: EXTERNAL_DRAM
  • failed to load iwl-debug-yoyo.bin (-2)
  • iwlwifi transaction failed, dumping registers
  • 0x00000000 | ADVANCED_SYSASSERT
    • no other hexvals
  • FW error in SYNC CMD BT_CONFIG
    • PHY_DB_CMD
    • MAC_CONTEXT_CMD
    • REDUCE_TX_POWER_CMD
    • REPLY_BEACON_FILTERING_CMD

I haven't installed the debug drivers yet because I wanted to get as much info off the system as I could before rebooting it, but when I do I'll follow up with that. Attached is my (zipped) encrypted system logs, as suggested by https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi/debugging. The SSU report is included in the zip. I had to double-wrap the zip so that the forums would let me attach the files.

0 Kudos
6 Replies
Jean_Intel
Employee
767 Views

Hello Umbra,

 

Thank you for posting on the Intel️® communities. We would be more than glad to help you with your issue.

 

To better assist you, please provide me with the following:

  • When did it start to happen?
  • Is this a laptop or desktop system?
  • Does the issue happen on different networks?
  • Are you able to reproduce the same issue while on a hardwired connection?
  • Is this the original adapter that came pre-installed in your system, or have you changed/installed a new adapter recently?
  • Can you replicate the issue using a Windows Operating System?

 

Best regards,

Jean O. 

Intel Customer Support Technician


0 Kudos
Umbra
Beginner
762 Views

Ah, thanks for the reply, I can't believe I forgot to add more hardware info.

 

This is on an Asus ZenBook, the ux305f, and this is the original adapter that came with the system. This has been happening for at least a year, but I can't remember when it first started. It happens on all kinds of different networks, yes, though once it happens it is no longer on (or even detecting) any networks. I'm not on a hardwired connection often enough to be sure if it crops up while on it, but swapping to a hardwired connection doesn't fix the issue. I don't actually know what causes the issue, so I don't have steps to reproduce it. It just kind of happens eventually. I've not tried replicating it on Windows, because I'd rather not wipe my laptop.

 

Thanks for the reply!

0 Kudos
Jean_Intel
Employee
756 Views

Hello Umbra,

 

Thanks for the information provided.

 

We would like to further investigate this matter. But before that, we would like to request you run the following Linux Commands and share with us the outcome:

  • # lspci​
  • # modinfo iwlwifi​
  • # lsmod | grep iwlwifi​
  • # dmesg | grep iwlwifi​   

 

Best regards,

Jean O. 

Intel Customer Support Technician


0 Kudos
Umbra
Beginner
742 Views

`dmesg | grep iwlwifi' was empty, but dmesg also only went back less than an hour ago. I posted my full system logs earlier (though encrypted), and the list of lines that I posted were excerpts from my system log, all of which were sent by iwlwifi.

0 Kudos
Jean_Intel
Employee
705 Views

Hello Umbra,

 

We appreciate your patience.

 

Based on our investigation of your reports and your mention of an empty 'dmesg | grep iwlwifi' output, it appears that the driver was not initialized, which may be due to a distribution issue. Our recommendation is to reach out to Debian for further guidance.

 

Since the course of action for this problem is to contact your Linux Distribution, we will close this thread now. If you need any additional information, please submit a new question, as this thread will no longer be monitored.  

 

Best regards,

Jean O.

Intel Customer Support Technician


0 Kudos
Umbra
Beginner
699 Views

How can it possibly have not been initialized if it was a) functional earlier and b) sending messages to dmesg? Like I said, there weren't any messages in dmesg at that point, but my initial post contains a ton of messages from dmesg, all sent by iwlwifi. It was sending info about hardware errors, software errors, and firmware errors. It was definitely initialized, and kept getting rebooted constantly.

0 Kudos
Reply