Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
1,077 Views

Wireless AC 9462 constant disconnection problem.

I have disconnections on a regular basis. Once I'm disconnected I can't reconnect and I get an error saying "we couldn't connect to this network". But my wifi router is showing in the list.

Other devices at home can connect with no problems so it really comes from my laptop.

 

I've got a Dell Vostro 5590

Windows 10 64bit

My wifi card is the Wireless AC 9462

The driver is the 21.80.2.1 version, downloaded directly from the intel website today, the problem is still here.

 

Please help, this is really annoying.

0 Kudos
7 Replies
Highlighted
Moderator
996 Views

Hello FAudi1,

 

Thank you for posting your question on this Intel® Community.

 

To better assist you, we would like to have more information about your system configuration.

 

  • When did this issue started?
  • Did it work before, and now it doesn't work? If yes, has anything changed on the computer since that time? For example, has the access point or environment changed?
  • What is the model number of your access point/router?
  • Did Intel® Wireless-AC 9462 adapter come pre-installed in your computer?

 

  • Generate a system report with the Intel® System Support Utility (Intel® SSU) and attach the report directly to this thread.
  1. Intel® SSU Download link
  2. Open the application and click on "Scan" to see the system and device information. By default, Intel® SSU takes you to the "Summary View".
  3. Click on "Summary" to change to a "Detailed View".
  4. To save your scan, click on "Next", then "Save".

 

Wanner G.

Intel Customer Support Technician

0 Kudos
Highlighted
Moderator
996 Views

Hello FAudi1,

 

If you need further assistance, please let us know. We will be glad to help you.

 

Wanner G.

Intel Customer Support Technician

0 Kudos
Highlighted
Beginner
996 Views

Hello,

 

Thanks for your concern. Ironically enough I didn't have the problem again since I posted the first message...

I will get back to you and go through all the steps you gave me if it happends again.

0 Kudos
Highlighted
Moderator
996 Views

Hello FAudi1,

 

Thank you for your response.

 

We will close this thread. Feel free to post an update or ask additional questions related to this thread.

 

If you need assistance with a different issue, please start a new thread, and we will be glad to help you.

 

Wanner G.

Intel Customer Support Technician

0 Kudos
Highlighted
Beginner
979 Views

I have the identical issue.  I have no wi-fi from neighbor's, multiple devices connected (apple, dell - perfect connections maintained for days / weeks)

I have had my Vostro 5490 for 3 weeks, it ran beautifully for the first week, then I am plagued by constant drop outs - the only changes are Windows updated - until today.  I have begun changing some of the advanced settings - of note Chanel width for 2.4GHz from auto to 20 MHz only.  As I type - I have not had a disconnect for nearly 30 minutes - the longest I've gone.  This intermittent disconnect kills productivity for remote workers!  I have the latest driver installed from your website.  I hope my connection keeps going after the change I made mentioned above

 

0 Kudos
Highlighted
Beginner
814 Views

Hey Intel, Hi Everybody,

Guess what. The same happens to me, but it gets even worse. Often when it disconnects it also, as crazy as it sounds, it kicks out all other devices from the wireless network! Seriously... all other connected devices lose connectivity for a moment. No joke! It took me days to realize this.

My notebook is Dell Inspiron 5490.

Right now I'm experimenting with different settings and different drivers etc. Sometimes the issue does not occur for many hours, so it is hard to say if the problem is resolved.

I'm on driver version 21.90.3.2 (at the time of writing Dell had version 21.80.0.4 available on their page).

Are there any confirmed solutions for this issue?

regards,

Marl

0 Kudos
Highlighted
Beginner
773 Views

Hey People,

Just to let you know.

The driver version 21.90.3.2 downloaded directly from the Intel site resolved the issue. There were no disconnections for several days now.

Drivers provided by Dell seem to be broken somehow.

 

Tags (1)
0 Kudos