Community
cancel
Showing results for 
Search instead for 
Did you mean: 
discgolfdc
Beginner
416 Views

Wireless connection stability with Windows 10

Hi.

 

I just asked another question on this forum, but as I was asking it, I realized that what I thought was supposed to take care of a problem I described therein, in fact, hasn't. Microsoft forums are of little to no help, so perhaps someone here might have some insight.

 

I currently run an ASUS X540LA laptop with Windows 10 Home Edition. For the last few months, I've noticed that my Wi-Fi internet connection goes in-and-out. A lot of disconnect/reconnect cycles. It's gotten to the point where I have, in fact, thrown something at my screen and cracked it. I've since replaced that. Stupid me.

 

In any event, I've been doing what I can to see if I could narrow down some possible culprits. Admittedly, the computer is almost on the diametric opposite side of my home, so I figured that wireless signal might be scant over here. To fix this, I put a repeater in the middle of my home. The repeater's wireless signal as received from the parent router is consistently between -35 dBm to -52 dBm. Even with the repeater receiving a signal at -52 dBm, I'm still getting Wi-Fi download speeds at the laptop between 40-50 Mbps and upload speeds between 10-15 Mbps. The signal being received by my laptop from the repeater seems to be clocking in right around the range of -36 dBm to -40 dBm, which seems to be an acceptable signal.

 

I've eliminated other software that might have potentially been interfering, though I don't believe so, such as third-party VPN, etc.

 

I went so far as to change the stock Wi-Fi/Bluetooth NIC in my laptop -- originally a Qualcomm Atheros AR956x, replaced with an Intel Dual Band Wireless-AC 7260 (my laptop's interface is HMC, so I went with what I could). I did so based on reports of Wi-Fi instability on the AR956x and much improved stability with the 7260.

 

Unfortunately, my laptop continues to go through these disconnect/reconnect cycles. In fact, during the course of writing this, my laptop has cycled 3-4 times. I switched over to writing my post in Notepad just to avoid any potential losses of work.

 

I've gone through site after site, blog after blog, and I've taken just about every other conceivable measure suggested at these turns...turning off the ability of Windows to shut down the NIC to save power, etc. Each suggestion, meant well, unfortunately doesn't change my situation.

 

No other device on this side of the house that is connected to the repeater has any sort of similar connectivity problem. They all connect happily and go about their business without the constant disconnect/reconnect cycling.

 

Does anyone have any insight as to why this might be happening? Things I might otherwise be able to check? Does anyone else with W10 have this kind of frustrating phenomenon plaguing them? Is it the result of some illustrious Microsoft update that probably borked something that I'll never be able to fix?

 

I realize that this might not necessarily be an inherent "Intel" question, but I replaced my NIC today and, with it being an Intel with strong reliability reviews, I thought maybe someone here might be able to chime in. I'm reticent to post to the Microsoft forums because they'll just tell me to reboot my computer or wipe it and start from scratch or something goofy like that, but I'll probably put a post similar to this over there as well.

 

Thank you in advance.

0 Kudos
1 Reply
Alberto_R_Intel
Moderator
180 Views

discgolfdc, Thank you for posting in the Intel® Communities Support.

 

In reference to your inquiry, we always recommend to install the Wireless driver provided by the manufacturer of the computer, since that driver was customized by them work with your specific system and also to check with them as well if the Intel® Dual Band Wireless-AC 7260 card is fully compatible with their platform.

 

I was looking for the Wireless drivers validated by ASUS, but there are no drivers for the Intel® Wireless card:

https://www.asus.com/Laptops/X540LA/HelpDesk_Download/

 

So, the best thing to do in this case will be to get in contact directly with them for them to confirm if the Intel® Dual Band Wireless-AC 7260 card is fully compatible with the laptop and for them to provide the proper drivers needed for the optimal performance of the card:

https://www.asus.com/support/

 

In the following link you will be able to find additional details about the integration of a Wireless card:

https://www.intel.com/content/www/us/en/support/articles/000005846/network-and-i-o/wireless-networki...

 

Any questions, please let me know.

Regards,

 

Albert R.

Intel Customer Support Technician

Reply