Community
cancel
Showing results for 
Search instead for 
Did you mean: 
DGorb
Beginner
3,022 Views

intel wireless 8265 linux: can't connect and work with bluetooth handsets

Hi,

I'm using laptop from system76 (galago model) which has Intel Wireless 8265NGW.

Here is the https://photos.app.goo.gl/HcyXEbbS9asWP39b7 photo of the device.

OS: Linux

The problem: I can't connect my bluetooth handset devices (I have two of them) to my laptop: the device may get connected but for a 5 - 10 seconds only, then get's disconnected but the laptop thinks it's connected. Something quite weird goes on there.

If I connect my android smartphone to laptop -- everything goes well and fast and reliable.

But not handsets !

These handsets connect to any bluetooth device I have in my home (several tablets, dell 3350 laptop under linux, to smartphone -- I mean they are working !)

I tried different bluetooth managers (NetworkManager, blueman, Gnome-specific, something else) -- all works in a same way.

I haven't tried windows, I have only Linux on my laptop.

Here are the video I recorder for system76 support team (they didn't help me):

1: https://www.youtube.com/watch?v=iSet5KXt_P4 Bluetooth doesn't work on System 76 Galago Pro - YouTube

2: https://www.youtube.com/watch?v=AU-H3TywaKo Trying to connect... - YouTube

Uname -a: Linux galago 4.15.0-23-generic # 25-Ubuntu SMP Wed May 23 18:02:16 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

 

lsusb:

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

 

Bus 001 Device 004: ID 8087:0a2b Intel Corp.

 

Bus 001 Device 003: ID 04f2:b649 Chicony Electronics Co., Ltd

 

Bus 001 Device 006: ID 045e:07a5 Microsoft Corp. Wireless Receiver 1461C

 

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

 

 

attaching dmesg (I may say nothing gets to dmesg when I try to connect to handsets).

Is there is anything else I need to provide ? some info ?

Thank you,

Dima

0 Kudos
3 Replies
idata
Community Manager
848 Views

Hello DimaGorbenko,

 

 

As we understand, your system is not able to get a reliable connection to your Bluetooth Handset Devices. We would like to mention that we do not provide full support for the Intel® Dual Band Wireless-AC 8265 in Linux. Driver development happens in the open-source Linux community and the community is the right source for support.

 

Please check the following links for details:

 

 

https://www.intel.com/content/www/us/en/support/articles/000005511/network-and-i-o/wireless-networki... Linux* Support for Intel® Wireless Adapters

 

https://wireless.wiki.kernel.org/en/users/Drivers/iwlwifi Linux Wireless Community

 

 

In our best effort, we noticed that your Linux distribution has Kernel 4.15.0-23, checking the information from the previous links, the AC 8265 is supported with Kernels 4.6 and above. So your distribution does not have the drivers needed to use the adapter properly. We strongly recommend you to try a suitable Linux version before engaging the community or considering other options.

 

 

Regards,

 

Jonathan B.
DGorb
Beginner
848 Views

hi Jonathan,

I've updated y kernel to 4.17 but it didn't help.

But I understood your point, I need to talk to open source community.

Thank you for helping me,

Dima

idata
Community Manager
848 Views

Hello Dima,

 

 

We are glad to help. The https://wireless.wiki.kernel.org/en/users/Drivers/iwlwifi iwlwifi Linux Community page has information about support contacts and also has some notes regarding Wi-Fi/Bluetooth coexistence in Linux.

 

 

Feel free to contact us if you have any further questions.

 

 

Regards,

 

 

Jonathan B.
Reply