Community
cancel
Showing results for 
Search instead for 
Did you mean: 
JFind
Beginner
7,180 Views

slow wifi 2,4 ghz with ac 8265 @ yoga 720 13IKB

Hello,

I have recently purchased a Yoga 720 13LKB with Intel AC 8265, Win 10 64 bit as OS. Now the issues I'm experiencing are twofold and the following:

1. Slow Wifi connection if a 2,4 GhZ frequency is chosen, whereas it is fast as it should be if I choose the 5 GhZ frequency. On the 5 ghz frequency, I get 30 Mbp/s, whereas on the 2,4 ghz frequency at most 10 Mb/s.

At the same time, my mobile phone and a very old notebook with a generally very bad Broadcom chip deliver on both connections the speed they should, on these devices, regardless of the frequency I always get 30 Mbp/.s

I had a look in the energy settings of Windows as well as into the advanced settings of my network card and tried various settings (I also read intensely on this board and tried many of the recommendations I found), none of which improved the speed on the 2,4 ghz frequency

2. On both the 5 ghz frequency and 2,4 ghz frequency, the range is much more limited on my Yoga than it is on my mobile phone and my old computer. I understand this in the case of the 5 ghz frequency, but there seems to be a serious issue with the 2,4 ghz frequency

I should stress the fact that these issues occur with different routers, the one I'm actually using is a FritzBox 7490 but the same issues held for some Netgear Router (the model of which I don't remember). Right now, I'm running the Intel® PROSet/Wireless Software and Drivers version 19.60.0, but I also tried different (older) drivers, none of which improved the speed on the 2,4 ghz frequency.

Thanks in advance for your help!

Tags (1)
0 Kudos
19 Replies
idata
Community Manager
1,084 Views

Hello computermole,

We understand you're experiencing performance issues with your Intel® Dual Band Wireless-AC 8265 while connected to the 2.4 GHz band only.

In order for us to investigate this problem we would like to take a look at your current hardware configuration and settings. Please download the https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility Intel® System Support Utility and run the report while connected to your 2.4 GHz network, then again while connected to your 5GHz network. You will then need to use the advanced editor (top right) while replying to enable attachments.

With this information we should be able to troubleshoot both of your issues, although the range issue may point towards a hardware problem. If this is the case, you may need to engage your computer manufacturer for warranty support at some point.

We look forward to hearing back from you.

Best regards,

 

Carlos A.
JFind
Beginner
1,084 Views

Hey,

the first file is the one I have created while connected to the 5GHz network. The second = 2,4 GHz network.

idata
Community Manager
1,084 Views

Hello computermole,

 

 

Thank you for those reports. Unfortunately they seem to be missing some of the usual information, which is odd.

 

 

Let's proceed by testing the latest driver provided by your computer manufacturer:

 

 

- http://pcsupport.lenovo.com/us/en/products/LAPTOPS-AND-NETBOOKS/YOGA-SERIES/YOGA-720-13IKB/downloads... Intel® WLAN Driver for Lenovo* Yoga 720-13IKB*

 

 

NOTE: Any links provided for third party tools or sites are offered for your convenience and should not be viewed as an endorsement by Intel® of the content, products, or services offered there. We do not offer support for any third party tool mentioned here.

 

 

Their version will be older than ours, but it takes into account any customizations performed on your adapter when it was integrated into your system. The drivers provided by us are generic versions, which in some cases may not work as well.

 

 

If you're still experiencing the same problem with their driver we can try a driver-only clean installation instead:

 

 

1. Download and extract our latest IT Admin driver for your adapter: https://downloadcenter.intel.com/download/26785/Intel-PROSet-Wireless-Software-and-Drivers-for-IT-Ad... Wireless_19.60.0_Driver64_Win10.zip

 

2. Under Programs and Features in the Control Panel, uninstall any instance of the "Intel® PROSet/Wireless Software." When prompted, choose to "discard settings."

 

3. Go to the Device Manager > Network Adapters > Right click on your Intel(R) Dual Band Wireless-AC 8265 and uninstall it. Make sure to mark the option to "Delete the driver software for this device."

 

4. Clear out your temporary files: Press the Windows* Key + R to open the run box. Type Cleanmgr.exe and press OK. Here you will need to make sure Temporary Files are checked, you may uncheck everything else then press OK.

 

5. Reboot your computer.

 

6. Go to the Device Manager > Network Adapters > Right click on your Intel(R) Dual Band Wireless-AC 8265 again, this time choose to "Update driver software..." > Select the option to "Locate and install driver software manually." Here you will need to direct the wizard to the location where you extracted the IT Admin package back in step one.

 

 

Do let us know if this makes a difference.

 

 

Best regards,

 

Carlos A.
JFind
Beginner
1,084 Views

Dear Carlos,

I have tried both suggestions, and they definitely affected my connection speeds and improved the range (I would now say that the range is normal, although a bit disappointing since it is not better than it is with my older computer nor with my (rather cheap) mobile phone). What happened with the connection speeds is very strange:

1. With the Lenovo Driver you suggested, the speed of the 2,4 ghz connection has definitely improved (+ 5 Mbit/s), but it is still only half as fast as the 5 ghz connection (and also only half as fast as it is on my old computer & mobile phone). The 5 ghz connection remains unchanged on the Lenovo driver.

2. If I do the driver-only clean install with your latest 19.60. driver, the speed of the 2,4 ghz connection drops below that which the Lenovo driver gives me. However, at the same time, the speed of the 5 ghz improves a bit (+ 5 Mbit/s).

With both suggested steps, the range has increased for the 2,4 ghz frequency, but the speed is still unacceptably low.

JFind
Beginner
1,084 Views

I should also say that when I access my router , the following information appears when I click on "wirless networks" while connected to the 5 ghz frequency network:

DESKTOP-PAB201V192.168.178.5200:28:F8:1E:A0:5529 / 1305 GHz / ac / 80 MHz

 

WPA2, 2 x 2

However, while I am connected to the 2,4 ghz frequency network, I do not get any information about my computer. From the information accessible via the router, I cannot even see that I am connected to the network!

idata
Community Manager
1,084 Views

Hello computermole,

 

 

I'm not sure why your router isn't detecting your computer info when you're connected to the 2.4 GHz SSID. But for this we can recommend making sure that your router is using the latest firmware available.

 

 

Going back to the range problem. At this point it's hightly recommended for you to engage your computer manufacturer as well. It's possible that your antennas may not be properly connected, or that they're defective. It's not normal to hear complains in regards to connection speed with these adapters, the 8265 is not a low end model.

 

 

As far as range goes, that depends a lot on the antennas that come installed in your system. These are provided by the computer manufacturer and in some models lower gain antennas may be used to comply with X or Y country regulation. Your system's chasis and antenna placement also play a big part in this.

 

 

Best regards,

 

Carlos A.
idata
Community Manager
1,084 Views

Hello computermole,

 

 

We have not heard back from you in a while. Where you able to contact Lenovo* for hardware support?

 

 

Please let us know if you require any further assistance.

 

 

Best regards,

 

Carlos A.
JFind
Beginner
1,084 Views

Unfortunately, bad news from Lenovo. It seems that my computer's hardware is fine. I'm still wondering why my cheap Motorola G4 Plus has much better Wifi on board than my yoga 720 notebook,

idata
Community Manager
1,084 Views

Hello computermole,

 

 

If the adapter is ok, then we may need to look else where to resolve the problem. The 8265 is a very good, modern adapter. It makes use of 802.11ac Wave 2 features, which allow it to performs better than other wirelress-AC adapters.

 

 

Another way to confirm an issue with your hardware would be by installing an USB Wifi Dongle, but this would require purchasing the adapter, and may not be worth the trouble in this case.

 

 

Have you been able to test your connection while on different WiFi networks? Does the same problem occur then?

 

 

Best regards,

 

Carlos A.
DDiel
Novice
1,084 Views

I am also suffering from very slow WiFi on this laptop, but the 15" version with the 4k display. I have no trouble with range but with speeds. For some reason my connection speed is 54mbps no matter what I try, 2.4ghz or 5ghz. I have tried the steps Intel mentioned, I completely removed the Bluetooth and wifi device and associated software and reinstalled with the latest driver (from this month) and still extremely slow. Like, I got a speed test of 6mbps and my home internet is 150mbps and I had full signal.

This was/is a very expensive laptop and I would like to get this resolved.

For what's it's worth, it sounds like a common problem with Lenovo laptops even with other brands of wifi hardware after searching the issue, I wish I could figure out the cause!

idata
Community Manager
1,084 Views

Hello Dandiele,

 

 

In order to better assist you, we would like the following information:

 

 

1. For documentation purposes, what is the brand and model of your wireless router/access point?

 

2. Please generate an Intel® System Support Utility report as well.

 

1. Please download and run the http://downloadcenter.intel.com/download/25293 Intel® System Support Utility.

 

2. Select to scan "everything," and run the scan while connected to your wireless network (if possible).

 

3. Save the report and attach it to your reply.

 

 

Note: To enable attachments, make sure to switch to the advanced editor while replying.

 

 

Best regards,

 

Carlos A.
DDiel
Novice
1,084 Views

Ok, I have compiled results from the scan tool you suggested, you can see it also shows the link speed of 54mbps were the info on my phone shows a link of 700mbps. I also have attached a screen shot of my speed test result using my phone ( LG V20) connected to the same wifi (5Ghz) from the same seat about 10 feet away from the router. There is a dramatic difference in speed test results every time, 5Ghz or 2.4Ghz no matter what and its usually a lot less then what I got today. Here are results from the laptop http://www.speedtest.net/my-result/6830853788 Speedtest.net by Ookla - My Results and I will attach a screenshot of the speedtest from my cellphone, it connected to the same server for the test

Keep in mind we can stream 4K video on TV while browsing facebook etc on our phones and have no issues, yet this laptop struggles when no other device is using the network to just browse the web some days.

more info about my router can be found here https://www.netgear.com/home/products/networking/wifi-routers/R6400.aspx R6400 | WiFi Routers | Networking | Home | NETGEAR It is a Netgear R6400 (AC1750)

Please help me figure out how to fix this issue, I paid a lot of money for this laptop and I am not sure what else to try

idata
Community Manager
1,084 Views

Hello Dandiele,

Thanks for these reports.

Looking at your settings, everything looks good. One thing we do recommend is owering your roaming agressiveness to the lowest possible setting, specially if you use this system at home where it doesn't normally required to constantly roam from one access point to the next. For this setting, we recommend "1. Lowest" (disables automatic roaming) or "2. Medium-Low" (only looks for alternate networks if network quality is low). In your system this is currently set to "5. Highest," which means your adapter will always be in the lookout for a better network, we've found that in some cases this may result in some link degradation.

Although your settings are near optimal, we noticed an odd behaviour. When connected to your 2.4 GHz network, your adapter connects using the legacy 802.11g standard. When connected to 5 GHz band, your system is linking up using the even older legacy standard 802.11a. Both of these will limit your connection rate to 54 Mbps, resulting in a maximum download speed of roughly 22-25 Mbps.

While the wireless standard may be manually limited though your adapter's http://www.intel.com/content/www/us/en/support/network-and-i-o/wireless-networking/000005559.html advanced settings (yours is set to allow 802.11ac for both bands), this is normally controlled by your router. Some routers may discriminate one system over another based on priority lists or quality of service (QoS) settings, often based on how often a system connects or the type of content it accesses. For this, we can recommend trying the following:

NOTE: Any links provided for third party tools or sites are offered for your convenience and should not be viewed as an endorsement by Intel® of the content, products, or services offered there. We do not offer support for any third party tool mentioned here.

1. https://kb.netgear.com/30228/How-to-disable-20-40-MHz-Coexistence-on-a-NETGEAR-router Enable 20/40 MHz Coexistence (should help improve your 5GHz performance).

 

2. Make sure https://kb.netgear.com/30962/How-does-lowering-wireless-mode-affect-internet-speed-and-how-are-they-... Wireless Link Rate is set to highest setting possible.

 

3. Make sure that you're using the latest firmware release for your router: https://kb.netgear.com/000049374/R6400-Firmware-Version-1-0-1-26 Netgear R6400* Firmware.

 

4. Try toggling your router's current QoS settings.

 

1. http://www.downloads.netgear.com/files/GDC/R6400/R6400_UM_07Aug2015.pdf Netgear R6400* User Manual.

 

2. QoS information and rules starts on chapter 4, page 45. Explains QoS. You may check if there are any custom rules applied which may need to be disabled.

 

3. Steps on how to disable WMM QoS: Page 57

Let us know if this helps.

Best regards,

 

Carlos A.
DDiel
Novice
1,084 Views

I agree with your thoughts on the actual connection being a legacy connection...I noticed this when I noticed my link speed never goes above 54mbps, sometimes it drops to 18mbps in the properties for the wireless adapter if I watch it, ,regardless if its 2 ft from the router or 20ft.

One thing I noticed was that in advanced setting for the adapter at the very bottom is "wireless mode" and mine does not list anything besides a/b/g. it is currently on a/b/g and there is no option for 802.11n or 11ac....I am not sure if there should be or not?

I have actually already disabled all QoS settings including upstream and downstream QoS. Router settings for both 2.4 and 5 are maxed out for link speed, one was 400 something and the 5ghz is at 1300.

The 20/40 is enabled, if I remember right. That was one setting I googled to figure out what it was for.

I will Verify all of the settings you mentioned tonight and see what happens, Netgear only offers 90 days of support for there products which I am not very happy about but hopefully we can figure this out!

any other driver software to enable the n or ac mode or is this automatic?

idata
Community Manager
1,084 Views

Hello Dandiele,

That's normal. Here's is how these settings work:

For wireless-AC, you need to have the following:

1. Wireless Mode: 5. 802.11a/b/g

 

2. HT Mode: VHT (Very High Throughput) Mode.

To limit your adapter to Wireless-N, the same applies, but you would set your adapter to work in HT (High Throughput) Mode.

For older standards, you would disable HT Mode and adjust the Wireless Mode accordingly.

With these settings, your adapter will have Wireless-AC enabled. However, you can't force it only connect in that mode if the network is being broadcast in a legacy mode. Your adapter will automatically downshift accordingly, as wireless standards are backward compatible. In some cases a router may only let a client (computer) connect in legacy mode if it believes it's not a high priority system, which may be the case here. You could test by connecting to another Wireless-AC network to see if you experience the same behavior.

To check the connection type currently in use, you can run the following command:

1. In the search box on the taskbar, type Command prompt, press and hold (or right-click) Command prompt, and then select Run as administrator > Yes.

 

2. At the command prompt, type: netsh wlan show interface

This will show the radio type currently in use. Right now even though you have 802.11ac enabled, it will show 802.11g, for example.

You can run a similar command to show the supported radio types (plus a bunch of other data, you may need to scroll back up to find this): netsh wlan show driver

Let us know if this helps.

Best regards,

 

Carlos A.
DDiel
Novice
1,084 Views

Ok so I changed the roaming aggressiveness to the lowest setting and double checked my router settings, all seems ok. I found a software to give info on the wifi signal and It appears to be showing correct but for whatever reason the laptop seems to not connect in the best mode. It shows it as being an n, AC signal and the max speed of 1300mbps

I will attach some screenshots of the command prompt with info (I assume you already have). One thing I noticed was the 802.11a connection on 5g vs the 802.11g you suggested it would show. Currently I am on an old driver but the results are the same unfortunately, I was trying to do a clean install and noticed that upon reboot the drivers are installed automatically albeit an old version, I figured id try it anyway and no luck. I will go ahead and update and see what happens.

and why not I figured id share another speed test result http://www.speedtest.net/my-result/6833507265 Speedtest.net by Ookla - My Results

DDiel
Novice
1,084 Views

http://beta.speedtest.net/result/6833709811

WOW its working! I've never had these speeds on this laptop since I've owned it.....Basically I had to do the last thing I really wanted to do because re-setting up everything is a huge pain but I went ahead and did a full factory reset on my router. IT WORKED! I made sure that this laptop was the very first thing to connect (in case your thoughts on priority were accurate) and I was amazed. I will attach a scan so you can see if anything is different.

MCurt1
Beginner
1,084 Views

Yeah we have seen the same thing reported with some users who had their throughput mode set to HT instead of VHT - I see no mention of that particular setting

*correction there is mention of that I see - apologies

idata
Community Manager
1,084 Views

Hello Dandiele,

 

 

Looking at this updated report we're glad to confirm that you're now connecting to your network using 802.11ac, and receiving the full connection rate expected for this adapter (866.7 Mbps).

 

 

If you have any additional questions, or there's anything else we can help you with, don't hesitate to contact us again.

 

 

Best regards,

 

Carlos A.
Reply