oneAPI Registration, Download, Licensing and Installation
Support for Getting Started questions for Intel oneAPI Toolkits, Intel Parallel Studio XE and Intel System Studio
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
743 Discussions

Error about modulefiles in OneApi Base Toolkit installation directory.

mpi_new_user
New Contributor I
1,325 Views

Hi,

I have installed base toolkit successfully,and I run the script ' modulefiles-setup.sh'. It creates a folder.Everything seems ok.

I tried to load the MKL library by running the command line :

module load intel/mkl/2021.1.1

 

And I got an error like this:

Loading mkl version 2021.1.1

Loading intel/mkl/2021.1.1
ERROR: Unable to locate a modulefile for 'compiler-rt/2021.1.1'
ERROR: Load of requirement 'compiler-rt/2021.1.1' failed

Then I tried to run 'module load intel/compiler-rt/2021.1.1'.The command was executed successfully.So, I reloaded mkl.The error still happened.

 

[root@node1 intel]# module list 
Currently Loaded Modulefiles:
1) intel/mpi/2021.1.1 3) intel/compiler-rt32/2021.1.1 5) intel/tbb32/2021.1.1 7) intel/tbb32/latest 
2) intel/compiler-rt/2021.1.1 4) intel/tbb/2021.1.1 6) intel/tbb/latest 
[root@node1 intel]# module load intel/mkl/2021.1.1 
Loading mkl version 2021.1.1

Loading intel/mkl/2021.1.1
ERROR: Unable to locate a modulefile for 'compiler-rt/2021.1.1'
ERROR: Load of requirement 'compiler-rt/2021.1.1' failed

 

Please let me know if I'm missing something.Thanks.

0 Kudos
1 Solution
mpi_new_user
New Contributor I
1,290 Views

After I reinstall the toolkit,I can use the modulefiles without errors.

I think it has been solved.

Thanks.

View solution in original post

3 Replies
GouthamK_Intel
Moderator
1,309 Views

Hi,

Thanks for reaching out to us!

As your issue is related to oneAPI toolkit Installation/Setting up the environment, we are having a dedicated forum where any issues related to Getting Started questions (registration, sign up, download, licensing, or installation) are answered.

So, we are redirecting this thread there for a faster response.

Have a Good day!


Thanks & Regards

Goutham


mpi_new_user
New Contributor I
1,291 Views

After I reinstall the toolkit,I can use the modulefiles without errors.

I think it has been solved.

Thanks.

GouthamK_Intel
Moderator
1,277 Views

Hi, 

Thanks for the confirmation!

As this issue has been resolved, we will no longer respond to this thread. 

If you require any additional assistance from Intel, please start a new thread. 

Any further interaction in this thread will be considered community only. 

Have a Good day.


Thanks & Regards

Goutham


Reply