oneAPI Registration, Download, Licensing and Installation
Support for Getting Started questions related to download, Installation and licensing for Intel oneAPI Toolkits and software development tools.

Intel oneAPI Debian Repo Broken?

jperaltac
Novice
1,790 Views

Hello,

I tried to update and upgrade my debian repository and got this error :

Err:4 https://apt.repos.intel.com/oneapi all/main all intel-oneapi-pytorch amd64 1.13.10.1-47264
404 Not Found [IP: 23.12.123.108 443]
Fetched 89.1 MB in 9s (9,683 kB/s)
E: Failed to fetch https://apt.repos.intel.com/oneapi/pool/main/intel-oneapi-pytorch-1.13.10.1-47264_amd64.deb 404 Not Found [IP: 23.12.123.108 443]

 

Any suggestion or help, it is welcome.

 

Joaquin

0 Kudos
1 Solution
jperaltac
Novice
1,756 Views

I solved, by using :

sudo apt remove intel-oneapi-python

sudo apt autoremove

and reinstalling with :

sudo apt install intel-oneapi-python

 

Joaquín.

View solution in original post

0 Kudos
4 Replies
jperaltac
Novice
1,757 Views

I solved, by using :

sudo apt remove intel-oneapi-python

sudo apt autoremove

and reinstalling with :

sudo apt install intel-oneapi-python

 

Joaquín.

0 Kudos
whatheway
New Contributor I
1,581 Views
workhorse@workhorse-MS-7D91:~$ sudo apt remove intel-aikit


[sudo] password for workhorse:
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Package 'intel-aikit' is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


workhorse@workhorse-MS-7D91:~$ sudo apt autoremove


Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


workhorse@workhorse-MS-7D91:~$ sudo apt install intel-oneapi-python


Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following additional packages will be installed:
intel-oneapi-dal-daal4py-2023.1.0
intel-oneapi-dal-scikit-learn-intelex-2023.1.0
The following NEW packages will be installed:
intel-oneapi-dal-daal4py-2023.1.0
intel-oneapi-dal-scikit-learn-intelex-2023.1.0 intel-oneapi-python
0 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.


Need to get 0 B/281 MB of archives.
After this operation, 283 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Selecting previously unselected package intel-oneapi-dal-daal4py-2023.1.0.
(Reading database ... 261437 files and directories currently installed.)
Preparing to unpack .../intel-oneapi-dal-daal4py-2023.1.0_2023.1.0-46349_amd64.d
eb ...
Unpacking intel-oneapi-dal-daal4py-2023.1.0 (2023.1.0-46349) ...
Selecting previously unselected package intel-oneapi-dal-scikit-learn-intelex-20
23.1.0.
Preparing to unpack .../intel-oneapi-dal-scikit-learn-intelex-2023.1.0_2023.1.0-
46349_amd64.deb ...
Unpacking intel-oneapi-dal-scikit-learn-intelex-2023.1.0 (2023.1.0-46349) ...
Selecting previously unselected package intel-oneapi-python.
Preparing to unpack .../intel-oneapi-python_2023.1.0-46399_amd64.deb ...
Unpacking intel-oneapi-python (2023.1.0-46399) ...
Setting up intel-oneapi-dal-scikit-learn-intelex-2023.1.0 (2023.1.0-46349) ...
Setting up intel-oneapi-dal-daal4py-2023.1.0 (2023.1.0-46349) ...
Setting up intel-oneapi-python (2023.1.0-46399) ...


workhorse@workhorse-MS-7D91:~$ sudo apt install intel-aikit


Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following additional packages will be installed:
intel-aikit-getting-started intel-oneapi-common-licensing-2023.0.0
intel-oneapi-model-zoo intel-oneapi-modin intel-oneapi-mpi-2021.8.0
intel-oneapi-mpi-devel-2021.8.0 intel-oneapi-neural-compressor
intel-oneapi-pytorch intel-oneapi-tensorflow


The following NEW packages will be installed:
intel-aikit intel-aikit-getting-started
intel-oneapi-common-licensing-2023.0.0 intel-oneapi-model-zoo
intel-oneapi-modin intel-oneapi-mpi-2021.8.0 intel-oneapi-mpi-devel-2021.8.0
intel-oneapi-neural-compressor intel-oneapi-pytorch intel-oneapi-tensorflow
0 upgraded, 10 newly installed, 0 to remove and 0 not upgraded.


Need to get 462 MB/1,784 MB of archives.
After this operation, 2,197 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y


Err:1 https://apt.repos.intel.com/oneapi all/main all intel-oneapi-pytorch amd64 1.13.10.1-47264
404 Not Found [IP: 104.69.89.197 443]


E: Failed to fetch https://apt.repos.intel.com/oneapi/pool/main/intel-oneapi-pytorch-1.13.10.1-47264_amd64.deb 404 Not Found [IP: 104.69.89.197 443]


E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
0 Kudos
whatheway
New Contributor I
1,581 Views

workhorse@workhorse-MS-7D91:~$ sudo apt remove intel-aikit


[sudo] password for workhorse:
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Package 'intel-aikit' is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


workhorse@workhorse-MS-7D91:~$ sudo apt autoremove


Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


workhorse@workhorse-MS-7D91:~$ sudo apt install intel-oneapi-python


Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following additional packages will be installed:
intel-oneapi-dal-daal4py-2023.1.0
intel-oneapi-dal-scikit-learn-intelex-2023.1.0
The following NEW packages will be installed:
intel-oneapi-dal-daal4py-2023.1.0
intel-oneapi-dal-scikit-learn-intelex-2023.1.0 intel-oneapi-python
0 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.


Need to get 0 B/281 MB of archives.
After this operation, 283 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Selecting previously unselected package intel-oneapi-dal-daal4py-2023.1.0.
(Reading database ... 261437 files and directories currently installed.)
Preparing to unpack .../intel-oneapi-dal-daal4py-2023.1.0_2023.1.0-46349_amd64.d
eb ...
Unpacking intel-oneapi-dal-daal4py-2023.1.0 (2023.1.0-46349) ...
Selecting previously unselected package intel-oneapi-dal-scikit-learn-intelex-20
23.1.0.
Preparing to unpack .../intel-oneapi-dal-scikit-learn-intelex-2023.1.0_2023.1.0-
46349_amd64.deb ...
Unpacking intel-oneapi-dal-scikit-learn-intelex-2023.1.0 (2023.1.0-46349) ...
Selecting previously unselected package intel-oneapi-python.
Preparing to unpack .../intel-oneapi-python_2023.1.0-46399_amd64.deb ...
Unpacking intel-oneapi-python (2023.1.0-46399) ...
Setting up intel-oneapi-dal-scikit-learn-intelex-2023.1.0 (2023.1.0-46349) ...
Setting up intel-oneapi-dal-daal4py-2023.1.0 (2023.1.0-46349) ...
Setting up intel-oneapi-python (2023.1.0-46399) ...


workhorse@workhorse-MS-7D91:~$ sudo apt install intel-aikit


Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following additional packages will be installed:
intel-aikit-getting-started intel-oneapi-common-licensing-2023.0.0
intel-oneapi-model-zoo intel-oneapi-modin intel-oneapi-mpi-2021.8.0
intel-oneapi-mpi-devel-2021.8.0 intel-oneapi-neural-compressor
intel-oneapi-pytorch intel-oneapi-tensorflow


The following NEW packages will be installed:
intel-aikit intel-aikit-getting-started
intel-oneapi-common-licensing-2023.0.0 intel-oneapi-model-zoo
intel-oneapi-modin intel-oneapi-mpi-2021.8.0 intel-oneapi-mpi-devel-2021.8.0
intel-oneapi-neural-compressor intel-oneapi-pytorch intel-oneapi-tensorflow
0 upgraded, 10 newly installed, 0 to remove and 0 not upgraded.


Need to get 462 MB/1,784 MB of archives.
After this operation, 2,197 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y


Err:1 https://apt.repos.intel.com/oneapi all/main all intel-oneapi-pytorch amd64 1.13.10.1-47264
404 Not Found [IP: 104.69.89.197 443]


E: Failed to fetch https://apt.repos.intel.com/oneapi/pool/main/intel-oneapi-pytorch-1.13.10.1-47264_amd64.deb 404 Not Found [IP: 104.69.89.197 443]


E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

 

Solution doesn't solve the pytorch problem.

0 Kudos
whatheway
New Contributor I
1,538 Views

workhorse@workhorse-MS-7D91:~$ sudo apt remove intel-oneapi-python

sudo apt autoremove

Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:


intel-aikit : Depends: intel-oneapi-python (>= 2023.0.0-25636)
Depends: intel-oneapi-pytorch (>= 1.13.0.0-31759)
Depends: intel-oneapi-modin (>= 0.17.0.1-31755)
intel-oneapi-neural-compressor : Depends: intel-oneapi-python (>= 2023.0.0-25636)
intel-oneapi-tensorflow : Depends: intel-oneapi-python (>= 2023.0.0-25636)


E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done


You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
intel-aikit : Depends: intel-oneapi-pytorch (>= 1.13.0.0-31759)
Depends: intel-oneapi-modin (>= 0.17.0.1-31755)
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).


workhorse@workhorse-MS-7D91:~$ sudo apt install intel-oneapi-python
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
intel-oneapi-python is already the newest version (2023.1.0-46399).
intel-oneapi-python set to manually installed.


You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
intel-aikit : Depends: intel-oneapi-pytorch (>= 1.13.0.0-31759)
Depends: intel-oneapi-modin (>= 0.17.0.1-31755)
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

0 Kudos
Reply