Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Worawan_D_
Beginner
147 Views

An assertion failure on VTune Amplifier Update 4

Jump to solution

Hi there, 

Please help. The VTune Amplifier XE update 4 (Windows 10 64-bit, VS2015 Enterprise) crashes when finalizing results. I have tried to uninstall and reinstall again. However, it doesn't help. The same error occurs on both VS2015 integration and the GUI. 

Here are the first part of the crash log messages. 

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

[Process]
Process Name: amplxe-eil-bridge.exe
Virtual Memory Size: 775632K
Working Set Size: 223784K

[Assertion]
CrashedPID: 7232
CrashedTID: 10488
Expression: Can't properly initialize leveldb cache.
File: C:\bb\INNLphep2w6r\b\b\tmpnxqvft\vcs\dbinterface1\src\sqlite\timelinedb\timeline_fill_helper_impl.cpp
Line: 42
Product: Intel(R) VTune(TM) Amplifier XE 2016; 470476
ReportPath: C:\temp\amplxe-log-wdc\2016-07-28-Thu-17-06-31-453.amplxe-eil-bridge.exe\

[Process]
Process Name: amplxe-gui.exe
Virtual Memory Size: 677376K
Working Set Size: 226276K

[Assertion]
CrashedPID: 9164
CrashedTID: 7672
Expression: Can't properly initialize leveldb cache.
File: C:\bb\INNLphep2w6r\b\b\tmpnxqvft\vcs\dbinterface1\src\sqlite\timelinedb\timeline_fill_helper_impl.cpp
Line: 42
Product: Intel(R) VTune(TM) Amplifier XE 2016; 470476
ReportPath: C:\temp\amplxe-log-wdc\2016-07-28-Thu-17-15-37-942.amplxe-gui.exe\


[Products]
Package ID: N/A
Package Contents: Intel(R) VTune(TM) Amplifier XE 2016 Update 4
Build Number: 470476

0 Kudos
1 Solution
147 Views

 

Hello,

Please check remaining crash log text and see if there is an error:  "Key not valid for use in specified state"?

If yes - then please apply the workaround described on Microsoft site:

http://answers.microsoft.com/en-us/windows/forum/windows8_1-security/key-not-valid-for-use-in-specif...

For "Key not valid for use in specified state" errors try moving the folder RSA from C:\Users\<User>\AppData\Roaming\Microsoft\Crypto\RSA to say C:\RSA (just in case there should be a need to restore it) then try installing again. This folder appears to act as a cache and should be rebuilt automatically as required.

 

Regards, Katya

View solution in original post

3 Replies
148 Views

 

Hello,

Please check remaining crash log text and see if there is an error:  "Key not valid for use in specified state"?

If yes - then please apply the workaround described on Microsoft site:

http://answers.microsoft.com/en-us/windows/forum/windows8_1-security/key-not-valid-for-use-in-specif...

For "Key not valid for use in specified state" errors try moving the folder RSA from C:\Users\<User>\AppData\Roaming\Microsoft\Crypto\RSA to say C:\RSA (just in case there should be a need to restore it) then try installing again. This folder appears to act as a cache and should be rebuilt automatically as required.

 

Regards, Katya

View solution in original post

Worawan_D_
Beginner
147 Views

Hi Katya,

Thanks a lot. Indeed, the log error said that  "Key not valid for use in specified state". After moving the RSA key, it works! 

147 Views

Glad to hear, thanks for letting us know and quick confirmation!

Reply