Community support for Analyzers (Intel VTune™ Profiler, Intel Advisor, Intel Inspector)
4922 Discussions

Could not connect to remote machine


I have vtserver running on linux and I have installed VTune with the remote agent on Windows 7. I have specified the hostname to connect to in the Advanced Activity configuration wizard. When I click on "Apply" after specifying all arguments I get an error saying that its not unable to connect to the remote machine. Exact message:

Could not connect to remote machine ..... A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to reponsd. Error no.:(10060) (WSAETIMEDOUT).

I am using version 9.1 Build 385.
Please help me fix this.

Should I run insmod-vtune as well?

0 Kudos
3 Replies

There are a few things that could be causing the issue here.
First - what version of VTune Analyzer are you running on your Windows 7 machine? In certain cases the version of vtserver on target may not be compatible with the installation on the host.

Next, did you get any messages when you started vtserver on the target system?

Finally, this is often caused by an actual networking issue. Please make sure you are able to ping back and forth between the 2 machines. If you have to use a fully qualified hostname or the IP address to ping to the remote system, make sure you use that same name or IP in the VTune Analyzer configuration wizard. Also try connecting the Linux machine using some other utility like SSH or FTP to make sure that works. If you have a firewall running on your Linux machine, you will need to allow VTune Analyzer to connect to it.

Please check on those things and then update this issue again with the status.



0 Kudos
Thank you for replying.

The version of Vtune analyzer on Windows 7 is 9.1 (build 385)
The version of vtserver on linux is 9.1 as well.

I am able to SSH to the linux machine. In fact thats the only I have access it as its in a different location. I am able to ping to/from both windows and linux machines. I also tried with both the hostname and the ipaddress in the configuration wizard on windows. I am not sure if there is a firewall on the linux machine but am guessing that since I am able to connect to it using SSH, it won't be an issue?

There were a few messages on linux when I started vtserver but none of them seemed unusual. One thing to note though is that I NOT running vtserver as root. But I do have access to the global_data folder and I am part of the vtune group. vtune_drv also appears in the output of lsmod.

Here are the messages(edited):

Setting up ISM environment ...
Setting up Remote Data Collection environment ...
vtlistenerd: 04/30/10 23:44:10 ======================================================

vtlistenerd: 04/30/10 23:44:10 VTune Performance Analyzer Remote Agent for Linux*
vtlistenerd: 04/30/10 23:44:10 Copyright (C) 2002-2008 Intel Corporation

vtlistenerd: 04/30/10 23:44:10 -- Remote Agent --------------
vtlistenerd: 04/30/10 23:44:10 server version: v9.1

0 Kudos
OK, I have a few suggestions. First, there likely is a firewall on the system, with the SSH port open. Can you work with your system admin to ensure that ports 50000 and 50001 are open? These are the ones that the VTune remote agent uses. The port numbers are also configurable if necessary using the -p option. See the help output (vtserver -h) for more information on configuring the port.

The other thing you should do, after getting your ports opened on the remote system, is to run vtserver with the -v option. This will print out verbose output. When you try again, start vtserver with the -v, and when you try to connect from the client using the wizard, you should see output from vtserver telling you what it is doing. If there is no output at all, you know that the request is never reaching the server. If there is output it should tell you either that the connection was established or give you an idea of the problem.

Try these things and let us know if it gets resolved.
0 Kudos