Analyzers
Support for Analyzers (Intel VTune™ Profiler, Intel Advisor, Intel Inspector)
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
4556 Discussions

Error message "Amplifier cannot detect local machine configuration".

Kurz__Heidi
Beginner
379 Views

Hi ,

in the sommer 2018 I have installed VTune_Amplifier_2018_update2_setup and my operating system is Windows 10.

At the beginning VTune works fine and all was OK. 

For two weeks now I cannot profile with VTune. I can start the tool, but if I want to start a profile session I always get the error message: 

"Amplifier cannot detect local machine configuration"

I removed the installation and installed it again but the error message has remained.

Best regards, 

Heidi

 

 

 

.

0 Kudos
11 Replies
Kirill_U_Intel
Employee
379 Views

Hi, Heidi.

Could you provide some info from vtune tools?

We need output from

VTUNE_INSTALL_DIR\bin64\amplxe-runss.exe --context-value-list

and

VTUNE_INSTALL_DIR\bin64\sep.exe -version

Thanks, Kirill

Kurz__Heidi
Beginner
379 Views

Hi Kirill,

here is my output:

c:\Program Files (x86)\IntelSWTools\VTune Amplifier 2018\bin64>amplxe-runss.exe --context-value-list
amplxe: Error: Unknown option: --no-altstack

 

c:\Program Files (x86)\IntelSWTools\VTune Amplifier 2018\bin64>sep.exe -version
Sampling Enabling Product version: 4.1 built on Mar  8 2018 01:23:43
SEP User Mode Version: 4.1.0
SEP Driver Version: 4.1.0
PAX Driver Version: 1.0.2
Platform type: 103
CPU name: Intel(R) Processor code named Skylake
PMU: skylake
Driver configs: Maskable Interrupt, PEBS OFF (by OS security)
Copyright(C) 2007-2018 Intel Corporation. All rights reserved.

 

Best regards, 

Heidi

 

 

 

Kirill_U_Intel
Employee
379 Views

Does the 32-bit amplxe-runss produce error about incorrect option  too?

 c:\Program Files (x86)\IntelSWTools\VTune Amplifier 2018\bin32>amplxe-runss.exe --context-value-list

could you provide output from --help option for both 32 and 62 bit amplxe-runss?

Kirill

Kurz__Heidi
Beginner
379 Views

Here are the outputs:

c:\Program Files (x86)\IntelSWTools\VTune Amplifier 2018\bin32>amplxe-runss.exe --context-value-list
amplxe: Error: Unknown option: --no-altstack

 

c:\Program Files (x86)\IntelSWTools\VTune Amplifier 2018\bin32>amplxe-runss.exe --help
amplxe: Error: Unknown option: --no-altstack

c:\Program Files (x86)\IntelSWTools\VTune Amplifier 2018\bin64>amplxe-runss.exe --help
amplxe: Error: Unknown option: --no-altstack

BR, Heidi

Kirill_U_Intel
Employee
379 Views

Very strange. The error of amplxe-runss option is the reason of "Amplifier cannot detect local machine configuration"

but it is not clear what is wrong with amplxe-runss.

in your experiments we don't send --no-altstack option to runss but it is always there. Looks like 'amplxe-runss --bla-bla-bla' will produce the same issue :( is it true?

Kirill

Kurz__Heidi
Beginner
379 Views

The tool amplxe-runss is available, but it seems not to work.

Here are the outputs again:

c:\Program Files (x86)\IntelSWTools\VTune Amplifier 2018\bin64>amplxe-runss
Intel(R) VTune(TM) Amplifier Data Collector
Copyright (C) 2009-2018 Intel Corporation. All rights reserved.

Usage: amplxe-runss [options] [[--] <application> [arguments]]

Example: amplxe-runss -- vtunedemo


c:\Program Files (x86)\IntelSWTools\VTune Amplifier 2018\bin64>amplxe-runss --bla
amplxe: Error: Unknown option: --no-altstack

c:\Program Files (x86)\IntelSWTools\VTune Amplifier 2018\bin64>amplxe-runss --no-altstack
amplxe: Error: Unknown option: --no-altstack

 

 

 

 

Kirill_U_Intel
Employee
379 Views

Probably the something wrong with environment

Could you send 'set' output from the console where you run amplxe-runss?

Kurz__Heidi
Beginner
379 Views

OK, here is my set output:

 

c:\Program Files (x86)\IntelSWTools\VTune Amplifier 2018\bin64>set
ALLUSERSPROFILE=C:\ProgramData
AMPLXE_RUNTOOL_OPTIONS=--no-altstack
ANT_HOME=d:\tools\install\ant\apache-ant-1.9.7\
APPDATA=C:\Users\hku\AppData\Roaming
COMMANDER_DRIVE=C:
COMMANDER_EXE=C:\Program Files\Totalcmd\TOTALCMD64.EXE
COMMANDER_INI=C:\Users\hku\AppData\Roaming\Ghisler\wincmd.ini
COMMANDER_PATH=C:\Program Files\Totalcmd
CommonProgramFiles=C:\Program Files\Common Files
CommonProgramFiles(x86)=C:\Program Files (x86)\Common Files
CommonProgramW6432=C:\Program Files\Common Files
COMPUTERNAME=PTV-D18-BE0087
ComSpec=C:\Windows\system32\cmd.exe
EmpirumServer=SKA-WN-EMPIRUM.PTVAG.PTV.DE
EmpirumServicePartition=0
FPS_BROWSER_APP_PROFILE_STRING=Internet Explorer
FPS_BROWSER_USER_PROFILE_STRING=Default
HOMEDRIVE=U:
HOMEPATH=\
HOMESHARE=\\fs-homeshares.ptvag.ptv.de\home$\Heidi.Kurz
JAMTHREADS=6
JAVA8_HOME_64=c:\Program Files\Java\jdk1.8.0_152\
JAVA_HOME=c:\Program Files\Java\jdk1.8.0_152\
JAVA_HOME_64=c:\Program Files\Java\jdk1.8.0_152\
LOCALAPPDATA=C:\Users\hku\AppData\Local
LOGONSERVER=\\SKA-WN-DC02
MapDir=m:/data/maps/binary/
MAP_DIR=m:/data/maps/binary/
MAVEN_HOME=d:\tools\install\maven\apache-maven-3.3.9\
MAVEN_OPTS=-Xms2G
NUMBER_OF_PROCESSORS=8
OneDrive=C:\Users\hku\OneDrive
OS=Windows_NT
Path=c:\Program Files\Java\jdk1.8.0_152\\bin;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\iCLS\;C:\Program Files\Intel\Intel(R) Management Engine Components\iCLS\;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Windows\SysWOW64\Empirum;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files\Intel\Intel(R) Management Engine Components\IPT;C:\Users\hku\.dnx\bin;C:\Program Files\Microsoft DNX\Dnvm\;C:\Program Files (x86)\Windows Kits\8.1\Windows Performance Toolkit\;C:\Program Files\Microsoft SQL Server\120\Tools\Binn\;C:\Program Files\SlikSvn\bin;C:\Program Files\TortoiseSVN\bin;C:\Program Files\Git\cmd;C:\Program Files\Microsoft SQL Server\130\Tools\Binn\;d:\tools\install\maven\apache-maven-3.3.9\\bin;d:\tools\install\ant\apache-ant-1.9.7\\bin;C:\Program Files (x86)\Microsoft SQL Server\100\Tools\Binn\;C:\Program Files\Microsoft SQL Server\100\Tools\Binn\;C:\Program Files\Microsoft SQL Server\100\DTS\Binn\;C:\Program Files\PuTTY\;C:\Program Files\TortoiseGit\bin;C:\Users\hku\AppData\Local\Microsoft\WindowsApps;c:\Program Files\PuTTY\;
PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC
PROCESSOR_ARCHITECTURE=AMD64
PROCESSOR_IDENTIFIER=Intel64 Family 6 Model 94 Stepping 3, GenuineIntel
PROCESSOR_LEVEL=6
PROCESSOR_REVISION=5e03
ProgramData=C:\ProgramData
ProgramFiles=C:\Program Files
ProgramFiles(x86)=C:\Program Files (x86)
ProgramW6432=C:\Program Files
PROMPT=$P$G
PSModulePath=C:\Program Files\WindowsPowerShell\Modules;C:\Windows\system32\WindowsPowerShell\v1.0\Modules
PUBLIC=C:\Users\Public
SESSIONNAME=Console
SystemDrive=C:
SystemRoot=C:\Windows
TEMP=d:\temp\hku\
TMP=d:\temp\hku\
USERDNSDOMAIN=PTVAG.PTV.DE
USERDOMAIN=PTVAG
USERDOMAIN_ROAMINGPROFILE=PTVAG
USERNAME=hku
USERPROFILE=C:\Users\hku
VS100COMNTOOLS=C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\Tools\
VS110COMNTOOLS=C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\Tools\
VS120COMNTOOLS=C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\Tools\
VS140COMNTOOLS=C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\Tools\
VTUNE_AMPLIFIER_2018_DIR=C:\Program Files (x86)\IntelSWTools\VTune Amplifier 2018\
windir=C:\Windows

 

 

Kirill_U_Intel
Employee
379 Views

could you unset this AMPLXE_RUNTOOL_OPTIONS=--no-altstack?

just set AMPLXE_RUNTOOL_OPTIONS=

BTW, did you add it yourself?

Kirill

Kurz__Heidi
Beginner
379 Views

Hi Kirill, 

I dont't know why I have had this environment variable.

I removed it and now VTune works again!

Many thanks, Heidi

 

Kirill_U_Intel
Employee
379 Views

Glad to hear that all is fine now.

Kirill

Reply