Analyzers
Support for Analyzers (Intel VTune™ Profiler, Intel Advisor, Intel Inspector)
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
4679 Discussions

Internal collection error has occured

gonnet
Beginner
165 Views
Hi,
I'm using the Intel VTune Amplifier XE 2011 on Ubuntu Linux 10.10 (kernel 2.6.35-28-generic-pae)running on an Intel Core i5 CPU. I am using a sep3_1 driver compiled from the supplied source which seems to load correctly:
$ sudo /opt/intel/vtune_amplifier_xe_2011/sepdk/src/insmod-sep3
Checking for PMU arbitration service (PAX) ... detected.
PAX service is accessible to users in group "vtune".
Executing: insmod /opt/intel/vtune_amplifier_xe_2011/sepdk/src/sep3_1-x32-2.6.35-28-generic-paesmp.ko
Creating /dev/sep3_1 base devices with major number 249 ... done.
Creating /dev/sep3_1 percpu devices with major number 248 ... done.
Setting group ownership of devices to group "vtune" ... done.
Setting file permissions on devices to "660" ... done.
The sep3_1 driver has been successfully loaded.
I am trying to perform a "Hotspot" analysis on a "Launch Application" target, yet I get the following error:
Collection failed
Collection failed. The data cannot be displayed.
Error: Internal collection error has occured. Please contact the technical support.
Running a "Lightweight Hotspots" analysis, however, works just fine.
Please do let me know if you need more information.
Kind Regards,
Pedro Gonnet
0 Kudos
3 Replies
Vladimir_T_Intel
Moderator
165 Views
Hi,
The Ubuntu Linux 10.10 is not fully supported byVTune Amplifier XE 2011 - see the Release Notes.
"VTune Amplifier XE supports Ubuntu* 10.10 default configuration only for event-based sampling analysis in the command line mode. To see how to enable all other types of analysis and GUI results analysis please follow to the solutions described in the Known Limitation section, items 200197559, 200197563 of the document."
gonnet
Beginner
165 Views
Ok, thanks for the pointer! The following
$ sudo sysctl -w kernel/yama/ptrace_scope=0
fixed the problem.
Vladimir_T_Intel
Moderator
165 Views
Good to know it helped!
Reply