Community
cancel
Showing results for 
Search instead for 
Did you mean: 
jwongx
Employee
442 Views

Need Help to Build Sampling Driver for VTune Running in Linux 5.11 Kernel

Jump to solution

Hi,

I am trying to build the sampling driver provided in VTune 2021.1.1 running on Ubuntu 20.04 with kernel 5.11. However, I encounter errors while building it:

------------------- Building sep driver --------------------
/bin/make -C /lib/modules/5.11.0-051100rc7-generic/build M=/opt/intel/oneapi/vtune/2021.1.1/sepdk/src LDDINCDIR=/opt/intel/oneapi/vtune/2021.1.1/sepdk/src/../include LDDINCDIR1=/opt/intel/oneapi/vtune/2021.1.1/sepdk/src/inc modules PWD=/opt/intel/oneapi/vtune/2021.1.1/sepdk/src -j4
make[1]: Entering directory '/usr/src/linux-headers-5.11.0-051100rc7-generic'
CC [M] /opt/intel/oneapi/vtune/2021.1.1/sepdk/src/lwpmudrv.o
CC [M] /opt/intel/oneapi/vtune/2021.1.1/sepdk/src/control.o
CC [M] /opt/intel/oneapi/vtune/2021.1.1/sepdk/src/cpumon.o
CC [M] /opt/intel/oneapi/vtune/2021.1.1/sepdk/src/eventmux.o
CC [M] /opt/intel/oneapi/vtune/2021.1.1/sepdk/src/linuxos.o
CC [M] /opt/intel/oneapi/vtune/2021.1.1/sepdk/src/output.o
CC [M] /opt/intel/oneapi/vtune/2021.1.1/sepdk/src/pmi.o
/opt/intel/oneapi/vtune/2021.1.1/sepdk/src/linuxos.c: In function ‘linuxos_Get_Exec_Mode’:
/opt/intel/oneapi/vtune/2021.1.1/sepdk/src/linuxos.c:129:32: error: ‘TIF_IA32’ undeclared (first use in this function)
129 | if (test_tsk_thread_flag(p,TIF_IA32)) {
| ^~~~~~~~
/opt/intel/oneapi/vtune/2021.1.1/sepdk/src/linuxos.c:129:32: note: each undeclared identifier is reported only once for each function it appears in
make[2]: *** [scripts/Makefile.build:279: /opt/intel/oneapi/vtune/2021.1.1/sepdk/src/linuxos.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[1]: *** [Makefile:1806: /opt/intel/oneapi/vtune/2021.1.1/sepdk/src] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-5.11.0-051100rc7-generic'
make: *** [Makefile:204: default] Error 2
failed

 I came across the https://community.intel.com/t5/Analyzers/Failed-to-Build-Sampling-Driver-with-5-10-3-kernel-on-Ubunt... post and it seems we have different errors with the 5.11 kernel. Is there any workaround to build and install the sampling driver? 

Labels (1)
0 Kudos
1 Solution
Vladimir_T_Intel
Moderator
249 Views

Hello,

Linux kernels version 5.11 and later will be supported by VTune 2021.2.0.

View solution in original post

5 Replies
Kirill_U_Intel
Employee
392 Views

Hi.

Did you have 5.11 rc7? Could you try to upgrade on v5.11? will it fail again?

I could not reproduce the same issue on my side?

uname -a
Linux nnltcar128-141 5.11.0 #1 SMP Wed Feb 17 13:55:17 MSK 2021 x86_64 x86_64 x86_64 GNU/Linux

Kirill

jwongx
Employee
376 Views

Hi Kirill,

Yes I was using 5.11 rc7. I upgraded to the 5.11 non rc version and still getting the same error previously.

Linux ubuntu 5.11.0-051100-generic #202102142330 SMP Sun Feb 14 23:33:21 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

 Thanks, 
Janan

Nico_G
Employee
313 Views

Hello @Kirin,

We are observing the same problem with kernel 5.11. Do you have a workaround patch to build the SEP kernel drivers for 5.11? 

 

Vladimir_T_Intel
Moderator
250 Views

Hello,

Linux kernels version 5.11 and later will be supported by VTune 2021.2.0.

View solution in original post

AthiraM_Intel
Moderator
288 Views

Hi,


We are forwarding your case to subject matter experts.


Thanks


Reply