Community
cancel
Showing results for 
Search instead for 
Did you mean: 
60 Views

Not all threads are seen in the Hardware Event-Based Sampling mode

I use VTune for finding hotspots in my multithreading C++ app on Windows 10. Dutation time estimate - less than minute. Fast finalizion mode. Everything works fine in User-Mode sampling type (except the accuracy of measurement because it's a realtime simulation app). But when I try to use Hardware-Based sampling with intervals of sampling: 1ms, 0.1ms, 0.05ms - all threads except the main (which is the most interesting for researching) are correct, but the main thread is not visible. I tried to reinstalling and restarting Intel sampling drivers, everything were succusfelly set up. My Processor    Intel(R) Core(TM) i7-9700K CPU @ 3.60GHz, 3600 Mhz, 8 Core(s), 8 Logical Processor(s). OS Version    10.0.17763 Build 17763. Intel VTune Amplifier 2019 Update 4 - 597835
What can me help with this problem? Thank you

0 Kudos
2 Replies
Vladimir_R_Intel
Employee
60 Views

Hi Mikhail,

Did you try both variants HW-based sampling with stacks and without? (it is important so as two different drivers work in these modes)

Is it possible to upload a reproducer here?

BR,

Vladimir

60 Views

Thank you, for your answer. It helps. I have tried to use HW-based sampling without stacks and it started to work correctly, but... not the best stack information of course ( Unfortunatly, it's not possible to upload the reproducer, but I can try to code a new small project with a hope of reproducing the bug.