Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Muktadir_C_Intel
Employee
221 Views

error: "/opt/intel/vtune_amplifier_2019.0.2.570779/bin64/../lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by

I have installed vtune 2019 stand-alone version from here on Fedora 27. After that I installed it using install_GUI.sh. After the installation was complete, when I run vtune (using amplxe-gui command). vtune is starting but I am getting the following error:  "/opt/intel/vtune_amplifier_2019.0.2.570779/bin64/../lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /lib64/libproxy.so.1)". 

I am getting the same error when I am trying to collect data of an application. Can anybody help me with this?

Muktadir

0 Kudos
4 Replies
Vitaly_S_Intel
Employee
221 Views

Hi Muktadir,

Does it affect VTune GUI? I mean - can you still see VTune UI, configure project, start collection and view the results?

Muktadir_C_Intel
Employee
221 Views

No I am not having any problem to do any of the above. So I guess I can ignore the error message?

Muktadir

Vitaly_S_Intel
Employee
221 Views

Yes, you can simply ignore these messages in command line.
Tello__Alexis
Beginner
221 Views

Hi to everyone,

First off i have the following intel compilers version: icc (ICC) and ifort 19.0.3.199 20190206

I have a similar issue but contrary to OP It is a fatal error for me. In short the following is happening,

I have installed intel compilers, have compiled my application which links to VTK (imaging software). I have previously compiled VTK with the GNU compilers (version 8.3). Upon execution of my code the following error appears

/opt/intel/clck/2019.2.1/lib/intel64/libstdc++.s/opt/intel/clck/2019.2.1/lib/intel64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by XXXXX.OMPINTEL)
/home/XXXXXX.OMPINTEL: /opt/intel/clck/2019.2.1/lib/intel64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /home/XXXXXX.OMPINTEL)o.6: version `GLIBCXX_3.4.21' not found (required by /home/XXXXXX.OMPINTEL)
 

as well as

/home/XXXXXX.OMPINTEL: /opt/intel/clck/2019.2.1/lib/intel64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /home/XXXXXX/VTK-8.2.0/lib/libvtkFiltersGeneral-8.2.so.1)

So I can see that my application as well as the VTK installation require this libstdc++.so.6 which IS present at /opt/intel/clck/2019.2.1/lib/intel64/ so I can guess that maybe the version is not the correct one OR even though it is there at that location it cannot access it.

I have tried the following to no avail:

-Compile my application with the flags  -D_GLIBCXX_USE_CXX11_ABI=0 and -lstd-cxx-11 (or the correct version of this as now I do not recall)

-set PATH, LD_LIBRARY_PATH and LIBRARY PATH as follows:

 export LIBRARY_PATH="$LIBRARY_PATH:/opt/intel/lib/intel64";
 export LD_LIBRARY_PATH="$LD_LIBRARY_PATH:/opt/intel/lib/intel64";
 export LD_LIBRARY_PATH="$LD_LIBRARY_PATH:/opt/intel/clck/2019.2.1/lib/intel64/";
 export PATH=/opt/intel/clck/2019.2.1/lib/intel64:$PATH;
 export PATH=/opt/intel/lib/intel64:$PATH;
 export PATH=/usr/bin:$PATH;

At this point I do not know how to proceed and I thank any advise you can give as I cannot use the intel compilers without this fix. The execution and both my code and VTK work with the GNU compilers without problem, so it is for sure something that I am linking incorrectly to the intel compilers.

Regards,

Reply