Community
cancel
Showing results for 
Search instead for 
Did you mean: 
pdiener68
Beginner
63 Views

Optimization Report button doesn't work.

I have been playing around with vtune 9.1 on a machine with x86_64 OpenSuse
11.1 (kernel 2.6.27.21-0.1) and have the problem that the Optimization Report
button does not open the Opt Report window, so I'm never given the chance
to tell vtune where my optimization report file is located.

I found some information that in vtune 8.0 it was necessary to have the
environment variable VT_ENABLE_OPTIMIZATION_REPORT set to ON, so I tried
that but with no effect.

Any ideas?

Otherwise vtune seem to function properly on my system.
0 Kudos
7 Replies
David_A_Intel1
Employee
63 Views

Did you follow these steps?
  1. In the source view, identify and select the source line(s) that caused the performance issue.
  2. Click Optimization Report in the source view toolbar to view the optimization report.
    The File Open dialog box opens.
  3. In the File Open dialog box, locate the optimization report file created by the compiler.
    The Opt Report view opens.

If so, and it still didn't work, what exactly happened when you pressed the Opt Report button?

pdiener68
Beginner
63 Views

Did you follow these steps?
  1. In the source view, identify and select the source line(s) that caused the performance issue.
  2. Click Optimization Report in the source view toolbar to view the optimization report.
    The File Open dialog box opens.
  3. In the File Open dialog box, locate the optimization report file created by the compiler.
    The Opt Report view opens.

If so, and it still didn't work, what exactly happened when you pressed the Opt Report button?

Yes, I am in the source view, I have selected a source line but when I click
Optimization Report
the File Open dialog box does not open. In fact nothing happens, so I never get to step 3.

Vladimir_T_Intel
Moderator
63 Views

Please, let us know which compiler and its version you were using for the application.

David_A_Intel1
Employee
63 Views

Actually, please execute the vtqfagent script, as 'root', in the installation directory, typically, /opt/intel/vtune. Note: do NOT redirect the script's output; this is done automatically and status messages are displayed on stdout. Once the script completes, it informs you of the log file name and location. Then, look in the log file for the "Checking IA32 emulation packages" section and for any other missing 'required' software. It sounds like the analyzer is unable to present the Open File dialog and, thus, some resources might be missing on your system.

Which Linux and which version are you using?

sisharma80
Beginner
63 Views

Quoting - pdiener68
I have been playing around with vtune 9.1 on a machine with x86_64 OpenSuse
11.1 (kernel 2.6.27.21-0.1) and have the problem that the Optimization Report
button does not open the Opt Report window, so I'm never given the chance
to tell vtune where my optimization report file is located.

I found some information that in vtune 8.0 it was necessary to have the
environment variable VT_ENABLE_OPTIMIZATION_REPORT set to ON, so I tried
that but with no effect.

Any ideas?

Otherwise vtune seem to function properly on my system.

I am also facing the similar problem where Optimization Report button doesn't work at all.

Here are the details of my run time environment:

1. Custom Suse 10.2 x86 Linux with kernel version 2.6.18-34.

2. Compiler is gcc 3.3.x

3. vtune 9.1

I was able to build sampling driver for my OS but couldn't use it since it caused the kernel to panic.

Anyway, I ran the vtune analyzer as follows:

> vtl activity -d 2000 -c callgraph -app -moi run

Once done with analysis, I packed the project and copied to another system with GUI support. Here I opened up the project and provided the source code path. I was able to view the hotspots but couldn't make "optimization report" option to work.

As suggested by MrAnderson, I also ran the vtqfagent script on the server where the analysis was taken. In the log file, generated by vtqfagent script, there was no "Checking IA32 emulation packages" section. May be everything was alright??

Any suggestions??

Thanks & Regards,

sisharma80

Vladimir_T_Intel
Moderator
63 Views

Quoting - sisharma80

I am also facing the similar problem where Optimization Report button doesn't work at all.

Here are the details of my run time environment:

1. Custom Suse 10.2 x86 Linux with kernel version 2.6.18-34.

2. Compiler is gcc 3.3.x

3. vtune 9.1


As far as I remembmer you can't use VTune Opt Report feature with gcc compiler. In order to enable this feature you need to compile the application with Intel compiler 9.1 or higher (add the -opt-report compilation option).
sisharma80
Beginner
63 Views


As far as I remembmer you can't use VTune Opt Report feature with gcc compiler. In order to enable this feature you need to compile the application with Intel compiler 9.1 or higher (add the -opt-report compilation option).

Thanks for the reply.

Regards,

sisharma80

Reply