Analyzers
Support for Analyzers (Intel VTune™ Profiler, Intel Advisor, Intel Inspector)
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
For the latest information on Intel’s response to the Log4j/Log4Shell vulnerability, please see Intel-SA-00646
4578 Discussions

Running my VS2008 application in Intel Inspector 2020 update 2 crashes

bmahf
Beginner
534 Views

I am new to using Intel Inspector.  My company has an application that we are trying to inspect for memory leaks and your tool was suggested.  The application is C++ with the Root GUI package built in VS2008.  I have followed all the instructions for setting up my application for inspection, including making sure that it contains debug symbols (Program Database (/Zi)), all optimization is disabled, run time library is Multi-threaded DLL (/MD), and the linker has Generate Debug Info as Yes (/DEBUG).

When I set up the Inspector project, I gave it the path to the executable to be inspected, and for Binary/Symbol Search tab I added full path to the pdb file produced when the project was built.  For the Source Search tab I added full path entries for all of the DLL dependencies.

I create a new analysis for the project and select Detect Leaks.  When I click Start, I can see that the libraries are being loaded as the application starts up, but where I would expect the application to start the whole way and for me to be able to interact with it, the application crashes and I see the Windows dialog asking whether I want to check online for a solution or close the program.  I choose to close the program and the Inspector reports the target has finished running.

In the Collector Messages panel I see the run log, which ends with:

---

Error: Internal error. Please contact Intel customer support team.
Application exit code: -2147483644
Result file: C:\Users\genesis\Documents\Inspector\Projects\geniBruce\r000mi2\r000mi2.inspxe
Analysis completed

---

But when I just double-click the executable that I am trying to analyze, it runs perfectly, starting up the whole way so that I can interact with it and then close it gracefully.  I am not sure what it is that I am doing incorrectly in order for a normally running application not to be able to successfully start when inside Intel Inspector 2020 update 2.

Thanks for any help...

Labels (1)
0 Kudos
7 Replies
Dmitry_Dontsov
Employee
520 Views

Hi @bmahf,

Could You please provide reproducer? Which Windows version did you use?

bmahf
Beginner
504 Views
Dmitry_Dontsov
Employee
499 Views

Yes, Reproducer - sample application to reproduce and investigate the problem on our side. Is it possible to share it with us?

RaeesaM_Intel
Moderator
479 Views

Hi,


Could you please let us know the updates on this issue?


Regards,

Raeesa


Dmitry_Dontsov
Employee
474 Views

Hi,

@RaeesaM_Intel , we could not reproduce the problem on our side with existing samples. Await response from submitter relative to an application to reproduce the issue.

 
RaeesaM_Intel
Moderator
437 Views

Hi,


We haven't heard back from you for a while. We are waiting for the response from your end. Could you please share the sample reproducer asked ?


Thanks in advance ,

Raeesa



RaeesaM_Intel
Moderator
389 Views

Hi,


We haven't heard back from you and would no longer be monitoring this issue. Please raise a new thread if you have further issues.


Regards,

Raeesa


Reply