Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
18 Views

Sockets error (111) lors du sampling

J'ai install une version test de vtune 9.1 sur un PC sour Linux (bi-processeur 64 bits Xeon) Red Hat 4 Update 4.

Lorsque je lance le sampling via vtlec, j'ai l'erreur suivante :

Sockets error

Could not connect to remote machine 127.0.0.1. Error No. (111).

Lors de l'installation, j'ai eu les messages suivants :

Wed Oct 22 11:16:42: EntireX DCOM for Linux was successfully installed.

Wed Oct 22 11:17:07: Failed - The installation of the VTune Performance Analyzer Driver Kit component failed.

Wed Oct 22 11:17:54: Failed - The installation of the VTune Performance Analyzer Remote Agent component failed.

Wed Oct 22 11:37:19: The Intel VTune Performance Analyzer 9.1 for Linux* (full install) was successfully installed.

Je me demande donc si mon problme ne viendrait pas de celui l'installation du Remote Agent ?

J'ai cherch une explication au pb d'installation du Remote Agent ds les logs prsents ds /var/log et j'ai trouv bcp de message du type :

/usr/bin/chcon: xxxxxxxxxxxxxx/vtune/rdc/analyzer/bin/libBistroInfoReader32e.so: Operation not supported
/usr/bin/chcon:xxxxxxxxxxxxxx/vtune/rdc/analyzer/bin/libBistroServer32e.so: Operation not supported

Quelqu'un auait-il une idee svp ? Est-ce du ma disctribution Red Hat ?

Est ce que cela serait mieux sur une redhat 3 update 9 par exemple ?

Merci d'avance !

0 Kudos
8 Replies
Highlighted
18 Views

can you please try to start the vtlistenerd program from your vtune directory /your_path_to_vtune/rdc/shared/bin/ and let us know what you get?
can you post an ls output from your rdc/analyzer/bin? it seems that the remote data collector agent did not install properly.

0 Kudos
Highlighted
Beginner
18 Views

Quoting - idleFellow
can you please try to start the vtlistenerd program from your vtune directory /your_path_to_vtune/rdc/shared/bin/ and let us know what you get?
can you post an ls output from your rdc/analyzer/bin? it seems that the remote data collector agent did not install properly.

Threre is nothing in this directory :

[cottereau@roseau rdc]$ pwd
vtune/rdc
[cottereau@roseau rdc]$ ls
README_RDC.txt

I suppose this is due to the fact that the Remote Agent installation failed ?

0 Kudos
Highlighted
Employee
18 Views

Quoting - sam76
Wed Oct 22 11:17:07: Failed - The installation of the VTune Performance Analyzer Driver Kit component failed.

This sounds like you are missing the kernel module ("driver") for VTune. Without the kernel module, you won't be able to sample any data.

The pre-built kernel modules and the sources are located in /opt/intel/vtune/vdk (if you installed VTune in the default directory).Change to the directory/opt/intel/vtune/vdk/src and run the script "build-driver". Since the VTune installation failed at that point, it is likely that won't compile but should give you a hint on what failed.

Kind regards

Thomas

0 Kudos
Highlighted
Beginner
18 Views

Quoting - sam76
Wed Oct 22 11:17:07: Failed - The installation of the VTune Performance Analyzer Driver Kit component failed.

This sounds like you are missing the kernel module ("driver") for VTune. Without the kernel module, you won't be able to sample any data.

The pre-built kernel modules and the sources are located in /opt/intel/vtune/vdk (if you installed VTune in the default directory). Change to the directory /opt/intel/vtune/vdk/src and run the script "build-driver". Since the VTune installation failed at that point, it is likely that won't compile but should give you a hint on what failed.

Kind regards

Thomas

Dear Thomas,

I have no directory vdk :


[cottereau@roseau ~/vtune]$ ls
analyzer doc man redist.txt samples shared vtuneSupport.txt
bin global_data rdc Release_Notes.htm scripts vtuneEULA.txt

I added a file to my post : it's a part of vtune installation logfile concerning vdk.

It says the installation failed because of "unsupported operations" and thus vdk/src was removed.

Regards,

Anne-Sohie

0 Kudos
Highlighted
Employee
18 Views

Quoting - sam76

Dear Thomas,

I have no directory vdk :


[cottereau@roseau ~/vtune]$ ls
analyzer doc man redist.txt samples shared vtuneSupport.txt
bin global_data rdc Release_Notes.htm scripts vtuneEULA.txt

I added a file to my post : it's a part of vtune installation logfile concerning vdk.

It says the installation failed because of "unsupported operations" and thus vdk/src was removed.

Regards,

Anne-Sohie

Probably you can install VTune on *supported* OS first then copy /opt/intel/vtune/vdk folder onto this machine.

However I'm not sure if you can build vtune driver with this VDK successfully.

0 Kudos
Highlighted
Employee
18 Views

Anne-Sophie,
In the directory, where you unpacked VTune, thereis anrpm "data/intel-vdk-src-4.1-102.rpm" with the vdk sources. You could give it a try to install this directly with "rpm -i".
Kind regards
Thomas
0 Kudos
Highlighted
Beginner
18 Views

Anne-Sophie,
In the directory, where you unpacked VTune, there is an rpm "data/intel-vdk-src-4.1-102.rpm" with the vdk sources. You could give it a try to install this directly with "rpm -i".
Kind regards
Thomas

Thomas,

I installed vdk rpm as you said.

In /opt I have 2 directories : intel and sag.

Intel contains : eclipsepackage EclipseTags.cfg EPCommonLauncher.sh licenses vtune

[cottereau@roseau intel]$ cd /opt/intel/vtune/
[cottereau@roseau vtune]$ ls
bin vdk
[cottereau@roseau vtune]$ ls -altr vdk/
total 22580
-rwxr-xr-x 1 root root 4799 Aug 14 21:16 rmmod-vtune
-r--r--r-- 1 root root 22490 Aug 14 21:16 kernel_checksums.txt
-rwxr-xr-x 1 root root 8038 Aug 14 21:16 install-boot-script
-rwxr-xr-x 1 root root 9190 Aug 14 21:16 insmod-vtune
-rwxr-xr-x 1 root root 64712 Aug 14 21:16 get-and-install-driver
-r--r--r-- 1 root root 1613438 Aug 14 21:16 vtune_drv-x32_64-2.6.23.1-42.fc8smp.ko
-r--r--r-- 1 root root 1767662 Aug 14 21:16 vtune_drv-x32_64-2.6.22-14-genericsmp.ko
-r--r--r-- 1 root root 1724816 Aug 14 21:16 vtune_drv-x32_64-2.6.18-92.el5smp.ko
-r--r--r-- 1 root root 1723656 Aug 14 21:16 vtune_drv-x32_64-2.6.18-8.2smp.ko
-r--r--r-- 1 root root 1723688 Aug 14 21:16 vtune_drv-x32_64-2.6.18-8.10AXsmp.ko
-r--r--r-- 1 root root 201594 Aug 14 21:16 vtune_drv-x32_64-2.6.18-4-amd64smp.ko
-r--r--r-- 1 root root 215402 Aug 14 21:16 vtune_drv-x32_64-2.6.16.60-0.21-smpsmp.ko
-r--r--r-- 1 root root 213944 Aug 14 21:16 vtune_drv-x32_64-2.6.13-15-smpsmp.ko
-r--r--r-- 1 root root 182587 Aug 14 21:16 vtune_drv-x32_64-2.6.13-15-defaultup.ko
-r--r--r-- 1 root root 195310 Aug 14 21:16 vtune_drv-x32_64-2.4.21-50.ELsmp.o
-rwxr-xr-x 1 root root 3191 Aug 14 21:16 vtune
-r--r--r-- 1 root root 1537706 Aug 14 21:16 vtune_drv-x32_64-2.6.9-78.ELup.ko
-r--r--r-- 1 root root 1609379 Aug 14 21:16 vtune_drv-x32_64-2.6.9-78.ELsmpsmp.ko
-r--r--r-- 1 root root 1379522 Aug 14 21:16 vtune_drv-x32_64-2.6.9-5.15up.ko
-r--r--r-- 1 root root 1431755 Aug 14 21:16 vtune_drv-x32_64-2.6.9-5.15smpsmp.ko
-r--r--r-- 1 root root 1378577 Aug 14 21:16 vtune_drv-x32_64-2.6.9-11.19AXup.ko
-r--r--r-- 1 root root 1428282 Aug 14 21:16 vtune_drv-x32_64-2.6.9-11.19AXsmpsmp.ko
-r--r--r-- 1 root root 214823 Aug 14 21:16 vtune_drv-x32_64-2.6.5-7.308-smpsmp.ko
-r--r--r-- 1 root root 184097 Aug 14 21:16 vtune_drv-x32_64-2.6.5-7.308-defaultup.ko
-r--r--r-- 1 root root 206037 Aug 14 21:16 vtune_drv-x32_64-2.6.5-7.145lxset1-smpsmp.ko
-r--r--r-- 1 root root 183741 Aug 14 21:16 vtune_drv-x32_64-2.6.5-7.145lxset1-defaultup.ko
-r--r--r-- 1 root root 1802001 Aug 14 21:16 vtune_drv-x32_64-2.6.25-14.fc9.x86_64smp.ko
-r--r--r-- 1 root root 1811233 Aug 14 21:16 vtune_drv-x32_64-2.6.24-16-genericsmp.ko
drwxr-xr-x 2 root root 4096 Nov 5 11:22 src
drwxr-xr-x 4 root root 4096 Nov 5 11:22 ..
drwxr-xr-x 3 root root 4096 Nov 5 11:22 .

I tried to use vtlec but I had the same error during sampling.

NB : my vtune installation relies on 2 differents directories :

[cottereau@roseau ~/vtune]$ pwd
/mnt/thuya/MSS/STR3/THES/cottereau/vtune
[cottereau@roseau ~/vtune]$ ls
analyzer doc man redist.txt samples shared vtuneSupport.txt
bin global_data rdc Release_Notes.htm scripts vtuneEULA.txt

(where my rdc directory only contains README_RDC.txt)

and /opt/intel for eclipse and vdk.

Regards,

Anne-Sophie

0 Kudos
Highlighted
Beginner
18 Views

I solved the problem installing vtune on another machine whose Red hat is Linux WS release 3 (Taroon Update 9).
This time vdk and rdc were successfully installed :
The VTune Performance Analyzer Driver Kit component was successfully install ed.

The VTune Performance Analyzer Remote Agent component was successfully insta lled.
------------------------------------------------------------
------------------------------------------------------------
The VTune Performance Analyzer component is being installed...
The VTune Performance Analyzer component was successfully installed.
------------------------------------------------------------

but I had installation warnings at the end ... and thus errors when using vtune

(Vtune Perf Environement : one or more components did not load correctly).

0 Kudos