Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Matt_F_1
Beginner
45 Views

VTune 9.0u1 crash on FC6

I am currently trying to evaluate VTune for use on FC6. The GUI (vtlec) crashes after I click "Finish" in the "First Use Wizard" with the error:

Eclipse window msg:

JVM terminated. Exit code=1
/opt/intel/eclipsepackage/3.2.1/jrockit-R27.2.0-jre1.5.0_10/bin/java
-Dosgi.sharedConfiguration.area=/opt/intel/vtune/bin/../shared/eclipse/configuration
-jar /opt/intel/eclipsepackage/3.2.1/eclipse/startup.jar
-os linux
-ws gtk
-arch x86
-launcher /opt/intel/eclipsepackage/3.2.1/eclipse/eclipse
-name Eclipse
-showsplash 600
-exitdata 1fc0009
-product com.intel.sdp.primary.product
-perspective com.intel.vtune.shell.tuningPerspective
-vm /opt/intel/eclipsepackage/3.2.1/jrockit-R27.2.0-jre1.5.0_10/bin/java
-vmargs
-Dosgi.sharedConfiguration.area=/opt/intel/vtune/bin/../shared/eclipse/configuration
-jar /opt/intel/eclipsepackage/3.2.1/eclipse/startup.jar

I've tried removing ~/.eclipse and ~/workspace, and setting OTHER_JVM_BINDIR to use Sun Java 1.5.0 32-bit, Sun Java 1.6.0 32 and 64-bit, and the included JVM.

I think it is something more fundamental than the JVM. When I run the cmd-line executable:
vtl activity -c sampling -app "/bin/ls" run
It produces the error message:
VTune Performance Analyzer 9.0 for Linux*. 30 DAY EVALUATION LICENSE
Copyright (C) 2000-2007 Intel Corporation. All rights reserved.

vtl.bin: config_n_control.cpp:599: signed int TBSInitDriver(): Assertion `dwConfigID == 0' failed.
/opt/intel/vtune/bin/vtl: line 216: 7699 Aborted "${BINARY}" "$@"
This is running FC6 with kernel 2.6.20-1.2952.fc6 on x86_64.

I've recently seen the thread on FC6 and the 2.6.20 kernel -- I'll try the patch posted on that thread.

I am currently trying to evaluate VTune on an AMD FX-55 processor. The production machine will be a quad-core Xeon (on order), but I was hoping that I could get some useful information until that arrives.

During install I did _NOT_ get an "unsupported kernel" or "unsupported processor" message, so VTune should work. At the very least there is a bug in the installer.

When will the next version of VTune be available (perhaps even to beta)?


Thank you,
Matt


0 Kudos
1 Reply
Matt_F_1
Beginner
45 Views

FYI, the workaround for scr30638 had no effect.

- Matt
Reply