Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Carlos_O_
Beginner
95 Views

VTune does not install on Ubuntu 14.04.1

I seem to have problems installing VTune Amplifier on Linux:

  1. Downloaded "vtune_amplifier_xe_2015_update2.tar.gz"
  2. Uncompressed and cd to "vtune_amplifier_xe_2015_update2"
  3. Ran "./install.sh" as root
  4. I got the following message:

Nothing to install
--------------------------------------------------------------------------------
Based on availability of RPM packages and coexistence checks, there is nothing
to install from this package. Installation will quit.
--------------------------------------------------------------------------------
q. Quit
--------------------------------------------------------------------------------
Please type a selection or press "Enter" to accept default choice : ^C
Interrupt install process?(Yes/No)[No]:

I'm using Ubuntu 14.04.1:

Linux slab2 3.13.0-44-generic #73-Ubuntu SMP Tue Dec 16 00:22:43 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

As the message is not very explicit I will appreciate any help.

Thanks

0 Kudos
8 Replies
Peter_W_Intel
Employee
95 Views

I just check the release-notes, Ubuntu* 14.04 is supported on U2, not sure for 14.04.01

Would you please try Ubuntu* 14.04? Did you install early VTune version in system? Please uninstall it first, vtune installer will try to uninstall prior versions but I don't know for Ubuntu* 14.04.01.

You may install VTune on other OS - then copy whole vtune directory to 14.04.01, i don't know if you can build/install vtune drivers successfully under vtune/sepdk/src, but user-mode sampling can work in most of cases I guess. 

Carlos_O_
Beginner
95 Views

I have attached the installation log file for reference.

 

Carlos_O_
Beginner
95 Views

The tar file was corrupted. It works now.

Sorry for the noise.

Peter_W_Intel
Employee
95 Views

Thank you for installation log. I will ask developer to have a look.

By the way, are you sure that you have enough space to install the tool? How about install the tool on other OS then copy Vtune directory to this machine, I mentioned last time - run amplxe-cl / amplxe-gui from vtune_amplxe_xe_2015/bin64

Cardin_P_
Beginner
95 Views

é mai indicado que se você tem a instalação do Vtune instalado, o mesmo tem que ser totalmente desinstalado e apos desinstalação de versão anterior a instalação da nova versão do Vtune, porem dessa vez tente descompactar o software no linux analise se existe dentro do da pasta uma extensão .SH, caso sim tente instalar, caso não tente descompactar e executar no console o novo Vtune. caso o mesmo erro persista, é interessante verificar se o Linux não esta com a base desatualizada para receber o Vtune 2015. 

Carlos_O_
Beginner
95 Views

The tar file was corrupted. It works now.

Sorry for the noise.

Peter_W_Intel
Employee
95 Views

@ Carlos O

Based on log, installer reports that RPM packages are not available. Looks like VTune Amplifier XE package was not unpacked successfully, probably because of lack of free space or corrupted TGZ archive. Could you please check if VTune Amplifier XE package was unpacked successfully, and the package was not corrupted.

Peter_W_Intel
Employee
95 Views

Sorry. I just saw your info, thanks for the update.
Reply