Community
cancel
Showing results for 
Search instead for 
Did you mean: 
milian
Beginner
212 Views

Vtune on Archlinux?

Jump to solution
Hello!

Now that VTune XE update 7 was released with Linux 3.x support I hoped to finnaly get VTune running on my Archlinux boxes, but sadly it does not work. I see that Archlinux is not supported, but cannot see the big difference compard to all the other supported distributions.

When I run the installer it warns me about my distribution not being supported but then comes the strange part: Even though I have gtk 2.24.8-2 and glibc 2.14.1-4 installed, VTune's installer says it cannot find either of those and eventually fails the installation:

--------------------------------------------------------------------------------
Installing Amplifier XE Command line interface component... failed
--------------------------------------------------------------------------------
Installing Amplifier XE Sampling driver kit component... failed
--------------------------------------------------------------------------------
Installing Amplifier XE Graphical user interface component... failed
--------------------------------------------------------------------------------

The installation target directory is created but empty... Any help on how to get it running would be greatly appreciated.

Thanks
0 Kudos
1 Solution
Mark_D_Intel
Employee
212 Views
You could try manually installing the rpm files in the CLI_install/rpm and rpm/ directories.
This should be enough to run a user-mode collection (hotspots, concurrency, or locksandwaits). To enable hardware-based sampling, look in the README.txt file in the sepdk/src directory for directions on compiling and installing the driver. To view results, you might also need to copy a license file to /opt/intel/licenses, or set the environment variable INTEL_LICENSE_FILE to the directory containing the license.

Mark

View solution in original post

8 Replies
Mark_D_Intel
Employee
213 Views
You could try manually installing the rpm files in the CLI_install/rpm and rpm/ directories.
This should be enough to run a user-mode collection (hotspots, concurrency, or locksandwaits). To enable hardware-based sampling, look in the README.txt file in the sepdk/src directory for directions on compiling and installing the driver. To view results, you might also need to copy a license file to /opt/intel/licenses, or set the environment variable INTEL_LICENSE_FILE to the directory containing the license.

Mark

View solution in original post

milian
Beginner
212 Views
Many thanks for this useful feedback! I've now used rpmextract to get the contents of the rpm files and can - after manually installing libjpeg6 and libpng12 - run amplxe-gui.

I can load a project, but when I try to run an analysis (attach to program) I see the following error:

Cannot load resources from file '/path/to/my/vtune/resource/client.dat#zip:images.xrc'

indeed, this file (client.dat I presume) does not exist in that folder. I've now symlinked perfclient.dat to client.dat and that makes this issue go away. But after a "hotspots" analysis (yes - it worked!) I see the error again, differently:

XRC resource 'tab_*' (class 'wxImage') not found!

the resources not found are: tab_grid, tab_summary and tab_timeline. So probably I need that client.dat, which rpm should contain it, or where do I get it from?

But this is amazing, finally I have a somewhat running vtune on my archlinux box! Many thanks again, Mark!
Mark_D_Intel
Employee
212 Views
This file (client.dat) is located in a CLI_install rpm, in intel-vtune-amplifier-xe-cli-206420-11.0-7.i486.rpm (which mostly contains the 32-bit CLI binaries and libraries). (Both 32 bit and 64 bit versions can be installed at the same time - the binaries and libs go to separate directories).
milian
Beginner
212 Views
Indeed that makes VTune work like a charm now. I thought that the non-64bit rpms should not be installed on a 64bit machine, thanks for the clarification.

I really appreciate your help here, thanks once again!

PS: I've documented the steps required to get VTune running on archlinux here: https://wiki.archlinux.org/index.php/VTune#VTune_Amplifier_XE_2011
Devendra_G_
Beginner
212 Views

I am trying to install VTune 2013 Update 16 on Archlinux 3.14.2-1. However, after following the instructions here and on the archwiki (as posted in the last message), I was only able to install the RPMs. When I try to compile the drivers, I get following error.

I am using GNU compilers. Do I need to install intel compilers to compile the drivers? Any suggestions are welcome.

Warm regards,

Devendra Ghate

Makefile:615: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler

gcc: error: unrecognized command line option ‘-fstack-protector-strong’

scripts/Makefile.build:308: recipe for target '/opt/intel/vtune_amplifier_xe_2013/sepdk/src/lwpmudrv.o' failed
Peter_W_Intel
Employee
212 Views

@Devendra G 

The problem may be due to system environment, or you are using high Linux kernel 3.14.2-1 (gcc 4.9 supports 3.14 kernel?)

You might use MACRO CONFIG_CC_STACKPROTECTOR_REGULAR ( or CONFIG_CC_STACKPROTECTOR_NONE) instead of MACRO

CONFIG_CC_STACKPROTECTOR_STRONG?

I don't know if latest u16 (driver test) can support kernel 3.14 well, you may try low Linux kernel platform, e.g 3.10 - if above does't work.

 

Devendra_G_
Beginner
212 Views

Thank you for your advice Peter. I moved back to linux 3.10.39 kernel and I was able to compile it. I need to disable the `nmi_watchdog` and it should work. Will report back if there are any further issues. By changing the kernel, I was able to compile the drivers effortlessly.

Devendra

Peter_W_Intel
Employee
212 Views

Devendra G.

I am glad that the tool works on your side!

Reply