Community
cancel
Showing results for 
Search instead for 
Did you mean: 
alex7
Beginner
75 Views

Writing property files failed

I also get this message.

I am running Suse linux 9.1 x86 (not emt) and vtunes 3.0p.

when I create a callgraph activity:

vtl activity myactivity1 -c callgraph -app myapp.sh -moi mybin

it reports:

VTune Performance Analyzer 3.0 for Linux*
Copyright (C) 2000-2004 Intel Corporation. All rights reserved.

Thu Sep 22 17:26:29 2005 Writing property files failed.

This does not appear to be a permissions problem - since:

vtl query -a myactivity1

gives
...
Folder with call graph ... activity: /home/me/VTune/Projects/vtune/cg142D06D5/

which contains:

-rwxr-xr-x 1 me mycorp 4915 Sep 22 17:26 bistro.bpj
-rw-r--r-- 1 me mycorp 281 Sep 22 17:26 bistro.log
-rw-r--r-- 1 me mycorp 1277 Sep 22 17:26 mybin.ini

but the ini file contains:

; comments

[Buffer Size]

;Use "buffer size" property in order to
;reduce memory consumption during the collection.
;Each thread in the instrumented application
;will dump its collected data to a file
;when the thread's buffer is filled.
;The value of the property should be an integer
;specifying the buffer size in KB.
;If this property is preceded by a number sign ('#'),
;all the collected data will be stored in memory until the end of collection.
*EOF*

which looks truncated. When the activity is run, the following (justified) error is printed:

Thu Sep 22 17:33:10 2005 error: the property 'buffer size' was not set in the property file.

Thu Sep 22 17:33:10 2005 Reading property files failed.

I seems like the activity creation fails when or before trying to write the buffer size into the file, and after that just gives up!

This behaviour also happens in the IDE (eclipse).


I note that the default:

vtl global-options
...
buffer-size-KB="0"
...

which might be a problem, or might be the default.

If I change this to 1024, creating an activity becomes ok again.
0 Kudos
1 Reply
David_A_Intel1
Employee
75 Views

Yes! I've seen this before, but hadthink hard to recall it.

It appears that sometimes the installation fails to set up the default buffer size and then you get into this situation. You might try re-installing.

I believe the buffer size is calculated based on your specific system, but I don't know what the formula is. For example, on the system I have, with 512 MB installed, the buffer-size is 131072.

Property files are also writting to /tmp/vtune_/Cache, so you need to be sure that you have write access to /tmp.

Regards,

Message Edited by DaveA on 10-06-2005 01:56 PM

Reply