Community
cancel
Showing results for 
Search instead for 
Did you mean: 
saphires
Beginner
56 Views

amplxe-cl launch failed with Dicer Error

I followed the manual to launch the command line amplxe but failed with some errors. Release manual says Westmere EX is already supported in update 3, but E7-2850 is not listed in it. So I am wondering if this is a supportability issue or not.
# amplxe-cl -collect hotspots ./lbm_peak.debug 20 reference.dat 0 1 100_100_130_cf_a.of >/dev/null
Error: Binary file of the analysis target does not contain symbols required for profiling. See the documentation for more details.
Error: Valid __errno_location symbol is not found in the static binary of the analysis target.
Using result path `/root/470.debug/r002hs'
Error: Error 0x40000020 (Dicer error) -- Cannot register product database plug-ins.

# amplxe-cl --version
Intel VTune Amplifier XE 2011 Update 4 (build 176374) Command Line Tool
Copyright (C) 2009-2011 Intel Corporation. All rights reserved.
# lsmod | grep sep
sep3_4 44486 0
# uname -r
2.6.32-131.0.15.el6.x86_64
# head -n10 /proc/cpuinfo | grep 'model name'
model name : Intel Xeon CPU E7- 2850 @ 2.00GHz
Any advice or hint?
Thanks!
0 Kudos
1 Reply
Peter_W_Intel
Employee
56 Views

I suppose that the problem wasNOT caused by unsupported processor, because of using hotspots analysis.

1. Check if you can run with other application, e.g. "amplxe-cl -collect hotspots -- /bin/ls"
2. Did you installed multiple versions in same machine? It said "Cannot register product datavase plug-in". If so, please uninstall all, then install oneversion only.
3. Can you run command under /tmp? I'm not sure if there is any restriction to write into current directory.

Regards, Peter
Reply