Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Employee
32 Views

callgraph results not showing the functions present in the dlls

Hi,
I am new to Vtune. I am using Vtune 7.0 and compiled the dlls with all the required options. I am able to see some of the dlls in the sampling results (source view is also working fine), but not all. When I see callgraph results; I am notable to seethe functionspresent in the the dll's(not even one). What may be the problem?
Note : I mentioned all the dll's in the "modules of interest" list. Some dll's show the instrumentation level as "All functions" and some show as "Exports".
I am launching the application which uses these dlls, using vtune.
Any sort of help is appreciated.
0 Kudos
5 Replies
Highlighted
Employee
32 Views

First, upgrade to 7.1! This is a free download from Intel Premier Support.
Second, call graph requires full debug information. Do you have that for the DLLsyou areinterested in?
Finally, how did you configure the activity? Is the analyzer "launching" the application? You said you listed the DLLs, but what about the EXE? I am just trying to understand how you configured the call graph activity.
You might check out http://support.intel.com/support/performancetools/vtune/v71/sb/cs-006107-prd1391.htmfor some common call graph troubleshooting techniques.
0 Kudos
Highlighted
Employee
32 Views

Hi Dave,

Sorry for the late response. I am now upgraded to 7.1 using the evaluation copy. As I mentioned earlier, "I am not able to see the functionsusing callgraph approach, but with Sampling I am able to see the function names and also the source." Can you clarify the following questions?

1) What is the impact on vtune, when the machine goes to"suspend mode" and comes back again during data collection?

To verify our dlls, the machine should go to suspend mode atleast once.

2) I am compiling the dlls, sys files in one machine (say, host machine) and following the steps below.

a) Copy the dlls, sys and symbol files to the target machine.

b) Enable sharing, for the source code directory in the host machine.

c) Start the vtune in the target machine.

d) Using the option mentioned in "Options-> Directories -> DirectoryMapping", I am mapping the source code path" in the host machinewith the network-drive(host-machinepath) path. Am I going wrong here?

e) Configuring the activity using Advanced activity configurationoption.

f) Using the option Modules of Interest List, I am selecting the dlls, sys files which I have created.

g) Launching the application which uses the above dlls using Applicationto Launch" option.

FYI, the application does not have any symbolinformation.

3) Does vtune uses "rdtsc" instruction to get the clockticks? If so, what is the impact of the errata of "rdtsc" mentioned in theink http://www.intel.com/design/mobile/specupdt/25266509.pdf

Finally, I have gone through the links, which you have mentioned, but the problem still exists. I have not yet tried with remote data collection. Where can I gettutorial to configure remote agents?

Thanks.

0 Kudos
Highlighted
Employee
32 Views

Thanks for all the details! I will try to address your questions.
  1. In general, events stop occurring if the processor is suspended. Please check out the processor events for your specific processor. See the Reference book (i.e. it is a "book" icon) in the online help contents (under VTune Performance Analyzer book) for specific info. For example, on Hyperthreading Technology enabled processors, there are two kinds of Clockticks events: one that stops counting when the processor is halted (HLT) and one that stops counting when the processor goes to sleep.
  2. Probably, "systemdir1dir2" doesn't work. You can try mapping the share to a drive and using that, instead, e.g., "X:dir2".
  3. No, the VTune analyzer does NOT use the rdtsc instruction. It uses the Clockticks performance monitoring event of the processor. You can find this in the Performance Monitoring section of the Pentium 4 processor manuals.
0 Kudos
Highlighted
Employee
32 Views

Hi Dave,
Thanks for your response. I tried the method(mapping to network drive), which you have mentioned. But i am not able to get the call graph view. when I click on the tuning browser, I get the following message "The results file is empty. The view will close". Where can I get debugging information regarding this issue? (I mean are there any files to look at.). Note, the dll's instrumentation status is as follows : Instrumentation Status:OK, Instrumentation Level: All functions, Module Type : user dll, Debug Info: Yes.
Thanks once again dave, for ur patience.
0 Kudos
Highlighted
Employee
32 Views

At this point, we would need to you submit an issue at Intel Premier Support (http://premier.intel.com) so that the technical support people can work with you to determine the problem.
0 Kudos