Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
108 Views

cannot communciate with the target, ssh windows to linux

Hi,

I'm trying to connect VTune 2018 update 3 from Windows 10 to a Centos system. I've followed the instructions here for setting up putty and plink for passwordless connection. I set the default settings for username and ppk key. I set up plink.exe in the Path and tested it by invoking

plink.exe user@ip_address

and it connects just fine. I've used this same key pair many times before in Putty. In VTune, I put in the same user@ip_address into the ssh destination. However, I keep getting the same messages:

  • Amplifier cannot detect remote machine configuration.
  • Cannot communicate with the target user@ip_address. To collect data on a remote Linux system, configure SSH to work in a password-less mode so that it does not prompt for the password on each invocation. Usually, this can be accomplished by either setting up a key-based authentication, or by setting the password to an empty string. Press F1 for more details.
  • Please verify the password-less connection by running following command from your host system: 'ssh -o BatchMode=yes -o ServerAliveInterval=5 -o StrictHostKeyChecking=no user@ip_address uname'.
  • Amplifier cannot detect remote machine configuration.
  • Process name is not specified. Provide a valid process name.
Is there something else that I need to set in VTune to use plink? Also I have SSH for Windows 10 installed. So, maybe that is causing a conflict?
 
Edit: I found the ssh.cfg file under C:\Program Files (x86)\IntelSWTools\VTune Amplifier 2018\config\connection_type. I'm attempting to change the config. However, I'm not sure what changes need to be made to use plink.
 
Thank you,
Bryan Carroll
 
0 Kudos
7 Replies
Highlighted
Employee
108 Views

Hi Bryan.

Looks like you have something like cygwin ssh in path

try to locate it by calling 'where ssh.exe'

Could you call 'set path=PLINK_DIR;%path%' to set environment before starting vtune?

Thanks, Kirill

0 Kudos
Highlighted
Beginner
108 Views

Hi Kirill,

Using where, I located ssh to C:\Windows\System32\OpenSSH\ssh.exe. So, I uninstalled OpenSSH. I used where to verify that ssh.exe could not be found. Then I tried again, still didn't work. I did get a different error.

  • Amplifier cannot detect remote machine configuration.
  • pscp (command-line SCP (secure copy) / SFTP client) is not in PATH.

The plink directory is already in the path. However, I tried the set path=PLINK_DIR%path% and started vtune from the command line. I got the same error as above.

Thank you,

Bryan Carroll

0 Kudos
Highlighted
Employee
108 Views

you must have 2 putty tools in path. plink.exe and pscp.exe

Could you download pscp too?

Kirill

0 Kudos
Highlighted
Beginner
108 Views

Yes, I downloaded pscp.exe and now it works great. Thank you!

One more question if you don't mind, I'm a novice/student. So I don't have a lot of experience with ssh and VTune. I'm working on a cluster. If I need to ssh to machine B through the first machine, machine A, how would I set that up? I tried using 'ssh machineB' in the remote command in Putty. If I call plink in the command line with 'plink user@machineA_IP', plink will automatically ssh to machineB. However, VTune will stop at machineA and try to find the application or process on machineA and fail.

Thank you,

Bryan Carroll

0 Kudos
Highlighted
Employee
108 Views

Hi Bryan.

VTune does not support ssh tunnel through another target. So, you need to setup Vtune on machineA and reun remote collection on machineB.

Let's me to clear something.

Did you run 'plink user@machineA_IP' on the host and get console machineB at once? Do you have some special setting in ssh config on the machine A(~/.ssh/config)?

0 Kudos
Highlighted
Beginner
108 Views

That's too bad that VTune doesn't support ssh tunnel. I won't be able to use it. I doubt it will be installed onto our cluster due to licensing.

Correct. No special config as far as I know. We do use munge authentication. So maybe that has something to do with it. So all I have to do is put 'ssh host_name' in the remote command in Putty and the command is automatically called.

Thank you,

Bryan Carroll

0 Kudos
Highlighted
108 Views

Hello Bryan,

I will allow Kirill to comment on further technical noticies, but let me specify on free Intel Software tools available for Students, Educators and Open Source contributors: https://software.intel.com/en-us/qualify-for-free-software/student

VTune Amplifier is included into the free offer as part of Intel Parallel Studio XE and Intel System Studio.

Regards, Katya

 

0 Kudos