Community
cancel
Showing results for 
Search instead for 
Did you mean: 
35 Views

cannot stop a running collection via amplxe-cl

Jump to solution
Hi,

This is Linux RHEL 6 (Red Hat Enterprise Linux 6). I cannot stop a running collection because the amplxe-cl tool does not see one running, but it is running.

example:

[bash]amplxe-cl --collect hotspots -knob accurate-cpu-time-detection=true -follow-child -target-duration-type=short -no-allow-multiple-runs -no-analyze-system -data-limit=1000 -slow-frames-threshold=40 -fast-frames-threshold=100 -result-dir=/tmp/test --search-dir /tmp/symbols --target-process server &[/bash]

when I try to stop the collection, the following error shows up
[bash]$ amplxe-cl --command stop
Fatal error: Cannot detect running collection to deliver command.
$
[/bash]


I see the collection it is running though:

[bash]28810 pts/1 Sl 0:00 amplxe-cl --collect hotspots -knob accurate-cpu-time-detection=true -follow-child -target-duration-type=short -no-allow-multiple-runs -no-analyze-system -data-limit=1000 -slow-frames-threshold=40 -fast-frames-threshold=100 -result-dir=/tmp/test --search-dir sym:r=/tmp/symbols --target-process server

28817 pts/1 Sl 0:00 /opt/intel/vtune_amplifier_xe_2011/bin64/amplxe-runss --ui-output-format xml --ui-output-fd 4 --option-file /tmp/test/config/runss.options

28845 pts/1 R+ 0:00 ps a
[/bash]


what could be wrong here?

Thank you,

-Rilson

0 Kudos

Accepted Solutions
David_A_Intel1
Employee
35 Views
Hi Rilson:

Which version of the VTune Amplifier XE are you using? Attach to process for hotspots on Linux is only supported in Update 3 or later. Try lightweight-hotspots if using an earlier version.

Note, when you specify a result directory or -user-data-dir on the collection command line, you must specify that option on the --command comand line, as well. For example, if you specified:

$ amplxe-cl -collect hotspots -result-dir /tmp/test -target-process server &

to collect data, you should use the following command to check the status:

$ amplxe-cl -result-dir /tmp/test --command status
PPID PID STATE NAME
011038 000513 RESUME server


That is because the status is determined from some file within the results directory.

So, basically, whatever results directory is used by the collection command, the same results directory must be used by the command with the --command option.

View solution in original post

2 Replies
David_A_Intel1
Employee
36 Views
Hi Rilson:

Which version of the VTune Amplifier XE are you using? Attach to process for hotspots on Linux is only supported in Update 3 or later. Try lightweight-hotspots if using an earlier version.

Note, when you specify a result directory or -user-data-dir on the collection command line, you must specify that option on the --command comand line, as well. For example, if you specified:

$ amplxe-cl -collect hotspots -result-dir /tmp/test -target-process server &

to collect data, you should use the following command to check the status:

$ amplxe-cl -result-dir /tmp/test --command status
PPID PID STATE NAME
011038 000513 RESUME server


That is because the status is determined from some file within the results directory.

So, basically, whatever results directory is used by the collection command, the same results directory must be used by the command with the --command option.

View solution in original post

35 Views
Hi Mr. Anderson,

Thanks for the fast reply. It worked by adding "-result-dir" to the stop command (is this in the help somewhere?)

My VTune is "Intel VTune Amplifier XE 2011 Update 3 (build 150226) Command Line Tool".
I have another doubt for you, I'll open it in a different thread =D

Thank you again,

-Rilson