Analyzers
Community support for Analyzers (Intel VTune™ Profiler, Intel Advisor, Intel Inspector)
4921 Discussions

problème enregistrement : locale::facet::_S_create_c_locale name not valid

theow13
Beginner
1,159 Views

bonjour,

je suis novice sur intel amplifier.

J'utilise la ligne de commande pour collecter mes données : amplxe-cl -q -collect hotspots -r NOM -data-limit=4000 --

En lançant mon programme, j'ai la ligne d'erreur :

amplxe: Error: 0x40000003 (Unexpected internal error / invalid state) -- locale::facet::_S_create_c_locale name not valid

avec

srun: error: n1928: task 19: Exited with exit code 2
srun: Terminating job step 12140471.0

 

 

Je ne peux pas ouvrir le fichier que je créé avec la commande amplxe-gui par la suite.

Avez-vous des idées de la cause ?

 

Merci d'avance !

Theo 

0 Kudos
7 Replies
RahulU_Intel
Moderator
1,122 Views

Hi,


Thank you for posting your question, however this is an English-only forum. I have translated your question and here is what resulted. Is this the question you were intending to ask?


"registration problem: locale :: facet :: _ s_create_c_locale name not valid

Hello,


i am new to intel amplifier.


i am using the command line to collect my data: amplxe-cl -q -collect hotspots -r name -data-limit = 4000 -


when launching my program, i got the error line:


amplxe: error: 0x40000003 (unexpected internal error / invalid state) - locale :: facet :: _ s_create_c_locale name not valid


with


srun: error: n1928: task 19: exited with exit code 2


srun: terminating job step 12140471.0


  i cannot open the file i created with the amplxe-gui command afterwards.


do you have any ideas for the cause?


 

thanks in advance!


follow"


Thanks


0 Kudos
theow13
Beginner
1,114 Views

ok, thank you for the answer.

Yes it is my question, and maybe i can give you more informations, I use intel/17.2 (Intel Compiler Suite) and vtune/2017.4.0.518798 (profiler).

Regards

Theo

0 Kudos
RahulU_Intel
Moderator
1,098 Views

Hi,


Thanks for the immediate response. We looked into your case. As you have mentioned your Vtune version in your previous reply ((vtune/2017.4.0.518798 (profiler)) you are using the older version of VTune. We are not able to reproduce the issue using the latest vtune (VTune 2021.5). We suggest you to install the latest version of VTune from the below link and try the same command and let us know if you face the same issue again. If you are using Vtune as standalone or with oneapi, from the below links you can choose either one according to your usage.

After installing the latest vtune, you could use the below command:

vtune -q -collect hotspots -result-dir <result directory> <target appilcation directory> -data-limit = 4000 -


To know more about different vtune commands you can refer this link:

https://software.intel.com/content/www/us/en/develop/documentation/vtune-help/top/command-line-interface/command-syntax.html


For downloading latest version of oneAPI:

https://software.intel.com/content/www/us/en/develop/tools/oneapi/base-toolkit/download.html


For downloading latest standalone version of VTune:

https://software.intel.com/content/www/us/en/develop/articles/oneapi-standalone-components.html#vtune


If the issue still persists, please let us know.


Thanks and Regards

Rahul




0 Kudos
RahulU_Intel
Moderator
1,066 Views

Hi,


We haven't heard back anything from you. Could you please confirm if the issue is resolved.


Thanks


0 Kudos
theow13
Beginner
1,050 Views

Hello,

Not yet, i will try to resolve my problem maybe the next week.

I get back to you as soon as I try.

Thanks you  for the answer !

0 Kudos
RahulU_Intel
Moderator
1,002 Views

Hi,


We haven't heard back from you. Did you get any chance to try out our suggestions. Could you please confirm if the issue is resolved.


Thanks and Regards

Rahul


0 Kudos
RahulU_Intel
Moderator
913 Views

Hi,


I haven't heard back from you. So I will close this case for now. If you have further any queries you can post a new question.


Thanks and Regards

Rahul


0 Kudos
Reply