Community
cancel
Showing results for 
Search instead for 
Did you mean: 
olsen_eric
Beginner
106 Views

running an application with a user different than the owner

Our application is owned by root, but we run it a separate user on purpose. Does VTune have some kind of soft check on permissions instead of actually trying to run the application? We specified not to run this application as root, but VTune will not seem to let me run it as anything but the owner. Changing the permissions is not an option for us as well. Running it normally under a normal ssh session works fine, its just VTune wont try it seems. We're running VTune 9.0 for Linux

Error Message: Wed Jun 4 14:49:16 2008 Error in module "" - The application user ID is different from the current user ID, try running it as a different user.

These are the permissions on the application
-rwsr-xr-x 1 root root 89543331 Jun 4 14:39



0 Kudos
5 Replies
Nicolae_P_Intel
Employee
106 Views

you can try to use the command line in vtune namely vtl. please have alook at the end of this post.

all the problems you have are because you do not have the right permissions. the vtune result directory /global_data should be accesible(write access)from your user ( i think that right now only the root has rights to write into this directory).

the next thing is that the vtune driver should be accesible for your user (you'll need to add your user to the vtune group in /etc/group file). the vtune drivers you can list with ll /dev/vtune*

after you have done that you can check with the following command line and send us the output in case it does not work

vtl activity myTestActivity -d 10 -c sampling -app ,run

where has the form "param1 param2 param3 etc..."

hope that this helps.

olsen_eric
Beginner
106 Views

Correct me if I'm wrong but sampling should not work if these same folders/drivers are not properly set with the right permissions. And sampling when I do not specify -app works fine for me. The problem here is launching an application with sampling/call graph.

is the remote host here
admin@/opt/intel/vtune/rdc/global_data/>:ll /dev/vtune*
crw-rw---- 1 root vtune 252, 0 May 30 16:02 /dev/vtune_d
crw-rw---- 1 root vtune 252, 1 May 30 16:02 /dev/vtune_m
crw-rw---- 1 root vtune 252, 2 May 30 16:02 /dev/vtune_p

admin@:/opt/intel/vtune/rdc/global_data/>: was able to write in this directory

admin@:/opt/intel/vtune/rdc/global_data/>:cat /etc/group | grep admin
admin:x:500:
vtune:x:506:admin

Permissions on the app
-rwsr-xr-x 1 root root 89543331 Jun 4 15:21

Just tried vtl and it returned the same error when trying to create the activity.

:~/ # vtl activity CallGraph -c callgraph,,admin@ -app ,"",,admin@ -moi -moi
VTune Performance Analyzer 9.0 for Linux*
Copyright (C) 2000-2007 Intel Corporation. All rights reserved.

Thu Jun 5 10:28:23 2008 Error in module "" - The application user ID is different from the current user ID, try running it as a different user.



Nicolae_P_Intel
Employee
106 Views

just to get you going, you could try out the statistical callgraph feature ofthis tool Intel Performance Tuning Utility 3.0which you can download free of charge from whatif.intel.com.

statistical callgraph does call stack sampling and therefore is much less intrusive as callgraph. there is a call count feature in IPTU that will give you exact function call count if you are interested in that.

I will come back to you on the vtune callgraph functionality later.

Nicolae_P_Intel
Employee
106 Views

have you tried to modify the write access to the binary as the following

-rwsrwxrwx and run the callgraph activity again?

olsen_eric
Beginner
106 Views

So the problem is related to the s bit in th euser permissions and SuSE OSes. If I change it to x it works properly in VTune. Wont work for our application but at least we narrowed down the problem.
Reply