Talk to fellow users of Intel Analyzer tools (Intel VTune™ Profiler, Intel Advisor)
5038 Discussions

the application got hang when using vtune amplifier to test it

Dear experts,

I'm usingVTune Amplifier(the latestet version), the application I would like to test doesn't have an user interface, I have to use command line to launch it, I put all the all the commands in a batch file and select this batch as the application to launch and I use hotspot as the analyze type, I use the default configuration and run it in stand alone mode, it executes quite well at the start point but after several seconds the command line prompt got hang and no responding, I have to stop its execution manually.

If I manually execute it by double clicking the batch, it works fine and never get hang.

Any suggestions?


0 Kudos
2 Replies
New Contributor II


Can you provide additional information about the nature of your application you are attempting to analyze? What type of application is it? For example is it a .NET? Is the application based on managed or unmanaged code? Are there third party libraries involved?

Can you let us know the Intel VTune Amplifier XE command line being used? This can be obtained via the Amplifier GUI by clicking on the Get command line button in the lower right corner of the GUI.

Are you able to analyze the application without having the application start via a batch file?

Does analysis stall at the same prompt each time? If so, what is the nature of the prompt? Is the prompt generated by the batch file or the application? Does analysis stall after entering data at the prompt? Any additional information you can add here may help us understand the behavior.

Would it be possible to provide the batch file / script and a compilable example that we can replicate with. If so we can discuss this option and take this tread private as needed.

Any additional information you can provide about the nature of your application and the unexpected behavior will help us determine a possible course of action.

Intel Support

0 Kudos
Hi Rob,

Thank you for your reply, the application is based on native c++ code, I'm not sure what kind of third party libraries you referred to.

Here is the command line:

amplxe-cl --collect hotspots -knob accurate-cpu-time-detection=true -follow-child -mrte-mode=native -target-duration-type=short -no-allow-multiple-runs -no-analyze-system -data-limit=100 -slow-frames-threshold=40 -fast-frames-threshold=100 --search-dir sym=F:\2.0.1400.9\Cut1400.9\source -- C:\Users\Administrator\Desktop\H\MCPBuilder\F.bat

And I also try the "Auto" instead of "Native" and get the same result.

I have to launch the exe via batch file, beacuse theexe doesn't have a GUI, when I try to double click onit, a command linelike black prompt box pops up andit closes automatically soon... another option I have isI can manually double click the bat to start the target exe, when the target exe is running I can use attach running process option toget the analyze result, I am able todo this, butthe execution time is quite short, after starting the exe, attaching the target process, I only have several seconds to collect the data and I'm afraid some important data already lost...

I am not able to build the application, it's huge and we have a build team take care of it, but they are in India and I alomost have no chance to get in touch with them...I can show you the bat I use:

cd "c:\Program Files (x86)\xxx\xxx\Bin"

builder.exe /m SAMPLE /c "Release|MCP" /re SAMPLE_Folder /f "C:\Users\Administrator\Desktop\H\MCPBuilder\MCPBuilderSettings.xml" /b /l C:\SAMPLE.log

I run it on x86 pc, the targer exe is builder.exe.

After it executes several seconds, I got below:

Builder.exe has stopped working

Here is the detail:

Problem signature:

Problem Event Name: BEX

Application Name: Builder.exe

Application Version:

Application Timestamp: 4d823c18

Fault Module Name: StackHash_998b

Fault Module Version:

Fault Module Timestamp: 00000000

Exception Offset: 1551190e

Exception Code: c0000005

Exception Data: 00000008

OS Version: 6.1.7600.

Locale ID: 1033

Additional Information 1: 998b

Additional Information 2: 998b1f5d45bf852a3c8029ef73050617

Additional Information 3: 7a95

Additional Information 4: 7a95c5ceb46afcc381f5303c8ea3b1e9

Thanks & regards

0 Kudos