Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Chason_D_
Beginner
191 Views

vtune collect error: valid _pthread_cleanup_push symbol is not found in the binary of the analysis target

Hello, all,

I get below error, when I run amplxe-cl to collect hotspots. Note: process 1183 is my application.

What is causing this? Thanks.

# amplxe-cl -collect hotspots -r temp -target-pid 1183
amplxe: Collection started. To stop the collection, either press CTRL-C or enter from another console window: amplxe-cl -r /home/chasond/vtune/t6/session10/tt3/temp -command stop.
amplxe: Error: Valid _pthread_cleanup_push symbol is not found in the binary of the analysis target.
amplxe: Error: Binary file of the analysis target does not contain symbols required for profiling. See the 'Analyzing Statically Linked Binaries' help topic for more details.
amplxe: Error: Valid _rt0_amd64_linux symbol is not found in the binary of the analysis target.
amplxe: Collection failed.
amplxe: Internal Error

Thanks,

Chason

 

0 Kudos
3 Replies
Dmitry_P_Intel1
Employee
191 Views

Hello Chason,

Is the application a statically linked binary as VTune assumed in one of the messages?

Thanks & Regards, Dmitry

Chason_D_
Beginner
191 Views

Hi, Dmitry,

Thanks for your response.

Yes, my application is statically linked binary, and file result is shown as below:

# file ./udv0.out
./udv0.out: ELF 64-bit LSB executable, x86-64, version 1 (GNU/Linux), statically linked, for GNU/Linux 2.6.32, not stripped

dmitry-prohorov (Intel) wrote:

Hello Chason,

Is the application a statically linked binary as VTune assumed in one of the messages?

Thanks & Regards, Dmitry

Chason_D_
Beginner
191 Views

Hi, Dmitry,

Thanks again for your tip.

Refer to blow links, I add linking parameters with '-u SYMBOL', when compiling my application. Now vtune works well:)

https://software.intel.com/en-us/node/609433

https://software.intel.com/en-us/node/605573

Best Regards,

Chason

 

Reply