Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
206 Views

vtune-gui Ubuntu 18.04 “Failed to launch VTune Amplifier GUI…”

I am on Ubuntu 18.04 LTS and I have installed Intel Parallel Studio XE 2020 Update 4, and everytime I try to launch Vtune profiler with gui from the terminal (vtune-gui) I get the message "Failed to launch VTune Amplifier GUI...". I tried to run vtune-self-checker.sh to see if everything is ok, and everything seemed fine. What can I do in order to launch the gui application?

Tags (1)
0 Kudos
6 Replies
Highlighted
Moderator
171 Views

Hi Ntsiris,

 

Which among the following versions of parallel studio are you using.

1)Intel Parallel Studio XE 2020 Cluster Edition

2)Intel Parallel Studio XE 2020 Professional Edition

3)Intel Parallel Studio XE 2020 Composer Edition

 

I have tried out with Cluster Edition in my ubuntu 18.04 and am able to launch vtune-gui without any issues.

 

Additionally could you also provide the below information to debug this further.

1)While installing did you install all components or parallel studio or did you do a configure install and choose components to install?

2)Was there any pre-requites missing error messages while you installed parallel studio.

3)Also could you confirm if you have multiple installations on vtune installed on your system.

 

 

For an immediate workaround for the time being I would suggest you to use vtune webserver with which you could get vtune-gui in a web browser. The below command launches vtune webserver.(vtune environment has to be initialized)

 

 

 

 

vtune-backend --web-port=8080

 

 

 

 

The below link explains vtune-webserver usage in detail

 

https://software.intel.com/content/www/us/en/develop/documentation/vtune-help/top/launch/web-server-...

 

Thanks 

Arun Jose

 

0 Kudos
Highlighted
Beginner
159 Views

Hello Arun, 

Thank you for your time and the imediate workaround.

I am using Intel Parallel Studio XE 2020 Cluster Edition.

No I did not configure my installation, I installed it with the default options.

The only pre-requites missing where the 32-bit libraries which I don't intent using anyway.

 Finally, I can confirm that there is only one instalation of vtune on my system, the one that came with Intel Parallel Studio XE 2020 Cluster Edition.

 

0 Kudos
Highlighted
Moderator
130 Views

Hi Ntsiris,


We are unable to reproduce your issue. Could you try restarting your machine. If possible could you also try installing standalone version of vtune and see if the error still exists.


https://software.intel.com/content/www/us/en/develop/tools/vtune-profiler/choose-download.html#stand...


Let us know your observation after the restart and re-installation, we will check with experts if issue still persists.


Thanks

Arun


0 Kudos
Highlighted
Beginner
120 Views

Hello, 

I have tried restarting my machine many times and nothing changed. I also installed the standalone version of Vtune and still I was unable to launch vtune-gui.

Are there any more information I can provide in order to help resolve the issue quicker?

Thank you.

0 Kudos
Highlighted
Moderator
112 Views

Hi


We are forwarding this case to subject matter experts. They will get back to you soon.


Thanks

Arun


0 Kudos
Highlighted
Employee
101 Views

have you tried suggested workaround?


0 Kudos