Application Acceleration With FPGAs
Programmable Acceleration Cards (PACs), DCP, FPGA AI Suite, Software Stack, and Reference Designs
480 Discussions

FPGA DevCloud: aocl diagnose missing "FPGA" device

E-Hong
New Contributor I
1,083 Views

I am using Intel DevCloud from MobaXterm to access the Arria 10 GX PAC. 

I initialized the environment following the given tutorial:

https://github.com/intel/FPGA-Devcloud/tree/master/main/Devcloud_Access_Instructions#50-Connecting-to-Servers-Running-FPGA-Development-Software

 

Later, when trying "aocl diagnose", this was shown in the prompt, indicating a successful initialization: 2021-04-28 23_04_21-u72654@s005-n003_ ~.png

 

However, when running "hello_query_device.py" from OpenVino, the output shows only a CPU device:

2021-04-28 23_05_51-u72654@s005-n003_ ~.png

 

When I ran the "hello_classification.py" example with "-d FPGA" flag for inference, I keep getting this error, which I believe is due to the lack of "FPGA" under "aocl diagnose":

2021-04-28 23_24_28-u72654@s005-n003_ ~_DIR_2021Y_04M22D_01H32M20S.png

 

My question: Should it shows another "Device: FPGA" below "Device: CPU"? If yes, can anyone guide me into making it visible?

 

Thank you.

0 Kudos
2 Replies
BoonBengT_Intel
Moderator
961 Views

Hi @E-Hong,

 

Thank you for posting in Intel community forum, hope this message find you well and apologies for the delayed in response.
Please do let us know if you are still facing the difficulties mention and we would get back to you as soon as possible.

 

Best Wishes
BB

0 Kudos
BoonBengT_Intel
Moderator
936 Views

Hi @E-Hong,

 

Greetings, as we do not receive any further clarification on what is provided, we would assume challenge are resolved. Hence thread will no longer monitor this thread. For new queries, please feel free to open a new thread and we will be right with you. Pleasure having you here.

 

Best Wishes
BB

0 Kudos
Reply