Community
cancel
Showing results for 
Search instead for 
Did you mean: 
AIvan11
Novice
1,372 Views

Generating AFU for Arria 10 GX PAC

Jump to solution

Hi,

I am trying to run minimal flow for the hello sample:

$ cd $OPAE_PLATFORM_ROOT/hw/samples/hello_afu $ afu_synth_setup --source hw/rtl/filelist.txt build_synth $ cd build_synth $ $OPAE_PLATFORM_ROOT/bin/run.sh

 

from:

https://www.intel.com/content/www/us/en/programmable/documentation/bfr1522087299048.html#unm15230514...

to generate an AFU.

 

Synthesis fails with the following error. I googled it, but nothing comes up.

Error (19877): Partial reconfiguration no longer supports synthesis revisions Error: Flow failed: Error: Quartus Prime Synthesis was unsuccessful. 2 errors, 9 warnings Error: Peak virtual memory: 1279 megabytes Error: Processing ended: Wed Oct 10 14:45:57 2018 Error: Elapsed time: 00:00:08 Error (23035): Tcl error: ERROR: Error(s) found while running an executable. See report file(s) for error message(s). Message log indicates which executable was run last.   while executing "execute_module -dont_export_assignments -tool syn" (procedure "synthesize_persona_impl" line 14) invoked from within "synthesize_persona_impl $synth_rev" (procedure "compile_pr_revision" line 18) invoked from within "compile_pr_revision $options(impl)" (procedure "main" line 110) invoked from within "main" invoked from within "if {($::quartus(nameofexecutable) == "quartus") || ($::quartus(nameofexecutable) == "quartus_pro") || ($::quartus(nameofexecutable) == "qpro")} {   #..." (file "./a10_partial_reconfig/flow.tcl" line 1039)

Do you know what may be causing it? Thanks in advance.

0 Kudos
1 Solution
AIvan11
Novice
149 Views

Yes, thank you. Downgrading to 17.1 and installing the patches provided with the acceleration stack solved the error.

View solution in original post

2 Replies
JohnT_Intel
Employee
149 Views

Hi,

 

From my understanding, you are using Quartus 18.0 or later version which is causing the issue. I would recommend you to use Quartus 17.1 Pro edition in order to compile your design.​

AIvan11
Novice
150 Views

Yes, thank you. Downgrading to 17.1 and installing the patches provided with the acceleration stack solved the error.

View solution in original post

Reply