Application Acceleration With FPGAs
Programmable Acceleration Cards (PACs), DCP, DLA, Software Stack, and Reference Designs
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
426 Discussions

Problem when programming bitstream onto A10-F100

VE000
Beginner
419 Views

I am trying to program a bitstream onto Mustang A10-F100 device (IEI)

 

Have followed the steps given in https://docs.openvinotoolkit.org/2019_R3/_docs_install_guides_VisionAcceleratorFPGA_Configure_2019R1...

 

On trying to program the device with a particular bitstream,am getting the following error-

 

 

 

command -

aocl program acl0 /opt/intel/openvino/bitstreams/a10_vision_design_sg1_bitstreams/2019R3_PV_PL1_FP16_SqueezeNet_VGG.aocx

 

Error -

 

How should I debug this error?

 

 

 

0 Kudos
7 Replies
JohnT_Intel
Employee
274 Views

Hi,

 

Could you provide the error message you observed? Could you confirm if you are using SG1 or SG2 board?

VE000
Beginner
274 Views

Hi

 

Am using SG1 board

 

Error message -

 

aocl program: Running program from /opt/altera/aocl-pro-rte/aclrte-linux64/board/a10_1150_sg1/linux64/libexec

FAILED to read auto-discovery string at byte 56: Expected version is 17, found 19

Error: The currently programmed/flashed design is no longer supported in this release. Please recompile the design with the present version of the SDK and re-program/flash the board.

acl_hal_mmd.c:1461:assert failure: Failed to initialize kernel interfaceprogram: acl_hal_mmd.c:1461: l_try_device: Assertion `0' failed.

aocl program: Program failed.

 

 

JohnT_Intel
Employee
274 Views

Hi,

 

It looks like you are board flash is having older version of bitstream. You will need to reconfigure your FPGA to the latest version. Please follow the guide in https://docs.openvinotoolkit.org/latest/_docs_install_guides_VisionAcceleratorFPGA_Configure.html to program the flash with the latest bitstream so that after it will work on the latest OpenVINO.

VE000
Beginner
274 Views

Hi

 

As per your suggestion I have downloaded the 2020.1 version of openvino and tried the steps as per the document provided above.

However the problem persists

 

Error message -

 

aocl program: Running program from /opt/intel/openvino/bitstreams/a10_vision_design_sg1_bitstreams/BSP/a10_1150_sg1/linux64/libexec

Programming device: a10gx_2ddr : Intel Vision Accelerator Design with Intel Arria 10 FPGA (acla10_1150_sg10)

 OpenCL Notification Callback: Malformed program interface definition found in binary:

 OpenCL Notification Callback: FAILED to read auto-discovery string at byte 56: Expected version is 17, found 19

Error: The currently programmed/flashed design is no longer supported in this release. Please recompile the design with the present version of the SDK and re-program/flash the board.

 OpenCL Notification Callback: Invalid binary

Failed clCreateProgramWithBinary.

Error code: -42

aocl program: Program failed.

 

JohnT_Intel
Employee
274 Views

Hi,

 

The issue is that you are not updating the FPGA flash content. Please performed the step below.

 

  1. Connect USB-Blaster to the board.
  2. Run "jtagconfig" to ensure that your Intel FPGA Download Cable driver is ready to use:
  3. Go to "/opt/intel/openvino/bitstreams/a10_vision_design_sg1_bitstreams/BSP/a10_1150_sg1/bringup"
  4. Program the new sof file to the board: "quartus_pgm -c 1 -m JTAG -o "p;sg1_boardtest_2ddr_base.sof""
  5. Soft reboot:
  6. Source the environment variable script you made.
  7. source /home/<user>/init_openvino.sh
  8. Run "aocl diagnose"
  9. Go to "/opt/intel/openvino/bitstreams/a10_vision_design_sg1_bitstreams/BSP/a10_1150_sg1/bringup"
  10. Run "aocl flash acl0 sg1_boardtest_2ddr_top.aocx"
  11. Hard reboot the host system including powering off.

 

VE000
Beginner
274 Views

Hi

 

Thank you for the reply.

 

I had updated the FPGA flash content also before trying to program the bitstream. Still the problem persists.

 

 

JohnT_Intel
Employee
274 Views

Hi,

 

Do you have issue on JTAG programming? Could you provide me the step you performed before and after the CPU reboot?

Reply