Community
cancel
Showing results for 
Search instead for 
Did you mean: 
iferr4
Beginner
1,001 Views

Wince 6: network bridging issue using intel 82574L

Hi all,

 

I'm using WinCE 6.0 on a MSC COM Express board based on an Intel Atom platform (CPU: Z520PT; Chipset Intel US15W).

 

The ethernet adapter is the Intel 82574L Gigabit Ethernet Controller.

 

I'm stuck because I'm trying to set up a network bridge between the Intel controller and a PCI add-on ethernet adapter (I have tried different boards..) but I can't.

 

I can't understand if the Intel Driver for WinCE 6 (e1q51ce6.dll) supports "Network bridging".

 

Theorically, that issue should concern the registry settings:

[HKEY_LOCAL_MACHINE\Comm\MBridge]

 

"DisplayName"="Microsoft Mac Bridge Miniport"

 

"Group"="NDIS"

 

"ImagePath"="MBridge.dll"

 

;"DisableSTA"=dword:01

 

"Bind"=multi_sz:"PCI\\RTCENIC1","PCI\\E1Q51CE61"

[HKEY_LOCAL_MACHINE\Comm\MBridge\Linkage]

 

"Route"=multi_sz:"MBRIDGE1"

[HKEY_LOCAL_MACHINE\Comm\MBridge1]

 

"DisplayName"="Microsoft Mac Bridge Adapter"

 

"Group"="NDIS"

[HKEY_LOCAL_MACHINE\Comm\MBridge1\Parms]

 

"BusNumber"=dword:0

 

"BusType"=dword:0

[HKEY_LOCAL_MACHINE\Comm\MBridge1\Parms\TcpIp]

 

"EnableDHCP"=dword:1

 

"DefaultGateway"=""

 

"UseZeroBroadcast"=dword:0

 

"IpAddress"="0.0.0.0"

 

"Subnetmask"="0.0.0.0"

[HKEY_LOCAL_MACHINE\Comm\PCI\E1Q51CE61\Parms]

 

"ProtocolsToBindTo"=multi_sz:"MBRIDGE"

[HKEY_LOCAL_MACHINE\Comm\PCI\RTCENIC1\Parms]

 

"ProtocolsToBindTo"=multi_sz:"MBRIDGE"

Any ideas?

Please help me. Thanks in advance.

Tags (1)
0 Kudos
0 Replies
Reply