Community
cancel
Showing results for 
Search instead for 
Did you mean: 
JLee169
Novice
2,017 Views

[Bay trail] Bay trail HDA can not output from HDMI

Hi All

My platform is Bay trail -I E3845 D0, BIOS is coreboot + intel FSP3, test OS is WIN7.

Issue description:

on WIN7 device control manager have HDA, use HDMI interface Video have

output, but audio no, from reltek codedec alc886 connect to earphone have output.

I check code, I find FSP look like to write verbtable fail, so after fsp initial, I rewrite

verb table again its success, but HDA still no output.

below is I check result,

1. VGA ROM pass its leavage from AMI mp project.

2. verbtable pass, I rewrite.

3. HDA device is on pass.

4. i2s fail. device manager should be show correct monitor model name, but just show pnp monitor.

5. reltek codec earphone pass.

I want know

1. Intel have porting guide for HDA?

2. have other point I not yet to check?

thanks.

Best Regards

James

0 Kudos
6 Replies
Gabriel_T_Intel
Employee
76 Views

Hello James.

We are searching for a possible reason why the HDMI is not working properly.

In the meanwhile please review the http://www.intel.com/content/www/us/en/standards/high-definition-audio-specification.html High Definition Audio Specification document.

Please disable the reltek codedec acl886 and just try with the HDA in the HDMI to test.

Best Regards.

Gabriel Thomas

idata
Community Manager
76 Views

Hi James,

It looks as if the graphics driver is not installed since your HDMI monitor is not detected.

There is another audio driver that comes along with the graphic driver package which should get this setup working.

Here a link to get the driver package for both Windows 32bit & 64bit.

https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=23584 Intel® Embedded Media and Graphics Driver for Windows* 7 (build # 1064) v36.15.0 (32bit) and v37.15.0 (64bit)

Regards,

Leon

JLee169
Novice
76 Views

Hi Gabriel,

Ok,thank you.

My PC today is crash, wait my fixed done, I will try to disable reltek,and report test result to you, thanks.

Best Regard

James

 

JLee169
Novice
76 Views

Hi Leon,

update your VGA driver test result is same, the audio also no output.

and driver on setup time have get the intel hda.thanks.

Best Regards

James

idata
Community Manager
76 Views

Hi James,

We would to hear more about your issue, have you managed to find a solution?

If not please let us know so we could find further solutions.

Have a nice day!

Regards,

Leon

JLee169
Novice
76 Views

Hi Leon,

No any solution for this issue, just pending ....

 

thanks

Best Regards

James