Embedded Intel Atom® Processors
Technological Conversations about Intel Atom® Hardware, Software, Firmware, Graphics

IEGD for Ubuntu 10.04


I am very new to the embedded world, but I am trying to install Linux drivers onto an Intel Atom Processor Z530 with the US15W system controller. The Linux drivers available for this system are for very old distributions including Fedora 10 and Ubuntu 8.04.

My question is, does Intel plan on supporting more recent versions including the Ubuntu long-term release 10.04?

If not, is there a way I can hack the current drivers to work with this distro?

Finally, if the answer to my previous two questions is no, is there somewhere I can download these old Linux releases?

Any help is greatly appreciated.

0 Kudos
2 Replies

I'm currently running Ubuntu 10.10, which I believe uses Xorg server 1.9. If you grab the IEMGD drivers current release there is a unofficial support for the MeeGo 1.1 platform. Modifying the install script to treat my system as MeeGo 1.1 seemed to work as I've got 3D accelerator support for the first time since I used the old psb drivers on Ubuntu 9.4 (Maybe it was 8.10)

At any rate, while Ubuntu is not officially supported, I was able to get the MeeGo 1.1 drivers to work "out of the box". Prior to that I had built a custom 1.7.99 Xorg server and installed the MeeGo 1.0 drivers. This also required me to freeze my kernel at 2.6.33 though (There was a compatibility issue with the EMGD kernel module and the linux headers).

I've not gotten backlight controls re-enabled yet, though I can still change them at boot time with the keyboard function keys. It's a work in progress but I'm getting there. I'm hoping that I can get answers to some of my configuration questions since the java installer tool that comes with the download is very complicated.

I own an Acer 0751h, which is the GMA500 (US15W) chipset.

So long and the short of it is, if you're prepared to invest the time, try switching to the IEMGD drivers. They're probably your best bet.

Feel free to contact me if you need some assistance, and I'll see what I can do.

0 Kudos

After some private chatter, I'm going to post my modified install.sh script and current xorg.conf. I had gone from Ubuntu 10.10 stock to a custom 2.6.33 kernel and Xorg 1.7.99 server, running the MeeGo 1.0 profile. With the MeeGo 1.1 release I think I successfully reverted back to 1.9 and 2.6.35, so if this doesn't work on a clean ubuntu build please let me know and we can see about tweaking it.

In theory this should work on any linux distro that runs the 2.6.35 kernel and Xorg 1.9, though paths might have to be tweaked to get libraries and drivers in the right places. YMMV.

The only notable changes to install.sh were changing the location of lspci bin (it's not /sbin/ on Ubuntu, and running whereis lspci will help you resolve path issues), and modifying the detect distro function to just force the MeeGo 1.1 configuration.

I end up with working 3D acceleration, and video playback runs great using xine. I use the GNOME Media Player in xine mode, as VLC and GStreamer modes either don't display video or crash and burn. I'm also able to drive my display at native resolution (1366x768), and resolutions smaller than that are now scaled in hardware, so 640x480 resolution doesn't make me squint).

I don't have backlight support (but can be adjusted during boot), and suspend/resume only works once (but it never worked before, and I haven't tried it just from the command line). My SVDO (VGA) port only works properly during boot up. Probably all of my current issues are a function of improper configuration at the xorg or CED phases. I went with a conservitive initial configuration just to make sure I didn't fry anything. I'm hoping someone in the forums can help me resolve those issues (in another post).

Enjoy! And thanks, Intel, for giving us something already substantially better than the psb drivers of yore.

0 Kudos