Community
cancel
Showing results for 
Search instead for 
Did you mean: 
TMiki1
Beginner
513 Views

Ixgbe driver fails to reset on C3508 X553.

I am using Intel C3508's built-in 10GbE LAN controller with "1GBASE-T (via Marvell 1543), 1 GbE SKU" (PCI device id 0x15e5), but it fails in rare cases with the probe of ixgbe driver of Linux.

 

Please tell us if you know the reason why this failure occurs.

 

The operating system is Linux-4.14.125, using the ixgbe driver of the kernel.

 

The function of the ixgbe driver that caused an error is ixgbe_reset_hw_X550em().

 

After performing a link reset by writing 1 to LRST bit (bit 3) of Device Control Register, it seems that LRST bit does not return to 0.

 

When I displayed the variable ctrl that read the value of Device Control Register when an error occurred, it was 0xdeadbeef.

 

Is there any way to prevent the device control register value from becoming 0xdeadbeef after reset?

Should I extend the sleep time after reset or read more device control registers?

 

0 Kudos
5 Replies
CrisselleF_C_Intel
Moderator
168 Views

Hello TMiki1,

 

Thank you for posting in Intel Ethernet Communities. 

 

Please allow us to check on your query. We will get back to you within 2-3 business days. 

 

You may also consider posting a request on Embedded Intel Atom® forum to request an assistance.

https://forums.intel.com/s/topic/0TO0P00000018NFWAY/embedded-intel-atom

 

Best regards,

Crisselle C

Intel Customer Support

A Contingent Worker at Intel

CrisselleF_C_Intel
Moderator
168 Views

Hello TMiki1,

 

Thank you for the patience on this matter.

 

Upon checking, your query will be best answered by Atom Embedded Support team. We will help you move this post to the designated team.

 

You may also check with sourceforge support for further assistance since this involves ixgbe driver.

https://sourceforge.net/

 

Please let us know if there is any other assistance needed from Ethernet Support team.

 

Best regards,

Crisselle C

Intel Customer Support

A Contingent Worker at Intel

CarlosAM_INTEL
Moderator
168 Views

Hello, @TMiki1​:

 

Thank you for contacting Intel Embedded Community.

 

Could you please confirm if this thread is a duplicate of the stated in the following website?

 

https://forums.intel.com/s/question/0D50P00004PSSlZSAX/ixgbe-driver-fails-to-reset-on-c3508-x553

 

We are waiting for your clarification.

 

Best regards,

@Mæcenas_INTEL​.

 

 

TMiki1
Beginner
168 Views

Since there was a reply that it is possible to post to EmbeddedIntelAtom® forum, I posted the same sentence.

 

Should posts on intel ethernet be deleted?

 

> Thank you for posting in Intel Ethernet Communities. 

>

> Please allow us to check on your query. We will get back to you within 2-3 business days. 

>

> You may also consider posting a request on Embedded Intel Atom® forum to request an assistance.

> https://forums.intel.com/s/topic/0TO0P00000018NFWAY/embedded-intel-atom

 

https://forums.intel.com/s/question/0D70P000006RbFVSA0

CarlosAM_INTEL
Moderator
168 Views

Hello, @TMiki1​:

 

Thanks for your clarification.

 

In order to avoid duplicate efforts , please only refer to the cited thread.

 

Best regards,

@Mæcenas_INTEL​.

Reply