Community
cancel
Showing results for 
Search instead for 
Did you mean: 
MGuse1
Novice
1,654 Views

Tizen IVI on Atom E38xx (kernel configuration)

Jump to solution

Hello! I prepare kernel 3.10.28 with recomendations from https://www-ssl.intel.com/content/dam/www/public/us/en/documents/guides/tizen-ivi-m2-kernel-ltsi-lin... https://www-ssl.intel.com/content/dam/www/public/us/en/documents/guides/tizen-ivi-m2-kernel-ltsi-lin... (january 2015 revision).

1) In that guide in 3.3.1.4 "cp arch/x86/configs/byt_32_tz_emgd_defconfig .config" and make sure following item is configured to y "CONFIG_DRM_EMGD=y".

2) Next, in 3.4.4.4 process these instructions:

"-Type "make arch=i386 menuconfig".

- Go to > Device Drivers > Multimedia Supports > Intel Atom Image Signal

Processor CSS2.0 Driver (set as "M")

- Save and Exit."

In the second instructions new config file created and all emgd settings are removed. I compared byt_32_tz_emgd_defconfig and .config file after 3.4.4.4. CONFIG_DRM_EMGD string is absent in new .config file.

That config file is more correct, byt_32_tz_emgd_defconfig, or new .config after 3.4.4.4? How prepare config file with settings for emgd and ISP together?

 

Thanks for any help!

Tags (1)
0 Kudos
1 Solution
idata
Community Manager
133 Views

Hello Maks Gusev,

 

Please try "make byt_32_tz_emgd_defconfig arch=i386 menuconfig", instead of "make arch=i386 menuconfig".

This will use the default config copied to the kernel top directory "cp arch/x86/configs/byt_32_tz_emgd_defconfig .config".

Regards,

Leon

View solution in original post

4 Replies
idata
Community Manager
133 Views

Hello Maks Gusev,

Welcome back to the Intel® Embedded Community.

We are working on getting an answer to your question. Have a great day and we'll be talking with you soon!

Regards,

Leon

Gabriel_T_Intel
Employee
133 Views

Hello Maks,

We are working in your case and will contact you with additional information as soon as possible.

Thanks,

Gabriel Thomas

idata
Community Manager
134 Views

Hello Maks Gusev,

 

Please try "make byt_32_tz_emgd_defconfig arch=i386 menuconfig", instead of "make arch=i386 menuconfig".

This will use the default config copied to the kernel top directory "cp arch/x86/configs/byt_32_tz_emgd_defconfig .config".

Regards,

Leon

View solution in original post

MGuse1
Novice
133 Views

Hello, Leon.

I recompiled sources using your instructions and this problem is solved now.

Reply