Community
cancel
Showing results for 
Search instead for 
Did you mean: 
lpralf
Beginner
86 Views

How to disable auto-negotiation for X552 10 GbE Backplane (Xeon D-1500 family)?

According to IEEE 802.3 Clause 73 the use of auto-negotiation is optional for backplane assembly. Is there a way to disable auto-negotiation of the 10 GBASE-KR interface of the Xeon D-1500 family?  According to Appendix B.5.1 of document Intel® Xeon® D-1500 Processors Datasheet, Vol. 4 the link speed can indeed be determined through static configuration. Unfortunately neither windows nor linux drivers seem to support this. How can I disable auto-negotiation and manually set the link speed?

0 Kudos
4 Replies
Michael_L_Intel2
Moderator
77 Views

Hello lpralf,


Thank you for posting in Intel Ethernet Communities. 


Let me check this document and get back to you after checking it or we may route this to the correct team that can handle your inquiry.


Thank you.


Best regards,

Michael L.

Intel® Customer Support


CarlosAM_INTEL
Moderator
59 Views

Hello, @lpralf:

Thank you for contacting Intel Embedded Community.

We want to address the following questions to understand the reported situation:

Could you please let us know the versions and the procedure followed to obtain the drivers related to this situation?

Could you please let us know if the affected device is your own design or it is a third-party one? 

We are waiting for your answers to these questions.

Best regards,

@CarlosAM_INTEL.

lpralf
Beginner
32 Views

Hello @CarlosAM_INTEL

I'am using a Kontron VX3058 board running Ubuntu 20.04 with the ixgbe driver (5.9.4).
According to the README file of the driver sources (https://downloadcenter.intel.com/downloads/eula/30240/Intel-Network-Adapter-Driver-for-PCIe-Intel-10...)
auto-negotation can be enabled or disabled by the ethtool command:
ethtool -s <ethX> autoneg <on|off>

Additionally the README states:
"Depending on your device, you may not be able to change the auto-negotiation setting."

When I run the command:
ethtool -s enp3s0f0 autoneg off
I get the following error:
"Cannot set new settings: Invalid argument
Not setting autoneg"

Therefore I assume that it is not possible to disable auto-negotiation.

 

Best regards,

@lpralf 

CarlosAM_INTEL
Moderator
11 Views

Hello, @lpralf:

Thanks for your reply.

You need to address your consultation related to the cited third-party device as a reference to the channels listed on the following website:

https://www.kontron.com/about-kontron/company-overview/contact-us/forms/contact-support

Best regards,

@CarlosAM_INTEL