Embedded Intel® Core™ Processors
Intel® Core™ Hardware, Software, Firmware, Graphics
Announcements
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.
1095 Discussions

How to disable auto-negotiation of X552

raon
Beginner
857 Views

My ethernet device is "X552 10 GbE Backplane".

I need to disable auto-negotiation to link up another 10GBASE-KR device(Not ethernet switch), which is the auto-negotiation is 'off'.

The speed is needed 10000 bps.

 

My O/S is CentOS 8 and a device driver is ixgbe-5.12.5

I tried the following command but the setting is not changed.

 

        ethtool -s eth1 autoneg off speed 10000 duplex full

 

I would like to know how I can disable the auto-negotiation.

 

The follwoing is a ethtool log of my device. 

 

[root@localhost ~]# ethtool eth1
Settings for eth1:
Supported ports: [ FIBRE ]
Supported link modes: 1000baseKX/Full
                                           10000baseKR/Full
Supported pause frame use: Symmetric
Supports auto-negotiation: Yes
Supported FEC modes: Not reported
Advertised link modes: 1000baseKX/Full
                                           10000baseKR/Full
Advertised pause frame use: Symmetric
Advertised auto-negotiation: Yes
Advertised FEC modes: Not reported
Speed: Unknown!
Duplex: Unknown! (255)
Port: Other
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: umbg
Wake-on: g
Current message level: 0x00000007 (7)
drv probe link
Link detected: no

0 Kudos
7 Replies
Zigfreid_Intel
Moderator
818 Views

Hello raon,


Thank you for posting on Intel Ethernet Communities. 


We would like to Provide you some of our steps on enabling or disabling the auto-negotiation.


To enable or disable auto-negotiation:

# ethtool -s <ethX> autoneg <on|off>


Then to set the speed and auto-negotiation setting....

 

The ethtool –s command can be used to change the current settings by defining the values for “speed,” “duplex,” and “autoneg” in the following format

 

sudo ethtool –s [device_name] speed [10/100/1000] duplex [half/full] autoneg [on/off]


Example: Set the speed at 1000Mb/s, the duplex mode to ‘full’ and the auto-negotiation to ‘on’ the command would be:


sudo ethtool –s enp0s3 speed 1000 duplex full autoneg on


The ethtool [device_name] command can be used to confirm that the changes have been applied.


In case this does not work, please advise us if you are using a custom mother board for this, if not please provide us the exact model of your mother board and the processor that you using. 


If you have questions or other clarifications please let us know so we can help you further


Awaiting to hear from you soon, should there be no response from you, I’ll make sure to reach out after 3 business days. Thank you and have a nice day!



Best regards,

Zigfreid I.

Intel® Customer Support



raon
Beginner
813 Views

Hello Zigfreid,

 

Thank you for your reply.

My card is a single board computer and CPU is Xeon D-1587.

 

I tried the command with ixgbe-5.12.5 but it was failed as following. The 'autoneg' was not chagned as following.

 

[root@localhost src]# ethtool -s eth1 speed 10000 duplex full autoneg off
[root@localhost src]#
[root@localhost src]# ethtool eth1
Settings for eth1:
Supported ports: [ FIBRE ]
Supported link modes: 1000baseKX/Full
                                           10000baseKR/Full
Supported pause frame use: Symmetric
Supports auto-negotiation: Yes
Supported FEC modes: Not reported
Advertised link modes: 1000baseKX/Full
                                           10000baseKR/Full
Advertised pause frame use: Symmetric
Advertised auto-negotiation: Yes
Advertised FEC modes: Not reported
Speed: Unknown!
Duplex: Unknown! (255)
Port: Other
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: umbg
Wake-on: g
Current message level: 0x00000007 (7)
drv probe link
Link detected: no

 

Best regards,

Minseok

 

Zigfreid_Intel
Moderator
802 Views

Hello raon,


Thank you very much for advising us and for providing the information that we have asked. As per checking on your concern, this is more of a processor and board feature rather than an ethernet connectivity feature. Please allow us to route this query to the concerned team instead for proper assistance. They will get in touch with you as soon as possible.


Please feel free to contact us if you need any assistance from Ethernet support team. Thank you and have a good day!



Best regards,

Zigfreid I.

Intel® Customer Support


CarlosAM_INTEL
Moderator
783 Views

Hello, @raon:

Thank you for contacting Intel Embedded Community.

We want to address the following question to better understand the reported situation:

Could you please let us know if the design related to this situation has been developed by you or by a third-party company?

Could you please give us the information of the affected system (such as the manufacturer, part number, model, and where we can find its information)?

Could you please list the sources used to develop the affected system?

We are waiting for your clarification.

Best regards,

@CarlosAM_INTEL.

raon
Beginner
768 Views
Hello Carlos,
 
Thank you for your interest.
 
My card is SBC, VPX6-1959, of Curtiss-Wright.
I have no any special source code. The OS is CentOS 8 and I use a driver, ixgbe-5.12.5, dowloaded from Intel Download Support.
 
Best Regards,
Minseok
 
CarlosAM_INTEL
Moderator
758 Views

Hello, @raon:

Thanks for your clarification.

You should address your questions related to products manufactured by the mentioned third-party company following the procedure stated in the following website as a reference:

https://www.curtisswrightds.com/support/technical.html

Best regards,

@CarlosAM_INTEL.

raon
Beginner
751 Views
Hello Carlos,
 
Ok, Thank you.
 
Minseok
Reply