Ethernet Products
Intel® Ethernet products and technologies
4169 Discussions

Cannot update NVM on X710-DA2

klosz007
Beginner
313 Views

Hi,

 

I have recently purchased a second-hand X710-DA2 card. It has ancient 5.04 NVM on it.

Windows recognizes it as "Intel(R) Ethernet Controller X710 for 10GbE SFP+".

PCI ID is 8086 1572 and subsystem ID is 4006 8086 for first port and 0000 8086 for second port.

 

NVM upgrade tool downloaded form Intel (I tried different NVM releases, both Windows and EFI versions) says "Update not available".

 

Card was manufactured in 2020. Stickers on the card say "H89493-004" and "X710DA2BLK"

So these markings are different than on the other two X710-DA2's that I purchased some time ago (both manufactured in 2017). These two upgraded to NVM 8.50 with no issues and they have "J11367-003" / "X710DA2" labels.

 

I'm guessing it's a branded/OEM card but have no idea from which OEM and where to look for NVM upgrade package.

 

Could you help ?

 

Thanks,

Zbyszek

 

 

Output from NVM update tool:

 

Intel(R) Ethernet NVM Update Tool
NVMUpdate version 1.37.28.0
Copyright(C) 2013 - 2021 Intel Corporation.


WARNING: To avoid damage to your device, do not stop the update or reboot or power off the system during this update.
Inventory in progress. Please wait [+.........]


Num Description Ver.(hex) DevId S:B Status
=== ================================== ============ ===== ====== ==============
01) Intel(R) Ethernet Controller X710 5.04(5.04) 1572 00:005 Update not
for 10GbE SFP+ available
02) Intel(R) I211 Gigabit Network n/a(n/a) 1539 00:008 Not supported
Connection


Tool execution completed with the following status: Device not found.
Press any key to exit.

 

 

0 Kudos
1 Reply
klosz007
Beginner
283 Views

I eventually resolved this myself by multiple download/ upgrade trial and error attempts. This mysterious "H89493-004" / "X710DA2BLK" X710-DA2 card is made by Intel for Lenovo.

I was able to update NVM to 8.40 using updater downloaded from Lenovo site (they do not have NVM updater to 8.50 yet).

 

Thanks,

Zbyszek

Reply