Ethernet Products
Intel® Ethernet products and technologies
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.
4255 Discussions

E810-XXVDA4 causes PC (i5-12400 + B660) to freeze after the BIOS screen



I am building a small-form-factor PC that needs a few high-speed optical network connections. The components are:

  • CPU: Intel i5-12400
  • NIC: Intel E810-XXVDA4 - 4xSFP28 (16 x PICe4)
  • MB: Asus Rog Strix B660-i Gaming Wifi
  • RAM: 2x16GB Corsair Vengeance DDR5-5600
  • PSU: 350W Silverstone FX350-G
  • SSD: Samsung 980 Pro 2TB M.2 connected in the front-slot.
  • OS: Ubuntu 21.10 with the latest mainline kernel: 5.16.2

Note that I am using the integrated graphics in the CPU. The motherboard has a single PICe x 16 slot and that is supposed to be used by the NIC.

The problem:
If the NIC is inserted into the PCIe slot, the PC freezes immediately after the BIOS screen. Accessing the BIOS works fine and inside the BIOS menus I do see that the NIC is correctly recognized and I can even configure some options for it. However, as soon as I leave the BIOS and try to continue to boot I get a black screen. As far as I can tell, the loading doesn't even attempt to boot the OS. I have configured GRUB to always show the GRUB menu on boot, but even it doesn't show up when the NIC is inserted into the slot. It seems the computer is completely frozen before even GRUB is started. In case it matters, I'm talking about an EFI boot, not the legacy mode.

Things I've tried to no avail:

  • Looked into various logs in /var/logs. There's absolutely no trace that there was a boot attempt. It really seems that the failure happens immediately after BIOS, before any OS- or GRUB-related code is executed.
  • Updated to the latest BIOS (1009) on the B660 motherboard.
  • Forced the BIOS to always use the CPU graphics, just in case it's confused by something else being in the x16 slot.
  • Forced the PCI to use Gen4 instead of automatically detecting the version.
  • Removed the Intel NIC. The computer boots normally into the OS and everything is working perfectly. As expected, the GRUB menu is always shown before the OS loads.
  • Tried a different NIC (based on Mellanox Connectx-4) - the PC booted normally into the OS.
  • Tried the Intel NIC in a different system (AMD 3950X + X570 Chipset + Ubuntu). That system booted fine into the OS and correctly recognized the card. Everything worked as expected.
  • Updated the Intel NIC to the latest firmware (3.10), while it was in the AMD system. The firmware update was successful but didn't help. When I inserted the card into the Intel system after the update that system still froze after BIOS.

It seems that the PC is somehow incompatible with the NIC. Any ideas about what the issue might be or how to go about diagnosing the problem will be much appreciated.


Labels (1)
0 Kudos
4 Replies

Hello MitkoA,

Thank you for posting on Intel Ethernet Communities. 

We are now carefully reviewing your case, please provide us some time to have this check before we provide you any of our recommendations. 

Also can we ask for you to provide us a photo of the markings of your NIC both front and back so we can validate your adapter if its a genuine intel or an OEM adapter. Please refer to the link below.

Can we also ask for you to provide us your SSU (System Support Utility) log so we can try to check for any errors and unusual behavior of your system if its still possible.

Please follow the steps on how to extract the SSU log

1. Download the Intel® System Support Utility and save the application to your system.

2. Open the application and click Scan to see system and device information. The Intel® System Support Utility defaults to the Summary View on the output screen following the scan. Click the menu where it says summary to change to Detailed View.

3. To save your scan, click Next and click Save. You can save the file to any accessible location on your computer.

Note: Please put a tick on "Everything" when extracting the log.

4. You can attach the log file on this thread. 

If you have questions or other clarifications please let us know so we can help you further

Awaiting to hear from you soon, should there be no response from you, I’ll make sure to reach out after 3 business days. Thank you and have a nice day!

Best regards,

Zigfreid I.

Intel® Customer Support


Hi Zigfreid,


Thanks for investigating the issue. I attached the info you requested. Please note:

  • The card is indeed a genuine Intel card, not an OEM one.
  • The computer in question only has Ubuntu installed, so I used the Linux version of the System Support Utility.
  • Since I can't boot with the E810-XXVDA4 NIC inserted, the tool report doesn't have an entry for that card. Only Intel cards that are part of the chipset are included.

In the meantime, I tried a few more things, but still no luck:

  • I tried disabling native ASPM in the BIOS.
  • I tried launching the UEFI Shell from the BIOS menu. This also doesn't work. The instant I click on the entry for launching the UEFI shell, the computer freezes (still displaying the image of the last BIOS screen, but no input works anymore).

Please let me know if there is any further information that you need, happy to provide whatever I can.




Hello MitkoA,

Firstly, thank you for providing us the information that we have asked. After a series of verification, we found out that this request is already a duplicate with case 05358423 that is now being handled by our local support group.

We do apologize for any inconvenience but in order to avoid any duplication and confusion, please use the case 05358423 moving forward and we will now close this case. Thank you for your understanding and we hope you have a good day!

Best regards,

Zigfreid I.

Intel® Customer Support


Hi Zigfreid,


Thank you for your message. I thought that the duplicate case 05358423 that you mentioned is my post on the intel support reddit thread. However, I was just told on that thread that I should get support on the Intel community forums:

Perfect, our Intel Community Forums support will be able to further assist you on this topic in a more detailed manner since additional documentation/reports might be needed or provided.

Could you please clarify where I'm supposed to get support on this issue?


Thanks and have a nice day.