Community
cancel
Showing results for 
Search instead for 
Did you mean: 
SKing3
Beginner
4,883 Views

I217-V No connection with 100 full duplex setting

We've just started deploying some new PCs that have the intel i217v ethernet controller and there has been an intermittent problem where if the interface is set to 100mb full duplex it will drop the connection and windows will say the network cable is unplugged. Changing some of the advanced settings (ie. interrupt moderation, interrupt moderation rate, efficient ethernet etc) will sometimes resolve the problem temporarily. Changing the speed back to Auto will fix the problem however this is not ideal for our network where the switch ports are set to 100 full rather than auto (no this cannot be changed).

The drivers are up to date and I have tried it with and without the extras that come with the drive

0 Kudos
10 Replies
SChun12
Beginner
134 Views

It happened to me too but still no solution.

DPetr8
Beginner
134 Views

I'm experiencing same problem. I have Intel I217-V NIC on my Asus Maximus VI Hero. Unfortunately, only stable setting is 10 Mb/s (full duplex/half dupex). In my case 100 Mb/s causes unplugging and reconnecting of the NIC. It's unusable. 1 Gb/s full dupex doesn't seems to work at all. We have to have something in common in our HW/SW configuration. I haven't found much topics dealing with this issue, so I think there cloud be some silly setting which causes troubles.

DPetr8
Beginner
134 Views

I was able to partially fix this problem. I found out that NIC has problem only while it's connected to my ASUS RT-G32 router. I inserted between PC and router extra switch (also from ASUS) and link was absolutely stable on 100 Mb/s full-dupex. So the problem appears only on particular combination of HW. It's not a complete solution but I hope it helps.

SChun12
Beginner
134 Views

In my case NIC is connected to my iPtime N704s router and it never connect with 100 full duplex. I've tried to fix this problem ton of times but still no solution. If NIC links directly to my PC not router, yes It works.

TVlie
Beginner
134 Views

Same problem here.....

FMeng2
Beginner
134 Views

A similar issue is happening to me...

If i set te connection on 100mbps full duplex, or lower connection type, all work flawlessy. in auto mode or Gigabit the connection doesn't work with the cable disconnected status. after a couple of minute with doing nothing the connection begin to work. Sometimes Enter in the configuration dialog of the NIC work too.

The issue seems connected to the cable sensibility of the NIC, because trying all the cable in my house I found one that work in GIGAbit with no problem. The other cable i've tried, the selfmade too, work in gigabit with no problem with the other Motherboard NIC.

The cable Test in the NIC properties report all the cable, the working too, poor cable, seems that intel have high standard...

Hope this help

Bye!!

MDahl
Beginner
134 Views

I too have problem with a i217-v on a ASUS Z87 Expert MB. It will not work at higher that 100 Mb/s. I have the latest driver (dec 2013).

MDahl
Beginner
134 Views

Solved the problem. It was a bad patch cable for me.

ASpar
Novice
134 Views

Was this every fixed properly? We have latest drivers from intel, but can get 100mb/Full working. Our switches are hard set to 100mb/full but the PCs (HP EliteDesk 800s) are reporting 100mb/half and we get collisions. They report half even when we hard set the nic to full

ASpar
Novice
134 Views

We found a solution to our issue with the i217-lm, assume it would be similar to the -v so worth a try.

Regardless of whether we set the NIC to 100mb/full, it still tried to auto neg and neg and 100mb/half, despite switch set to 100mb/full and not to auto neg.

To fix, search the registry for the key LinkNegotiationProcess, and set it to 2.

In our case there were 3 instances that need changing.

The default setting is 1, which is to auto negotiate. 2 is forced. This has solved the problem on all our HP EliteDesk 800s.

Reg keys if anyone is interested, for our Intel i217-LM NIC:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4D36E972-E325-11CE-BFC1-08002BE10318}\0007]

"LinkNegotiationProcess"="2"

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Control\Class\{4D36E972-E325-11CE-BFC1-08002BE10318}\0007]

"LinkNegotiationProcess"="2"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002BE10318}\0007]

"LinkNegotiationProcess"="2"