Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
1,272 Views

Problem setting rx ring size using ixgbe on vSphere ESXi 5.1

I have a high throughput UDP application running on vSphere 5.1 and I am dropping packets due to rx_dma_no_resources (ethtool -S vmnic4). I have attempted to change the rx ring buffer size to 4096, but no matter what I do the highest I can seem to get is 456 (according to ethtool -G). Ethtool says the highest supported value is 4096, so does anyone know how I can increase the ring buffer size to that amount? I am using driver 3.1.32.

Thanks!

Tags (1)
0 Kudos
2 Replies
Highlighted
20 Views

The version of the driver you have is a bit dated. I would try the latest which available from VMware at:

http://www.vmware.com/resources/compatibility/detail.php?deviceCategory=io&productid=12665&deviceCat... - IO Devices&page=1&display_interval=10&sortColumn=Partner&sortOrder=Asc http://www.vmware.com/resources/compatibility/detail.php?deviceCategory=io&productid=12665&deviceCat... - IO Devices&page=1&display_interval=10&sortColumn=Partner&sortOrder=Asc - IO Devices&page=1&display_interval=10&sortColumn=Partner&sortOrder=Asc

If this still does not work, I am afraid you will need to open a customer case with VMware, they actually own this driver. If in turn VMware needs Intel's assistance, they will contact us.

Best of luck,

Patrick

0 Kudos
Highlighted
Beginner
20 Views

Updating to the latest driver worked and allowed me to tune the ring size. I was using the driver that came with an HP custom image. Thanks for your help!

0 Kudos