Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
164 Views

Intel Ethernet Adapter i219-v (Code 10)

Hi guys,

 

I have an MSI MPG Z390 Gaming Edge AC motherboard and I'm having some trouble with my ethernet adapter. It was working fine up until about 3 days ago when all of a sudden stopped working - at first, it appeared to be connected to an "unidentified network" before completely disappearing from my list of adapters in network settings.

 

Now, in the device manager I have the caution triangle on the adapter and it's giving me a "Code 10 - device cannot start" the oem9.inf can't start, leading to the e1dexpress service not working??

 

I've tried the following;

 

  • Disabling and re-enable the controller
  • Reinstalling drivers
  • Downloading drivers from both intel website and MSI website
  • Power cycling my PC
  • Updated windows and BIOS to latest versions
  • Clean install of windows

A good point to note, my motherboard is only about a month old, I'm finding it hard ot believe that it is a hardware issue but I could be wrong.

 

I downloaded a 3rd party driver software and next to my ethernet adapter, it has the "repair" option. Also, in the I/O panel, the yellow light is on when the cable is in, which according to the manual means its linked, so the adapter has power going to it and is functional I'm assuming?? But I'm at a standstill here I'm completely clueless on what to do. I've tried pretty much all the Code 10 fixes online, nothing has worked.

 

Any help is appreciated.

 

Kind regards,

Greg

0 Kudos
9 Replies
Highlighted
Honored Contributor III
60 Views

Re: Intel Ethernet Adapter i219-v (Code 10)

It always boggles my mind when I hear people say 'it's new, it must work'. This is far from reality. Some of these ODMs do a full test of like one unit in a hundred. The rest get a quick spotcheck and out the door they go. This is why they have the no-questions-asked replacement policies - because they know there are going to be failures and DOAs.

 

Ok, all that said, I don't think that this is the case this time. I am seeing way, way too many Code 10 reports in the past few weeks (and especially since the release of Windows 10 2004). It may be that Intel's drivers have a problem and we will need to wait for a new release to get it resolved. In your case, this happened suddenly - three days ago? Hhmmm, that would line up with the Tuesday updates on Windows Update.

 

Have you tried doing a from-scratch reinstall? Here's the process:

 

  1. If you haven't already, download - but do not install just yet - the latest driver package. Here is a link: https://downloadcenter.intel.com/download/22283/Intel-Ethernet-Adapter-Complete-Driver-Pack?product=....
  2. Disable Internet access. Unplug Ethernet cable and/or disable wireless. Keep disabled until told to re-enable.
  3. From Apps & Features app, uninstall any instances of the Intel Network Connections package.
  4. Manually shutdown and reboot your computer.
  5. In Device Manager > Network Adapters, check for entry for Ethernet or Network Connections device(s). If no entries there, go to Step 8.
  6. Right click on the entry for each Ethernet or Network Connections device and uninstall it., choosing to "Delete the driver software for this device".
  7. Go to Step 4.
  8. (Optional but recommended) Clear out your temporary files using the Windows Clean Disk tool.
  9. Install the driver package downloaded in step one.
  10. Manually shutdown and reboot your computer.
  11. Enable Internet access.
  12. Test.

 

Hope this helps,

...S

0 Kudos
Highlighted
Beginner
60 Views

Re: Intel Ethernet Adapter i219-v (Code 10)

Hi Scott,

 

Thanks for the reply.

 

Just done those steps you listed there and it hasn't worked.

This was also after a clean install of windows which I done last night. I've almost given up hope really to be honest it's either the latest version of Windows has screwed it up or its a hardware issue.

 

I've contacted the MSI forums and support site for a possible custom solution and waiting on an answer but it doesn't look too hopeful at the moment.

 

These are the issues event viewer is giving.

https://i.gyazo.com/aceae50349a748c61ae43cc0ab6e20c7.png

https://i.gyazo.com/7108de73fa0821a84381a5169b25407c.png

 

Regards,

Greg

0 Kudos
Highlighted
Honored Contributor III
60 Views

Re: Intel Ethernet Adapter i219-v (Code 10)

Do you have latest BIOS for your board installed?

Did your system get updated to Windows 10 2004 (build 19041)?

...S

0 Kudos
Highlighted
Beginner
60 Views

Re: Intel Ethernet Adapter i219-v (Code 10)

My BIOS is to the latest version.

 

With regards Windows, I actually don't I just checked. I'm getting this in the update page. I'm not entirely sure why it won't let me download from there as the Microsoft site says its compatible for Windows 1909 which is what I'm running.

 

https://i.gyazo.com/412a98562c26ec5adeb3710fc3c1f28c.png

 

I'm now downloading the update manually via the update assistant to update to 2004.

 

Hopefully this will fix the issue

0 Kudos
Highlighted
Beginner
60 Views

Re: Intel Ethernet Adapter i219-v (Code 10)

Just updated to the latest version of windows, 2004 build 19041.329 and it hasn't fixed my issue..

 

0 Kudos
Highlighted
60 Views

Re: Intel Ethernet Adapter i219-v (Code 10)

 

Hello GClif1,

 

Thank you for posting in Intel Ethernet Communities. 

 

Please allow us to check on your request. Rest assured that we will give an update as soon as possible but no later than 1-3 business days.

 

Hoping for your kind patience.

 

Best regards,

Crisselle C

Intel® Customer Support

0 Kudos
Highlighted
60 Views

Re: Intel Ethernet Adapter i219-v (Code 10)

Hello GClif1,

 

Good day!

 

We hope you don't mind providing the following information that would help us in checking your query.  

 

1.) Is there any hardware or software changes prior to the issue?

2.) You mentioned that you've contacted MSI forums and support site, can you share if you already hear from them? If yes, kindly share it with us.

3.) Please provide the System Support Utility log of your system. This will allow us to check your Adapter details and configuration. Kindly refer to the steps below.

a- Go to https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows-?product=91...

b- Open SSU.exe

c- Mark the box "Everything" and then click "Scan".

d- When finished scanning, click "Next".

e- Click on "Save" and attach the file to a post.

 

We look forward to your reply.

 

Should there be no response, we will follow up after 3 business days.

 

Best regards,

Crisselle C

Intel® Customer Support

0 Kudos
Highlighted
60 Views

Re: Intel Ethernet Adapter i219-v (Code 10)

Hello GClif1,

 

How are you today?

 

We'd like to follow up the additional information that we requested for us to further investigate the issue.

 

Awaiting to hear from you.

 

I’ll make sure to follow up after 3 business days in case we don't receive a reply.

 

Best regards,

Crisselle C

Intel® Customer Support

0 Kudos
Highlighted
26 Views

Re:Intel Ethernet Adapter i219-v (Code 10)

Hello GClif1,


Good day! 


Please be informed that we will now close this request since we haven't received any response from our previous follow ups. Just feel free to post a new question if you may have any other inquiry in the future.


Best regards,

Crisselle C

Intel® Customer Support


0 Kudos